64 bits guests are not allowed

Discussions related to using VirtualBox on Linux hosts.

64 bits guests are not allowed

Postby fierabras66 » 27. Apr 2009, 00:47

Hi. I am an Ubuntu 9.04 64 bits user.
I did installed VirtualBox from the repositories an AFAIK it should support 64 bits guests, but it doesn't.
I did allowed the virtualization in bios setup, virtualbox kernel modules are operating and the system kernel support virtualization is configured as required.
My system is and Phenom Quad with 16 Gb., and my question is if the Virtual Box version installed from the repositories supports 64 guests.

Thx.
fierabras66
 
Posts: 4
Joined: 27. Apr 2009, 00:37
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: opensuse

Re: 64 bits guests are not allowed

Postby Perryg » 27. Apr 2009, 01:27

Version 2.2.0 has it all in one download.
Previous versions you had to download the 64 bit version or the 32 bit version separately.

On some PCs the CPU might be 64 bit and the Motherboard does not truly support it, or the Bios does but needs to be updated.
So contacting the manufacture may be needed to be needed to determine the truth.
For VirtualBox to be able to use the 64 bit option it must have VT-x/AMD-V turned on in the bios.
Perryg
Site Moderator
 
Posts: 25923
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: 64 bits guests are not allowed

Postby fierabras66 » 27. Apr 2009, 17:57

Thanks for your answer Perryg.

I'm beginning to suspect that motherboard is not fully allowing virtualization, but the system work in 64 bits mode.

But, I need a confirmation on VBOX 64 bits guests virtualization capability for the repositories 2.2 versión. Thx.
fierabras66
 
Posts: 4
Joined: 27. Apr 2009, 00:37
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: opensuse

Re: 64 bits guests are not allowed

Postby grayeul » 28. Apr 2009, 15:33

I am having a similar problem. I have a new Dell E6500 laptop, which seems to be supporting 64-bit fine. I have enabled the Virtualization in the BIOS and I have turned on:
VT-x/AMD-V, Nested Paging, and PAE/NX in the General machine settings.

But, when I try to boot up a 64-bit ISO I get a warning that my CPU is only 32-bits.
I'm running the standard virtualbox-ose package from Ubuntu 9.04 (Jaunty Jackalope),
which seems to be version 2.1.4_OSE

Is there anything else I can check to see that I'm fully 64-bit enabled? I know this isn't the newest vbox, but
thought it should still work.
grayeul
 
Posts: 4
Joined: 28. Apr 2009, 15:26
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: WinXP, Linux

Re: 64 bits guests are not allowed

Postby Sasquatch » 28. Apr 2009, 15:36

Check the manual and VirtualBox FAQ. They both say to check these things:
    BIOS
    CPU
    VM Settings
    Other Virtualizers that might use hardware virtualization
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: 64 bits guests are not allowed

Postby grayeul » 28. Apr 2009, 17:10

As I stated in my original post,
    I have enabled the appropriate Virtualization settings in the BIOS
    My CPU is 64-bit (Intel Core 2 Duo - P8600)
    I turned on the VT-x, AMD-V setting for the VM

I'm not sure what "Other Virtualizers" refers to. Didn't see that in the FAQ. Are you talking about using VMWare instead?

My question was for anything *else* I might have missed, or possible confirmation that it should work with the above settings.
Can anyone confirm running a 64-bit guest OS on this hardware?

Sasquatch wrote:Check the manual and VirtualBox FAQ. They both say to check these things:
    BIOS
    CPU
    VM Settings
    Other Virtualizers that might use hardware virtualization
grayeul
 
Posts: 4
Joined: 28. Apr 2009, 15:26
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: WinXP, Linux

Re: 64 bits guests are not allowed

Postby Perryg » 28. Apr 2009, 17:15

Just a thought here.
You could contact your system provider and ask them if the unit you actually have will work with a 64 bit visualizer.
Might be more definitive than what anyone will tell you.
Perryg
Site Moderator
 
Posts: 25923
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: 64 bits guests are not allowed

Postby Sasquatch » 28. Apr 2009, 17:22

On some Intel boards, the BIOS setting is the reverse of what it says. Turning it ON actually turns it OFF. You wouldn't be the first.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: 64 bits guests are not allowed

Postby grayeul » 28. Apr 2009, 18:06

I tried with the BIOS settings both ways on the Dell E6500.... since I can't get it to work either way, I can't say for sure which setting is really *on*.

According to: http://ark.intel.com/cpu.aspx?groupId=35568
The P8600 has Intel Virtualization and is 64-bit.
grayeul
 
Posts: 4
Joined: 28. Apr 2009, 15:26
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: WinXP, Linux

Re: 64 bits guests are not allowed

Postby Perryg » 28. Apr 2009, 18:17

My friend, that is your CPU. My CPU is also supposed to work but come to find out my motherboard does not support it to the point that it will actually work. That's why I suggested that you contact Dell and ask them straight up will this work? While you have support they can tell you what if anything else you will need to do. Puts the ball in their court so to say. Of course this is only a suggestion, but that is where I would go. I have had Dell computers and they do not always work like I wanted them to or as they stated when purchasing.
Perryg
Site Moderator
 
Posts: 25923
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: 64 bits guests are not allowed

Postby Sasquatch » 28. Apr 2009, 19:21

Since this is done on a Linux Host, check /proc/cpuinfo, there should be VMX or SVM in the flags. If it's not, then you don't have VT-x/AMD-v.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: 64 bits guests are not allowed

Postby grayeul » 28. Apr 2009, 20:18

yep, I did that.. I have the vmx flag in /proc/cpuinfo.

However, that flag is on whether or not the BIOS setting for Virtualization is enabled.

SOLVED! -- The Dell E6500 BIOS has three settings for Virtualization Support:
Virtualization -- Enable Intel Virtualization Technology -- on
VT for Direct I/O -- Enable VT for Direct I/O -- on
Trusted Execution -- "specifies whether a Measured Virtual Machine Monitor (MVMM) can utilize the additional hardware capabilities provided by Intel Trusted Execution Technology. The TPM, Virtualization Technology, and Virtualization Technology for Direct I/O must be enabled to use this feature" -- off

If I turn on the Trusted Execution flag, then I get the virtualbox warnings about only having a 32-bit architecture. With it off, things seem to work OK. This was unexpected behavior to me.... I have the TPM stuff turned off in the Security portion of the BIOS. I would have expected this to effectively be a don't care..... guess not. If I ever get around to messing with TPM, maybe I'll try it :-)
grayeul
 
Posts: 4
Joined: 28. Apr 2009, 15:26
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: WinXP, Linux


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 13 guests

cron