no audio driver on Windows 7 (64bit) guest

Discussions related to using VirtualBox on Linux hosts.

no audio driver on Windows 7 (64bit) guest

Postby GuinnessTrinker » 24. Jan 2009, 19:01

Host: Ubuntu 8.10 (64Bit)
virtualBox 2.1.2
guest Windows 7 (64bit)

installation: no problem

"geräteerweiterungen installieren": no problem

audio device driver on virtualbox: pulse audio / ICH AC97

windows 7 device manager: audiocontroller for multimedia


error: driver not found :?:
GuinnessTrinker
 
Posts: 5
Joined: 24. Jan 2009, 18:52
Location: Germany

Postby stefan.becker » 24. Jan 2009, 19:23

Search Forum vor "Vista realtek".
stefan.becker
Volunteer
 
Posts: 7046
Joined: 7. Jun 2007, 21:53

Postby Sasquatch » 24. Jan 2009, 20:23

Did you check the Windows Update site from Windows 7? It should provide you with the driver.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby GuinnessTrinker » 24. Jan 2009, 20:44

Sasquatch wrote:Did you check the Windows Update site from Windows 7? It should provide you with the driver.


yes. no success.
GuinnessTrinker
 
Posts: 5
Joined: 24. Jan 2009, 18:52
Location: Germany

Postby GuinnessTrinker » 24. Jan 2009, 22:26

stefan.becker wrote:Search Forum vor "Vista realtek".


my system has a
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

not a realtec

do you really think a realtec driver could help?
GuinnessTrinker
 
Posts: 5
Joined: 24. Jan 2009, 18:52
Location: Germany

Postby stefan.becker » 24. Jan 2009, 23:16

Doesnt interest what hardware the host has.

In the guest you need a realtek audio codec.

But first try to disable audio, then restart, then enable again. It should be found by windows update. If not: http://www.start64.com/index.php?option ... Itemid=108
stefan.becker
Volunteer
 
Posts: 7046
Joined: 7. Jun 2007, 21:53

Postby GuinnessTrinker » 25. Jan 2009, 00:09

stefan.becker wrote:Doesnt interest what hardware the host has.

In the guest you need a realtek audio codec.

But first try to disable audio, then restart, then enable again. It should be found by windows update. If not: http://www.start64.com/index.php?option ... Itemid=108

Your link is broken. Other links at realte are (very) slow.
I used this. Its the latest driver:

http://www.download3k.com/Install-Realt ... river.html

It works!!
Thanks a lot for that hint.

Klaus
GuinnessTrinker
 
Posts: 5
Joined: 24. Jan 2009, 18:52
Location: Germany

Postby Sasquatch » 25. Jan 2009, 01:08

Link works for me, and is fast.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: no audio driver on Windows 7 (64bit) guest

Postby Sani9000 » 2. May 2009, 16:04

That hint was really useful. Many thanks!

Greets, Martin
Sani9000
 
Posts: 1
Joined: 2. May 2009, 16:00
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows Vista 64 Bit

Re: no audio driver on Windows 7 (64bit) guest

Postby nicpac22 » 10. Jun 2009, 04:06

So, I've now read several posts on both this forum and others on getting audio to work in Windows 7 as a guest OS but I still can't seem to get mine working. I'm running Fedora 10 as the host (64-bit) and Windows 7 RC as the guest OS also 64-bit in VBox 2.2.4. Network, graphics, everything else works fine, but for some reason windows cannot find my audio device. I have updated to the latest Realtek HD drivers, I have tried every combination of ALSA, Pulseaudio, etc. with AC97 and SB16, with no luck (yes, I made sure the enable audio checkbox is checked). No matter what, in windows device manager for my audio device, I get:

The device cannot start. (Code 10)

I have enabled, disabled the audio device, restarted the VM, uninstalled and reinstalled the drivers, to no avail. At this point, any advice would be greatly appreciated.

Thanks,

Nick
nicpac22
 
Posts: 5
Joined: 10. Jun 2009, 03:58
Primary OS: Fedora 10
VBox Version: OSE Fedora
Guest OSses: Windows 7 RC

Re: no audio driver on Windows 7 (64bit) guest

Postby nicpac22 » 13. Jun 2009, 17:34

Bump. Anyone? I'm fairly certain this has something to do with another process not allowing VBox to access the soundcard, but I can't seem to find it...
nicpac22
 
Posts: 5
Joined: 10. Jun 2009, 03:58
Primary OS: Fedora 10
VBox Version: OSE Fedora
Guest OSses: Windows 7 RC

Re: no audio driver on Windows 7 (64bit) guest

Postby Perryg » 13. Jun 2009, 17:47

@nicpac22,

Have you used the Windows update to install the drivers for you? When you open Windows update it may say that you are up to date but you need to tell it to check for updates anyway before it will check for drivers. Also it may show them as additional updates instead of Windows needed updates and you will need to put a check mark in to actually get the drivers. Use the AC97 sound for Windows 7.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: no audio driver on Windows 7 (64bit) guest

Postby scottro » 17. Jun 2009, 18:00

@Guiness---that site worked well for me too, thank you. It said Vista driver, but works on Win 7 RC as well.
scottro
 
Posts: 20
Joined: 6. May 2008, 01:30

Re: no audio driver on Windows 7 (64bit) guest

Postby billcondie » 22. Aug 2009, 21:27

I finally got it to work after days of frustration

In Audio settings I chose ALSA with ICH AC97

Went to Windows 7 updates -- and bingo!

Now I've got MovieMaker 2.6 working great and the days of a dual boot are numbered.
billcondie
 
Posts: 13
Joined: 1. Feb 2009, 00:37

Re: no audio driver on Windows 7 (64bit) guest

Postby Sasquatch » 23. Aug 2009, 00:05

Nicpac,

Remove the device from device manager, reboot the machine and it should install the driver properly now.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 14 guests