Page 1 of 2

ksoftirqd Using 20-25% of CPU with only GUI running

PostPosted: 10. Aug 2007, 18:18
by poet_imp
When I start VirtualBox, before I even think of starting a virtual machine, I look at system utilization and notice ksoftirqd using a very significant portion of my box; usually 20-25%.

Here is what I see in top:

Code: Select all   Expand viewCollapse view
    7 root      15  -5     0    0    0 S   21  0.0   0:11.80 ksoftirqd/1

Is this a known issue? Is there something I can do to make it not do this?

$ uname -a
Linux #1 SMP Fri Jul 27 18:10:34 EDT 2007 i686 i686 i386 GNU/Linux

$ rpm -qa | grep -i virt

$ sudo /usr/bin/smoltSendProfile
Platform: i686
BogoMIPS: 6403.40
CPU Vendor: GenuineIntel
CPU Model: Intel(R) Pentium(R) 4 CPU 3.20GHz
Number of CPUs: 2
CPU Speed: 3199
System Memory: 2026
System Swap: 1983
Vendor: BUYMPC
Form factor: unknown

Am I the only one?

PostPosted: 13. Aug 2007, 23:29
by poet_imp
Interesting... I was hoping for at least a "I am noticing the same things... " post. Am I the only one seeing this?

PostPosted: 20. Aug 2007, 00:07
by vor
I was seeing this too using a 2.6.22 kernel and VirtualBox from svn. Just starting the VirtualBox gui was causing the problem even if no VM's were running. Getting the latest bits from svn today made the problem go away so it would seem the problem will be fixed with the new version of VirtualBox.

PostPosted: 20. Aug 2007, 00:11
by vor
Actually, I take that back. It appeared to be fixed but then I realized I didn't have the kernel module loaded. Once the kernel module is loaded, it still uses the 20% CPU while idle even with the latest bits from svn.

PostPosted: 20. Aug 2007, 00:48
by c0nv1ct
Same issue here, seems to have started around the time i upgraded my kernel to 2.6.22. I get 2 processes, ksoftirqd/0 and ksoftirqd/1, both using 10-20% cpu. I'm using vbox 1.4.0 though, havent tried svn version yet.

PostPosted: 4. Sep 2007, 01:02
by c0nv1ct
Problem still exists in 1.5.0 OSE :(

PostPosted: 6. Sep 2007, 22:34
by frank
Please could you attach your kernel configuration?



PostPosted: 10. Sep 2007, 11:32
by frank
Please could you try to boot with the

Linux kernel command line parameter?

PostPosted: 10. Sep 2007, 18:58
by nc42
What does nohz=no do? It seems to work

PostPosted: 11. Sep 2007, 09:48
by frank
This option prevents the host Linux to enter the tickless mode. In this mode the kernel timer is programmed in one-shot mode, contrary to the periodic mode which is normally used. VirtualBox currently does not play well with host kernels in one-shot mode. We are working on a solution. Until we fixed it, use this option to restore the old behavior.

Kubuntu 7.10 gutsy

PostPosted: 9. Nov 2007, 12:03
by thripsi
I had the same problem with ksoftirqd on (k)ubuntu 7.10
(linux 2.6.22-14-generic, VirtualBox 1.5.0 OSE).
The boot option "nohz=off" did solve the problem .

PostPosted: 9. Jan 2008, 21:39
by Pépou
Frank Mehnert wrote:Please could you try to boot with the

Linux kernel command line parameter?

Sorry but I've got the CPU problem too. Where can we change the kernel configuration ??

Thank you. My guest is ubuntu gusty.

PostPosted: 10. Jan 2008, 14:59
by frank
The guest is not relevant, only the host in that case.

PostPosted: 11. Jan 2008, 11:30
by Pépou
Sorry I confused myself. My host is ubuntu gusty, and my guest is windows XP.. So I need to do this modification !

Thank you in advance for your help.

PostPosted: 11. Jan 2008, 19:47
by Ingo
In / boot/grub/menu.list for bootloader grub or in /etc/lilo.conf for bootloader lilo.