VirtualBox-6.1 on Fedora 36 - Installation failed

Discussions related to using VirtualBox on Linux hosts.

VirtualBox-6.1 on Fedora 36 - Installation failed

Postby Tomle » 18. Jun 2022, 05:34

Hi there,

I've just upgraded to Fedora 36 from F35 today. Everything seems to be fine except I can't seem to be able to install VirtualBox-6.1-6.1.34_150636_fedora36-2.x86_64.rpm on it.

In the /var/log/vbox-setup.log, these are the last few lines. Can someone help shed some light please? Thank you.

{ echo ; echo '/tmp/vbox.0/VBoxNetFlt.o: $(wildcard ./tools/objtool/objtool)' ; } >> /tmp/vbox.0/.VBoxNetFlt.o.cmd
/tmp/vbox.0/linux/VBoxNetFlt-linux.c: In function ‘vboxNetFltPortOsXmit’:
/tmp/vbox.0/linux/VBoxNetFlt-linux.c:2314:23: error: implicit declaration of function ‘netif_rx_ni’; did you mean ‘netif_rx’? [-Werror=implicit-function-declaration]
2314 | err = netif_rx_ni(pBuf);
| ^~~~~~~~~~~
| netif_rx
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:288: /tmp/vbox.0/linux/VBoxNetFlt-linux.o] Error 1
make[1]: *** [Makefile:1838: /tmp/vbox.0] Error 2
make: *** [/tmp/vbox.0/Makefile-footer.gmk:117: vboxnetflt] Error 2
(END)
Tomle
 
Posts: 3
Joined: 18. Jun 2022, 05:27

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby birdie » 18. Jun 2022, 10:29

Please use the latest test build from https://www.virtualbox.org/wiki/Testbuilds - download the "Linux 64-bit" version.

(It is possible to use VirtualBox 6.1.34 for Fedora with modules from the test build but it's quite complicated and I wouldn't recommend it).
Last edited by birdie on 18. Jun 2022, 15:51, edited 2 times in total.
birdie
 
Posts: 353
Joined: 2. May 2010, 14:19
Location: Artem S. Tashkinov
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: Windows, Linux, other Unixes

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby Tomle » 18. Jun 2022, 14:20

Thank you for the help, birdie!

I gave it a shot and I got the following errors.

error: Failed dependencies:
libvpx.so.5()(64bit) is needed by VirtualBox-6.1-6.1.35_151866_el8-1.x86_64

libvpx.so.5() appears to be in libvpx-1.7.0-8.el8.x86_64, so I gave that a shot too, and got the following errors. It appears Fedora 36 already comes with a newer package. At this point, I'm not sure if it's worth a risk of downgrading from Fedora 36 package (libvpx-1.11.0-1.fc36.x86_64) to libvpx-1.7.0-8.el8.x86_64.

[Downloads]$ sudo rpm -i 'libvpx-1.7.0-8.el8.x86_64 (2).rpm'
warning: libvpx-1.7.0-8.el8.x86_64 (2).rpm: Header V4 RSA/SHA256 Signature, key ID c21ad6ea: NOKEY
package libvpx-1.11.0-1.fc36.x86_64 (which is newer than libvpx-1.7.0-8.el8.x86_64) is already installed
file /usr/share/doc/libvpx/AUTHORS from install of libvpx-1.7.0-8.el8.x86_64 conflicts with file from package libvpx-1.11.0-1.fc36.x86_64
file /usr/share/doc/libvpx/CHANGELOG from install of libvpx-1.7.0-8.el8.x86_64 conflicts with file from package libvpx-1.11.0-1.fc36.x86_64
file /usr/share/doc/libvpx/README from install of libvpx-1.7.0-8.el8.x86_64 conflicts with file from package libvpx-1.11.0-1.fc36.x86_64
Tomle
 
Posts: 3
Joined: 18. Jun 2022, 05:27

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby fth0 » 18. Jun 2022, 14:26

FWIW, the "Linux 64-bit" test build has less dependencies and should work on many Linux distributions.
fth0
Volunteer
 
Posts: 3654
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby Tomle » 18. Jun 2022, 15:11

Hi fth0,

Thank you for the help. I just used that Linux 64-bit run file and it works! I'm super happy now! :)

Thanks everyone for having helped!
Tomle
 
Posts: 3
Joined: 18. Jun 2022, 05:27

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby John Of Gwent » 21. Jun 2022, 02:16

I am running a fairly recently built Fedora 36 system having had endless problems trying to get /sbin/vboxconfig to do ANYTHING useful at all on a Debian system I had running for quite a while. I almost considered gong back to windows to run my virtualbox builds ! However, after about a week of hard slog with various dnf install command lines loading kernel headers etc I got Oracle Virtualbox working perfectly at the end of last week.

regrettably, tonight I tried to run up one of my virtualbox images and got the dreaded "you need to run /sbin/vboxconfig"

I suppose it should "go without saying" that the very first thing i did was to check for an updated version of virtualbox and was told the one i have "Version 6.1.34 r150636 (Qt5.15.3)" is the latest available.

even more regrettably, when I ran the above command I was told to examine /var/log/vbox-setup.log to discover why vboxconfig had failed....

I did, and found this delightful message about a hundred lines down.

/tmp/vbox.0/linux/VBoxNetFlt-linux.c:2314:23: error: implicit declaration of function ‘netif_rx_ni’; did you mean ‘netif_rx’? [-Werror=implicit-function-declaration]
2314 | err = netif_rx_ni(pBuf);
| ^~~~~~~~~~~
| netif_rx
cc1: some warnings being treated as errors

googling for the "error implicit declaration ... etc" led me to a this thread on the fedora forum.

I would love to show you the thread but i am told I have t be a member for another day or so.

Anyone curious enough to lkook should find it there through a search for "Kernel-5-17-12-breaks-virtualbox-6-1-34"

Here it seems fellow Fedora 36 Users report flawless operation of the Oracle Virtualbox system on their Fedora builds last week was suddenly derailed by a kernel upgrade.

I've no idea what they might do, but I'll keep my eyes on that thread and hope !
John Of Gwent
 
Posts: 1
Joined: 21. Jun 2022, 01:52

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby scottgus1 » 21. Jun 2022, 03:17

John Of Gwent wrote:I'll keep my eyes on that thread and hope

This topic has the solution already, if I read it right: viewtopic.php?f=7&t=106307#p519481
scottgus1
Site Moderator
 
Posts: 16084
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby elisspace » 25. Jun 2022, 16:41

I'm on Fedora 36, this also worked for me. I got a message when running the installer about a previous installation. I can't remember how I installed it, but
Code: Select all   Expand viewCollapse view
dnf remove VirtualBox-*
didn't work, so I ran the command anyway, presumably installing it mostly over the previous installation and everything is running flawlessly now. Thanks so much!
elisspace
 
Posts: 1
Joined: 25. Jun 2022, 16:39

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby ctsuzuki » 30. Jun 2022, 16:43

Hi,
Where can I get the extension pack for these version ? On the site, there is only for the 6.1.34, not for the 6.1.35.

Thanks & Regards
ctsuzuki
 
Posts: 13
Joined: 23. Apr 2013, 19:57

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby scottgus1 » 30. Jun 2022, 19:21

ctsuzuki wrote:Where can I get the extension pack for these version ? On the site, there is only for the 6.1.34, not for the 6.1.35.

6.1.35 is a test build, and the EP is available on that site.
scottgus1
Site Moderator
 
Posts: 16084
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: VirtualBox-6.1 on Fedora 36 - Installation failed

Postby nikkkki » 2. Jul 2022, 00:06

This is due to commit 2655926aea9b in kernel.

Fixed here[1]. You can patch your existing module sources accordingly.


[1] www[dot]virtualbox[dot]org/browser/vbox/trunk/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c#L2314
nikkkki
 
Posts: 1
Joined: 2. Jul 2022, 00:02


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 17 guests