Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Discussions related to using VirtualBox on Linux hosts.

Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 31. May 2021, 10:02

Does anyone knows how to make VB find my USB devices? I already added my user to the
Code: Select all   Expand viewCollapse view
 usergroup sudo gpasswd -a yourusername vboxusers
and follow the troubleshooting guide at this forum, and installed the last extension pack and no success. any help will be appreciated. thank you, in advance...
cheers



Code: Select all   Expand viewCollapse view
99% 2021-05-28 14:49:37 ⌚  ukelinux in ~
○ → VBoxManage -version
6.1.22r144080

99% 2021-05-28 14:49:54 ⌚  ukelinux in ~
○ → VBoxManage list extpacks
Extension Packs: 1
Pack no. 0:   Oracle VM VirtualBox Extension Pack
Version:      6.1.22
Revision:     144080
Edition:     
Description:  Oracle Cloud Infrastructure integration, USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module:  VBoxVRDP
Usable:       true
Why unusable:

99% 2021-05-28 14:51:04 ⌚  ukelinux in ~
○ → VBoxManage list usbhost
Host USB Devices:

<none>


99% 2021-05-28 14:51:11 ⌚  ukelinux in ~
○ → VBoxManage list usbfilters
Global USB Device Filters:

<none>


99% 2021-05-28 14:51:16 ⌚  ukelinux in ~
○ → VBoxManage showvminfo Windows10
Name:                        Windows10
Groups:                      /
Guest OS:                    Windows 10 (64-bit)
UUID:                        1b94ed40-0e1b-4ebf-983b-18172960f56a
Config file:                 /home/zensir/VirtualBox VMs/Windows10/Windows10.vbox
Snapshot folder:             /home/zensir/VirtualBox VMs/Windows10/Snapshots
Log folder:                  /home/zensir/VirtualBox VMs/Windows10/Logs
Hardware UUID:               1b94ed40-0e1b-4ebf-983b-18172960f56a
Memory size:                 8000MB
Page Fusion:                 disabled
VRAM size:                   128MB
CPU exec cap:                100%
HPET:                        disabled
CPUProfile:                  host
Chipset:                     piix3
Firmware:                    BIOS
Number of CPUs:              6
PAE:                         disabled
Long Mode:                   enabled
Triple Fault Reset:          disabled
APIC:                        enabled
X2APIC:                      disabled
Nested VT-x/AMD-V:           disabled
CPUID Portability Level:     0
CPUID overrides:             None
Boot menu mode:              message and menu
Boot Device 1:               DVD
Boot Device 2:               HardDisk
Boot Device 3:               Network
Boot Device 4:               Floppy
ACPI:                        enabled
IOAPIC:                      enabled
BIOS APIC mode:              APIC
Time offset:                 0ms
RTC:                         local time
Hardware Virtualization:     enabled
Nested Paging:               enabled
Large Pages:                 disabled
VT-x VPID:                   enabled
VT-x Unrestricted Exec.:     enabled
Paravirt. Provider:          Default
Effective Paravirt. Prov.:   HyperV
State:                       powered off (since 2021-05-28T12:17:49.000000000)
Graphics Controller:         VBoxSVGA
Monitor count:               1
3D Acceleration:             disabled
2D Video Acceleration:       disabled
Teleporter Enabled:          disabled
Teleporter Port:             0
Teleporter Address:         
Teleporter Password:         
Tracing Enabled:             disabled
Allow Tracing to Access VM:  disabled
Tracing Configuration:       
Autostart Enabled:           disabled
Autostart Delay:             0
Default Frontend:           
VM process priority:         default
Storage Controller Name (0):            SATA
Storage Controller Type (0):            IntelAhci
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  30
Storage Controller Port Count (0):      4
Storage Controller Bootable (0):        on
SATA (0, 0): /home/zensir/VirtualBox VMs/Windows10/Windows10.vdi (UUID: 8e7a56bb-5c2c-4780-9d69-915f1caa7a30)
SATA (1, 0): /usr/share/virtualbox/VBoxGuestAdditions.iso (UUID: 3159fab6-6b2f-4987-97e6-3405163a087e)
NIC 1:                       MAC: 080027DCEFFC, Attachment: Bridged Interface 'wlp0s20f3', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 2:                       disabled
NIC 3:                       disabled
NIC 4:                       disabled
NIC 5:                       disabled
NIC 6:                       disabled
NIC 7:                       disabled
NIC 8:                       disabled
Pointing Device:             USB Tablet
Keyboard Device:             PS/2 Keyboard
UART 1:                      disabled
UART 2:                      disabled
UART 3:                      disabled
UART 4:                      disabled
LPT 1:                       disabled
LPT 2:                       disabled
Audio:                       enabled (Driver: PulseAudio, Controller: HDA, Codec: STAC9221)
Audio playback:              enabled
Audio capture:               disabled
Clipboard Mode:              Bidirectional
Drag and drop Mode:          Bidirectional
VRDE:                        disabled
OHCI USB:                    disabled
EHCI USB:                    disabled
xHCI USB:                    enabled

USB Device Filters:

Index:                       0
Active:                      yes
Name:                        4g Pendrive
VendorId:                    aaaa
ProductId:                   1111
Revision:                   
Manufacturer:               
Product:                     
Remote:                     
Serial Number:               

Bandwidth groups:  <none>

Shared folders:<none>

Capturing:                   not active
Capture audio:               not active
Capture screens:             0
Capture file:                /home/zensir/VirtualBox VMs/Windows10/Windows10.webm
Capture dimensions:          1024x768
Capture rate:                512kbps
Capture FPS:                 25kbps
Capture options:             ac_enabled=false

Guest:

Configured memory balloon size: 0MB


Attachments
Windows10-2021-05-28-14-17-49.log.tar.gz
(38.99 KiB) Downloaded 6 times
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby mpack » 31. May 2021, 11:23

Just to be clear: the extension pack is what provides USB2/USB3 functionality, so "installing the last extension pack" is a prerequisite, not just something you try.

I already added my user to the <vboxusers group>

... and then you logged out and back in again, right?

USB basics and troubleshooting.
mpack
Site Moderator
 
Posts: 34553
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 31. May 2021, 15:23

Yes, I followed all the troubleshooting guide, including longing out, and didn't work to me work.
i think is still a permission problem...
what else can I try?
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby scottgus1 » 31. May 2021, 15:33

zensir wrote:I followed all the troubleshooting guide

Not yet, there's a post #8. We don't see anything yet from post #8.
scottgus1
Site Moderator
 
Posts: 13050
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 1. Jun 2021, 15:33

it's everything attached and pasted in the first post.
If not can you be a bit more specific, please.
Thanks!
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby scottgus1 » 1. Jun 2021, 15:55

Oops, how stupid of me! I am sorry, I totally missed it! :oops:

Definitely not seeing the USB devices:
VBoxManage list usbhost
Host USB Devices:

<none>


I'm not certain I missed it, leastways a page search didn't find it, but I don't think there is an output for "id", to see if the group assignment stuck.

I'm no Linux guru, so I have to web-search this one. A web-search of ""Linux Hosts" USB devices not found site:forums.virtualbox.org" brings up several possible solutions, of which this:
viewtopic.php?f=7&t=89562#p429573 suggests that the use of 'sudo' in the assignment may not or is not necessary and may be detrimental. Also a reboot is necessary to get the group assignment to stick.
scottgus1
Site Moderator
 
Posts: 13050
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby mpack » 1. Jun 2021, 16:10

I'm certainly no Linux expert either, but I believe there is a "groups" command that can list the groups the current user is a member of. If "vboxusers" is listed then all should be good.

I'm assuming btw that "Elementary OS" and Ubuntu are identical in all important respects, with only cosmetic differences.
mpack
Site Moderator
 
Posts: 34553
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 1. Jun 2021, 21:34

scottgus1 wrote:Oops, how stupid of me! I am sorry, I totally missed it! :oops:

no problem :D

I'm not certain I missed it, leastways a page search didn't find it, but I don't think there is an output for "id", to see if the group assignment stuck.

this is what I get fro the id and groups command
Screenshot from 2021-06-01 21.21.30.png
Screenshot from 2021-06-01 21.21.30.png (12.88 KiB) Viewed 1279 times

Screenshot from 2021-06-01 21.23.06.png
Screenshot from 2021-06-01 21.23.06.png (30.61 KiB) Viewed 1279 times

I assume the group and the user its there...
I am lost.

I'm no Linux guru, so I have to web-search this one. A web-search of ""Linux Hosts" USB devices not found site:forums.virtualbox.org" brings up several possible solutions, of which this:
viewtopic.php?f=7&t=89562#p429573 suggests that the use of 'sudo' in the assignment may not or is not necessary and may be detrimental. Also a reboot is necessary to get the group assignment to stick.[/quote]
Yup, already read that, thanks a lot for your response...
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 1. Jun 2021, 21:45

mpack wrote:I'm certainly no Linux expert either, but I believe there is a "groups" command that can list the groups the current user is a member of. If "vboxusers" is listed then all should be good.

yup, as you can see, the group is listed there, I can't count the number of times I rebooted to test if the user was logged in to the group. :P

Code: Select all   Expand viewCollapse view
id zensir
uid=1000(zensir) gid=1000(zensir) groups=1000(zensir),4(adm),6(disk),7(lp),24(cdrom),27(sudo),30(dip),46(plugdev),118(lpadmin),127(sambashare),131(vboxusers),998(vboxsf)


I'm assuming btw that "Elementary OS" and Ubuntu are identical in all important respects, with only cosmetic differences.


you are assuming right, Built on Ubuntu 18.04.4 LTS :D.

I tried this solution in this post, but no change:
https://github.com/dnschneid/crouton/wiki/VirtualBox-udev-integration
I can't see the VBoxCreateUSBNode.sh file in my machine. Could this be the problem?

I also tried this script that seemed to work for others but no success to me:
https://gist.github.com/gon1332/70422af1fa6bed497964701b81fef124

any suggestion?
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby zensir » 1. Jun 2021, 22:52

Seems to be working now, after many hours of digging, found this post:
https://forums.opensuse.org/showthread.php/503064-suse-host-virtualbox-does-not-reach-USB-devices?p=2692376#post2692376
In my case the problem occurred because the file did not exist /usr/lib/udev/60-vboxdrv.rules

although I didn't have the 60-vboxdrv.rules file I had the file etc/udev/rules.d/60-vboxadd.rules (I assumed it was the same but named different), so I created the folder /udev in /lib/ (as mentioned in the post) and copy and pasted my 60-vboxadd.rules there, rebooted, started my VM with my empty USB filters and all my connected devices showed up in the list (see pic).
Screenshot from 2021-06-01 22.45.18.png
Screenshot from 2021-06-01 22.45.18.png (47.04 KiB) Viewed 1276 times


Then I had to follow this instructions to make my WACOM work with sensitive pressure:
https://superuser.com/a/1416761

I had the same issue using a Windows 10 VM under VirtualBox 5.2.20 with Inkscape. The mouse cursor would not move with my Wacom Intuos tablet, but the pressure sensitivity was on. Enabling the mouse trail, making this as small as the slider will allow, shows the cursor position with the tablet pen. To get this, type 'mouse' in the search box, select 'mouse settings' 'additional mouse options' 'pointer options' 'display pointer trails'.



thanks for your help guys!
:D
zensir
 
Posts: 8
Joined: 28. May 2021, 14:21

Re: Virtualbox 6.1 in eOs Hera Host won't find any USB devices available

Postby scottgus1 » 2. Jun 2021, 14:29

Thanks for responding with your find! There have been some of these "Linux not finding USB devices despite everything in "USB Basics and Troubleshooting' being set up correctly" posts, but I haven't found a solution.

Based on the log posted in your first post you were running the official Virtualbox.

So the problem was a missing file in the host OS?
scottgus1
Site Moderator
 
Posts: 13050
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 10 guests