Problem with VBOX 6.1.30 and Oracle Linux 8.5 Host

Discussions related to using VirtualBox on Linux hosts.

Problem with VBOX 6.1.30 and Oracle Linux 8.5 Host

Postby pwstephe » 6. Dec 2021, 18:42

Installed Vbox 6.1.30 and Extension Pack on an Oracle Linux 8.5 host x86 and when attempting to create a VM for the same Oracle Linux 8.5 release I receive the following error messages:

vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.

The distribution packages containing the headers are probably:
kernel-uek-devel kernel-uek-devel-5.4.17-2136.301.1.3.el8uek.x86_64
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
kernel-uek-devel kernel-uek-devel-5.4.17-2136.301.1.3.el8uek.x86_64

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.
If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system's documentation for more information.

When I run /sbin/vboxconfig it just repeats the error.

When I check the kernel level:
[pstephenson@localhost-live Documents]$ uname -r
5.4.17-2136.301.1.3.el8uek.x86_6

I'm not sure what to do to correct this problem.
pwstephe
 
Posts: 2
Joined: 16. Feb 2016, 17:12

Re: Problem with VBOX 6.1.30 and Oracle Linux 8.5 Host

Postby scottgus1 » 6. Dec 2021, 18:46

This is what you need to do:

pwstephe wrote:Please install the Linux kernel "header" files matching the current kernel


How this is done depends on the Linux flavor, but please see the manual, section 2.3.1 "Installing on Linux Hosts > Prerequisites"

BTW the same prerequisites are needed inside the VM for Guest Additions.
scottgus1
Site Moderator
 
Posts: 14356
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Problem with VBOX 6.1.30 and Oracle Linux 8.5 Host

Postby pwstephe » 7. Dec 2021, 00:37

So apparently VirtualBox 6.1.30 doesn't currently support the current level of Oracle Linux 8.5 guests without adding an older version of the kernel-headers. I'm surprised.

Thanks,
Phil
pwstephe
 
Posts: 2
Joined: 16. Feb 2016, 17:12


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: juri and 21 guests