Microphone input not working Linux Host Win10 Guest

Discussions related to using VirtualBox on Linux hosts.

Microphone input not working Linux Host Win10 Guest

Postby Scuber » 26. Jan 2019, 06:23

I'm running the latest version 6.0.2.r128162 (Qt5.9.5) with extentions and guest additions.
The Host is Ubuntu 18.04 (64bit) and the Guest is Windows 10 (64bit).

I can't seem to get the microphone to work in my Windows 10 Guest. VBox Audio is enabled, Host Audio Driver: PulseAudio, Audio Controller: Intel HD Audio, Extended Features Audio Output and Audio Input are both checked.
Pulse Audio shows activity on the Microphone input but the audio is not present in the Win10 Guest.

I have a Windows application that is an interface to a ham radio (Ham Radio Deluxe). The radio has a sound card in it that feeds the audio out from the radio into the Microphone input which Ham Radio Deluxe uses for digital communications. No audio is present from the microphone within the Win10 Guest.

Is anyone else having this issue?
Scuber
 
Posts: 4
Joined: 26. Jan 2019, 06:12

Re: Linux Host Windows 10 Guest

Postby andyp73 » 26. Jan 2019, 11:05

I don't know why I think this, as I can't find any documentary evidence to support it, but I believe that it is the line-in that passed to the guest not the microphone input. If that is the case then you may need to change the audio settings of the host.

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: Linux Host Windows 10 Guest

Postby Scuber » 26. Jan 2019, 18:54

I can see the audio coming in from the radio going to the line-in (microphone) in Pulse-Audio. The audio looks fine and works fine with fldigi which is a linux based app. The problem is trying to get the audio into Windows 10 Guest in VirtualBox.

I don't see any other options other than the ones in Pulse Audio where I tell it to use a particular device for Input and Output. I only have 2 sound cards, the built in one and the one inside the radio. I know I have the correct ones selected because they work with native apps as well as an app running under wine.

I believe Virtual Box has a problem with the microphone/(line-in) when running VirtualBox with a Linux Host and a Windows 10 Guest.

Norm
Scuber
 
Posts: 4
Joined: 26. Jan 2019, 06:12

Microphone input not working Linux Host Win10 Guest

Postby Scuber » 26. Jan 2019, 22:39

I recently made a post with a rather poor description in the Subject line. I thought I would re-post with a more descriptive subject line in hopes of getting a responses from a few more people having the same issue.
[ModEdit: The two topics have been merged.]
-------------------------

I'm running the latest version 6.0.2.r128162 (Qt5.9.5) with extensions and guest additions.
The Host is Ubuntu 18.04 (64bit) and the Guest is Windows 10 (64bit).

I can't seem to get the microphone to work in my Windows 10 Guest.

In VirtualBox under Windows 10 guest settings in the Audio tab:
Audio is enabled, Host Audio Driver: PulseAudio, Audio Controller: Intel HD Audio, Extended Features Enable Audio Output Input are both checked.

In Pulse Audio under the Recording tab it shows:
VirtualBox: VirtualBox Line In [Windows 10] from PCM2901 Audio Codec Analog Stereo
The volume is at 100% and I can see the audio activity in the graph line below the description.
NOTE: I notice it says Line In for the device in Pulse Audio. I don't think this has any bearing on the subject but not positive. Regardless, it
does indicate its being used by VBox and there is activity (sound) being detected.

In Windows 10 guest under Sound Devices, under the Recording tab there is only one item present: Microphone - High Definition Audio Device. The level control is set to 100% but there is NO audio present on this device but there should be!

I have a Windows application that is an interface to a ham radio (Ham Radio Deluxe). The radio has a sound card in it that feeds the audio out from the radio into the Microphone input which Ham Radio Deluxe uses for digital communications. No audio is present from the microphone within the Win10 Guest.

Is anyone else having this issue?

Sorry if re-posting with more info and a better subject line isn't the proper way to do this.....

Norm
Scuber
 
Posts: 4
Joined: 26. Jan 2019, 06:12

Re: Microphone input not working Linux Host Win10 Guest

Postby Scuber » 1. Feb 2019, 18:41

After looking all over the internet, this seems to be a problem that has NEVER been fixed since v5.0.1 or so.

Without microphone input, VirtualBox is worthless to me. The only reason I need it is for an application that uses microphone input.

ANYONE ELSE HAVING THIS ISSUE?

Norm
Scuber
 
Posts: 4
Joined: 26. Jan 2019, 06:12

Re: Microphone input not working Linux Host Win10 Guest

Postby socratis » 8. Feb 2019, 07:48

I merged your two threads, just because there were already answers to both of them. Please don't open duplicates in the future.

I want you to get away from the ham application and verify that you have basic audio in. Take a simple microphone, either a built-in into a laptop, or an external one. Make sure that it works before you go into the details. Learn to walk before you run...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Microphone input not working Linux Host Win10 Guest

Postby AstroTom » 26. Mar 2020, 15:32

I have exactly the same problem as described above. The previous posts describe the details properly. I don't use a hm radio software, so it's not the software or additional sound card.

In the Linux host I get the microphone input from the mic jack, in the Windows10 guest it does not arrive. Something like this should work out of the box. Please look at this urgently or advise how to get it to work.
AstroTom
 
Posts: 1
Joined: 26. Mar 2020, 15:29

Re: Microphone input not working Linux Host Win10 Guest

Postby TEP » 8. Jun 2020, 19:01

Just in case anyone else is having this issue, the solution for me was a Microphone Privacy setting in Win10. Settings - Privacy - Microphone - Allow apps to access your microphone AND Allow Desktop apps to access your microphone. I tried every combination I could in Virtualbox until one of them caused Windows to display an error on the sound and that let me to a post that said to check your privacy settings. Enabled them and all microphone sources now work (laptop, headset, usb webcam).
TEP
 
Posts: 3
Joined: 11. Jan 2013, 17:42

Re: Microphone input not working Linux Host Win10 Guest

Postby Jackson4x4 » 17. Sep 2020, 20:53

Hi,

In my case, I had to change the virtual machine setting for the window machine I was using Oracle. I enabled audio input which was disabled by default. After this, I was able to use my ubuntu microphone on virtual windows. Hopefully, this helps you out in accessing the microphone as well...

Take care...
Jackson4x4
 
Posts: 1
Joined: 17. Sep 2020, 20:49

Re: Microphone input not working Linux Host Win10 Guest

Postby peddecke » 2. Nov 2020, 16:18

I still have the same problem. Ubuntu 18.04.5 on Dell XPS13 as host, Virtualbox 5.2.42 with Windows 10 as guest. PulseAudio as host driver with Intel HD Audio as controller. The main reason for me is the legacy Skype for Business, unfortunately still used by lots of organizations. I tried with both S4B as the default Voice recorder on Windows. Sound output works perfect, sound input doesn't. The VirtualBox settings seem OK as well (both input as output are enabled). I checked all volume settings in the host OS, which are OK (I see the virtualbox line in in the pulseaudio volume control under "recording applications"), but my voice input is never heard in the Windows Host OS, neither in Skype nor Voice Recorder. Privacy permissions for Voice Recorder are OK by default (access to microphone) but S4B cannot be found in that list.

Am I missing something? Thanks.
peddecke
 
Posts: 1
Joined: 2. Nov 2020, 16:07

Re: Microphone input not working Linux Host Win10 Guest

Postby DJViking » 19. Oct 2021, 12:18

TEP wrote:Just in case anyone else is having this issue, the solution for me was a Microphone Privacy setting in Win10. Settings - Privacy - Microphone - Allow apps to access your microphone AND Allow Desktop apps to access your microphone. I tried every combination I could in Virtualbox until one of them caused Windows to display an error on the sound and that let me to a post that said to check your privacy settings. Enabled them and all microphone sources now work (laptop, headset, usb webcam).


This was the solution that solved it for me on VirtualBox 6.1
DJViking
 
Posts: 1
Joined: 19. Oct 2021, 12:17


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 15 guests