[Win7 64 Host] VM Sound wont work and freeze VM

Discussions related to using VirtualBox on Windows hosts.
Post Reply
helgo1506
Posts: 5
Joined: 19. Oct 2019, 20:01

[Win7 64 Host] VM Sound wont work and freeze VM

Post by helgo1506 »

Hallo there,

I got a weird problem with my VMs, when i active the sound on it. Im using an USB headset on my host. Worked perfectly there. But when i try to active the sound for my VMs it freezes the VMs. When i disable the sound on the VM, it worked without problem. I got the Problem a long time now. The funny thing is, that it works on my Laptop (same Windows 7 64 Host), which got only the onboard thing. In an old version (dont know when it did started) it worked. I though perhaps things got changed from the dev views point with the Sound input. But with the newest Version (6.1.2) it still dont work. I dont think, that its a Host problem, cause all games (relativ old game too, that run on Win7) are working perfectly.
It doesnt matter what system the guest is. It seems a problem with the virtualbox.

I tried to use my onboard soundcard (the output/input is not shown until i plug something in, just for the note), set it on default and did restart VB, but still the same problem.

Does some guys have the same problem or is it just me?
Attachments
Windows 2000-2020-02-23-23-08-17.log
(80.44 KiB) Downloaded 8 times
birdie
Posts: 431
Joined: 2. May 2010, 14:19
Primary OS: Fedora other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux, other Unixes
Location: Artem S. Tashkinov
Contact:

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by birdie »

Try updating your host sound drivers.
helgo1506
Posts: 5
Joined: 19. Oct 2019, 20:01

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by helgo1506 »

They're up-to-date. But i dont think it got something to do with that, cause ALL my sound outputs, that i can use, wont work for VB. Like i said, in generall it works with all other applications and games. I think it's a Direct Sound und VB Problem. But in games DirectSound works, so idk...perhaps the Interface they are using or so?
birdie
Posts: 431
Joined: 2. May 2010, 14:19
Primary OS: Fedora other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux, other Unixes
Location: Artem S. Tashkinov
Contact:

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by birdie »

helgo1506 wrote:They're up-to-date. But i dont think it got something to do with that, cause ALL my sound outputs, that i can use, wont work for VB. Like i said, in generall it works with all other applications and games. I think it's a Direct Sound und VB Problem. But in games DirectSound works, so idk...perhaps the Interface they are using or so?
Try deleting your sound drivers then and see if the ones which come with Windows work for you.
helgo1506
Posts: 5
Joined: 19. Oct 2019, 20:01

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by helgo1506 »

In the attachment is my standard Sound, i use. It is a Windows driver, like you can see.
I added another log, where i actived the sound debug. When i look into, all i can see is, that it is trying to buffer the sound. It seems it cant complete it, at some point. This leads to enormous lags in the VM and VB-GUI.

EDIT: I packed the debug sound output files (.wav) and uploaded it. When i play them with my host after i cloed the VM, i can hear first sek (windows 2000 welcome sound) perfectly fine in the files, but it is not complete. But this will not be outputed on my host driver during the VM.
Attachments
Temp_snd.rar
Debug sound files (.wav)
(148.62 KiB) Downloaded 5 times
Windows 2000-2020-03-04-13-19-11.rar
Audio Debug Log
(52.35 KiB) Downloaded 6 times
Sound Driver from Standard Audio, i use.
Sound Driver from Standard Audio, i use.
mmc_2020-03-04_12-49-09.png (16.3 KiB) Viewed 1902 times
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by scottgus1 »

I don't typically run sound from my guests so I don't have much expertise in diagnosing sound issues.

However, I would suggest a troubleshooting step: Remove all of the fancy USB & Bluetooth & other format sound stuff you may or do have installed, and the drivers therefor, and go back to basic old-school analog 1/8" stereo headphone jack output, as a test after a host reboot, and see if your guests put out good sound over the 1990's hardware.

If you get good sound with your father's audio setup ( :lol: ) then try adding in the new-fangled hardware one piece & driver at a time, with a good guest audio test, to see if anything breaks.

FWIW sometimes an uninstall & reinstall of various conflicting hardware/drivers reestablishes coexistence.
helgo1506
Posts: 5
Joined: 19. Oct 2019, 20:01

Re: [Win7 64 Host] VM Sound wont work and freeze VM

Post by helgo1506 »

To prove that it is not a host hardware problem, i uninstalled all sound drivers, that i could (one is the HDMI sound from my graphic, cant really uninstall this xD) und i set default sound to my onboard and even changed the driver to the windows one (HD audio on host). And still, like i though, sound dont work in VMs. Playing sound in host directly is still working. Again...here are some logs. I really dont think it got to do with ANY host driver Problem.

In the new logs, it says something about the record audio thing (i dont got one, without my headset, what is clear.i disabled it for the vm anyway, but it still tries to lookup for one.)

Just for note : changing the emulated guest sound driver, dont change anything. And i added a log for Windows 10 guest too. In Linux same thing.
Attachments
Windows 10-2020-03-04-19-38-29.rar
Windows 10 Logs with HD audio.
(34.6 KiB) Downloaded 7 times
Windows 2000-2020-03-04-20-09-41.rar
Windows 2000 with AC97 audio
(50.19 KiB) Downloaded 5 times
Post Reply