How to force VirtualBox to use native virtualization hardware

Discussions related to using VirtualBox on Windows hosts.

How to force VirtualBox to use native virtualization hardware

Postby Ricjames » 5. Sep 2019, 19:23

I am currently trying to boot up a VM with vagrant and I am having an issue where VirtualBox is using NEM mode(green turtle) instead of the native hardware virtualization(blue chip), even though hyper-v is completely disabled and VT-x is enabled through the BIOS. Once the VM boots up, the screen stays black. Is there anything I am missing in order to get this to work?

I am running the Ubuntu/bionic64 os
Attachments
vboxlog.log
(65.94 KiB) Downloaded 8 times
Ricjames
 
Posts: 1
Joined: 5. Sep 2019, 19:08

Re: How to force VirtualBox to use native virtualization hardware

Postby scottgus1 » 5. Sep 2019, 19:26

Usually we don't handle Vagrant-edited Virtualbox, beacuse Vagrant, well, changes things....

But this is in your log:
00:00:05.500287 HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
00:00:05.690888 NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...


So Hyper-V isn't fully disabled yet. See I have a 64bit host, but can't install 64bit guests Carefully go through each command in the 2nd & 3rd posts. Based on my perusal of successful fixes for this problem, the silver bullet appears to be the "bcdedit" command & complete power-down in post 2 point 1.
Human government is like that crazy uncle who hides a quarter in his fist behind his back, then asks you to guess which fist the quarter is in...
No matter which side you choose, Left or Right, both Sides are empty.
scottgus1
Volunteer
 
Posts: 4459
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Win7


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 56 guests