[Resolved] wont install Linux

Discussions related to using VirtualBox on Windows hosts.

[Resolved] wont install Linux

Postby Data007 » 28. Aug 2019, 03:31

I have a strange problem I am trying to install Linux(debian) on the latest virtual box.
It boots to the install screen(select install->graphic install....)
when I select the install method Virtual box stops, no sign of HD activity or any of the bottom icons showing activity.

When I say stop's I mean I can then select the machine and close it normally.

As a last try I did go into featues and enabled hyperV

Any ideas as to why the machine(virtual) will not boot.

Capture.PNG
Capture.PNG (21.78 KiB) Viewed 163 times
Last edited by socratis on 28. Aug 2019, 19:55, edited 1 time in total.
Reason: Marked as [Resolved].
Data007
 
Posts: 5
Joined: 4. Dec 2017, 13:59

Re: wont install Linux

Postby socratis » 28. Aug 2019, 09:52

Data007 wrote:As a last try I did go into featues and enabled hyperV

That's the wrong route actually. You need to disable any and all Hyper-V components. Look at the topic "I have a 64bit host, but can't install 64bit guests" for some Hyper-V enablers that we're aware of so far.

Take a look at the status bar. Do you see "slow" icon (Image)? That means a Hyper-V component is enabled. If VirtualBox is running without Hyper-V enabled, where proper, hardware virtualization is actually available, then the standard virtualization icon (Image) would show.

If that doesn't work, we need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25873
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: wont install Linux

Postby Data007 » 28. Aug 2019, 11:30

TY for the reply, I have disabled the hyperV and the problem still exists.
I suspect its something to do with the ISO I have downloaded i386 version, it did not like the amd64 version.

Anyway the log file is enclosed/attached.
Debian10-2019-08-28-10-22-22.zip
(24.82 KiB) Downloaded 9 times
Data007
 
Posts: 5
Joined: 4. Dec 2017, 13:59

Re: wont install Linux

Postby scottgus1 » 28. Aug 2019, 15:12

Something weird is going on:
In a normal guest with VT-x running you get a segment showing the host's VT-x features along with this line:
HM: HMR3Init: VT-x w/ nested paging hw support

Your log has the VT-x features segment, but this line instead:
00:00:01.882602 CPUM: No hardware-virtualization capability detected

I don't know if or why VT-x Features would appear and then say no VT-x. Check your BIOS that this setting is on, google for how to find it.

Data007 wrote:it did not like the amd64 version.

I wonder if your New Guest wizard does not show any 64-bit guests? See I have a 64bit host, but can't install 64bit guests
Human government is like that crazy uncle who hides a quarter in his fist behind his back, then asks you to guess which fist the quarter is in...
No matter which side you choose, Left or Right, both Sides are empty.
scottgus1
Volunteer
 
Posts: 4469
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Win7

Re: wont install Linux

Postby Data007 » 28. Aug 2019, 18:55

Hi
Turning on Virtual x in the bios and making a new machine(wiping old settings), and its installing.
Never had that bother before......... THANKS.
--
Steve
Data007
 
Posts: 5
Joined: 4. Dec 2017, 13:59

Re: wont install Linux

Postby scottgus1 » 28. Aug 2019, 18:57

Glad you're up and running!
VT-x is becoming more of a requirement for Virtualbox and other virtualizers, even on guests that did not require VT-x before.
Human government is like that crazy uncle who hides a quarter in his fist behind his back, then asks you to guess which fist the quarter is in...
No matter which side you choose, Left or Right, both Sides are empty.
scottgus1
Volunteer
 
Posts: 4469
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Win7

Re: wont install Linux

Postby socratis » 28. Aug 2019, 19:54

scottgus1 wrote:VT-x is becoming more of a requirement for Virtualbox

Just wait until Raw-Mode is going to be no more. Have you tried the 6.0.97 testbuilds lately? ;)
00:00:08.823267 VirtualBox VM 6.0.10 r132072 linux.amd64 (Jul 12 2019 11:46:03) release log
...
00:00:09.821901 ************************* CFGM dump *************************
00:00:09.821909 [/] (level 0)
00:00:09.821924 CSAMEnabled <integer> = 0x0000000000000001 (1) <-- Gone!
00:00:09.821935 CpuExecutionCap <integer> = 0x0000000000000064 (100)
00:00:09.821936 EnablePAE <integer> = 0x0000000000000001 (1)
00:00:09.821938 HMEnabled <integer> = 0x0000000000000001 (1)
00:00:09.821939 MemBalloonSize <integer> = 0x0000000000000000 (0)
00:00:09.821940 Name <string> = "Windows 10 (64)" (cb=16)
00:00:09.821942 NumCPUs <integer> = 0x0000000000000002 (2)
00:00:09.821943 PATMEnabled <integer> = 0x0000000000000001 (1) <-- Gone!
00:00:09.821944 PageFusionAllowed <integer> = 0x0000000000000000 (0)
00:00:09.821945 RamHoleSize <integer> = 0x0000000020000000 (536 870 912, 512 MB)
00:00:09.821947 RamSize <integer> = 0x00000000c0000000 (3 221 225 472, 3 072 MB, 3.0 GB)
00:00:09.821950 RawR0Enabled <integer> = 0x0000000000000001 (1) <-- Gone!
00:00:09.821951 RawR3Enabled <integer> = 0x0000000000000001 (1) <-- Gone!
00:00:09.821952 TimerMillies <integer> = 0x000000000000000a (10)
00:00:09.821953 UUID <bytes> = "dc 36 d4 da 17 78 32 42 9c d0 b2 43 ac b2 d5 64" (cb=16)
00:00:06.139535 VirtualBox VM 6.0.97 r132765 linux.amd64 (Aug 15 2019 21:13:11) release log
...
00:00:06.704612 fHMForced=true - No raw-mode support in this build! <-- NEW!
...
00:00:07.133005 ************************* CFGM dump *************************
00:00:07.133022 [/] (level 0)
00:00:07.133048 CpuExecutionCap <integer> = 0x0000000000000064 (100)
00:00:07.133090 EnablePAE <integer> = 0x0000000000000001 (1)
00:00:07.133093 HMEnabled <integer> = 0x0000000000000001 (1)
00:00:07.133095 MemBalloonSize <integer> = 0x0000000000000000 (0)
00:00:07.133098 Name <string> = "Windows 10 (64)" (cb=16)
00:00:07.133101 NumCPUs <integer> = 0x0000000000000002 (2)
00:00:07.133103 PageFusionAllowed <integer> = 0x0000000000000000 (0)
00:00:07.133105 RamHoleSize <integer> = 0x0000000020000000 (536 870 912, 512 MB)
00:00:07.133109 RamSize <integer> = 0x00000000c0000000 (3 221 225 472, 3 072 MB, 3.0 GB)
00:00:07.133114 TimerMillies <integer> = 0x000000000000000a (10)
00:00:07.133116 UUID <bytes> = "dc 36 d4 da 17 78 32 42 9c d0 b2 43 ac b2 d5 64" (cb=16)

Now the logs look a lot more like the ones generated by my OSX Host! :)

Marking as [Resolved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25873
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], socratis and 55 guests