[Solved] Mouse Pointer disappears in Text Editor

Discussions related to using VirtualBox on Windows hosts.

[Solved] Mouse Pointer disappears in Text Editor

Postby Sadpanda » 12. Aug 2019, 14:06

Hello,

After starting a Windows 10 virtual machine from VirtualBox that I setup, I've been having issues with the mouse pointer doing the following.
1. The mouse pointer will become much larger on my laptop. When I go to Notepad, Word, Visual Studio, etc. the large mouse pointer and the "I" symbol indicating you can type are both being rendered. I believe the normal behavior is that the "I" symbol would only appear. It should also be noted that this happens whether or not I've got a second monitor hooked up via HDMI.
2. I use my 65 inch Panasonic TV as a second monitor. While the mouse size is normal when moving it around there, the "I" symbol either disappears or is rendered as a very small dot.

For my setup, I have implemented "Insert Guest Additions CD Image". I've tried tweaking the following below after that was done.
1. In the Settings-->Display-->Graphics Controller, I've toggled this to be VBOXSVGA and VBOXVGA.
2. In the Settings-->System-->Motherboard-->Pointing Device, I've toggled it between USB Tablet and PS/2 Mouse.

I can turn on Mouse Integration and things will work on the Virtual Machine. However, I am remoting into work via RDC and then I experience lag with my mouse from my machine at work.

The final thing I'll add is that my setup on my old laptop with VirtualBox doesn't have any of the issues I'm experiencing with my new laptop. My old laptop uses Windows 7 OS locally and a Windows 10 Virtual Machine. The new laptop has Windows 10 locally and for the Virtual Machine.

Any ideas how to resolve?
Sadpanda
 
Posts: 3
Joined: 12. Aug 2019, 13:06

Re: Mouse Pointer disappears in Text Editor

Postby mpack » 12. Aug 2019, 15:01

Not a host question - moving topic to Windows Guests.

Did you install the Guest Additions? I don't mean "did you insert the CD", I mean did the GAs installer appear or did you launch it?
mpack
Site Moderator
 
Posts: 30672
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Mouse Pointer disappears in Text Editor

Postby Sadpanda » 12. Aug 2019, 15:20

The GAS Installer did not appear after I selected the "Insert Guest Additions CD Image" option from the toolbar.

I had to manually click on the "VBoxWindowsAdditions" from the D drive to run it there. So, after running that, full screen mode was being rendered correctly without any black around the edges.
Sadpanda
 
Posts: 3
Joined: 12. Aug 2019, 13:06

Re: Mouse Pointer disappears in Text Editor

Postby Sadpanda » 20. Aug 2019, 14:41

I'm still unsure what's going with my original issue and hadn't heard anyone else chime in with how to fix this.

Anyway, I setup another Windows 10 VM with the same iso file where everything works with my old laptop. Again, my old laptop has Windows 7 along with the Windows 10 VM and there isn't an issue when I log in into the VM and then remote into my work via VPN.

I've tried toggling the mouse, the Graphics Controller again with the second Windows 10 VM on my new laptop. However, it also has the same where the mouse disappears on my second monitor which is a 65 inch Panasonic TV.

At this point, there only two things that are different on the new laptop vs old laptop.
1. The new laptop uses a newer version of Virtualbox. I think it's 6.0.10 that's on the new laptop where my old laptop is using 6.0.8.
2. Old laptop uses Windows 7 as it OS and Windows 10 as the VM. The new laptop has Windows 10 for both the OS and the VM.

Should I roll back the version to use 6.0.8 on the new laptop?
Sadpanda
 
Posts: 3
Joined: 12. Aug 2019, 13:06

Re: Mouse Pointer disappears in Text Editor

Postby HF » 20. Nov 2019, 17:34

I'm seeing what may be the same issue. Windows 10 1709 Host, Windows 10 1909 Guest, Virtualbox v6.0.14 and the matching Guest Additions are installed.

What I see is the mouse pointer looks fine except when it is over certain text editors such as Visual Studio where it seems to "dissappear". It only vanishes when over the edit window, you can see the mouse when its over Properties and other panes. Additionally, the mouse is visible if you highlight text which changes its color. Then you can move the mouse over the highlight and see the mouse but the moment the mouse pointer tip goes off the selection, the mouse "vanishes".

The workaround I'm using for now is change the mouse pointer from the default to the Windows Black scheme and enable Pointer Shadows. The resulting mouse pointer is visible, a decent size, though a bit ugly.

This was a problem in the earlier v6 releases but went away. I suspect its a regression.

-herb
HF
 
Posts: 19
Joined: 3. Dec 2014, 01:01

Re: Mouse Pointer disappears in Text Editor

Postby HF » 15. Jan 2020, 17:07

I just installed VirtualBox 6.1.2 for which the release notes describe many graphics fixes and improvements.

The problem that I was consistently having with the mouse pointer over text editors such as Visual Studio is fixed. I can switch back to the default mouse and the problem I described in the previous post no longer occurs.

Thanks.
HF
 
Posts: 19
Joined: 3. Dec 2014, 01:01

Re: Mouse Pointer disappears in Text Editor

Postby mpack » 15. Jan 2020, 19:10

HF wrote:The problem that I was consistently having with the mouse pointer over text editors such as Visual Studio is fixed [in 6.1.2].

That is good news. Thanks for reporting back.

Sadpanda has not been back here since November, so I'm just going to go ahead and mark the topic solved.
mpack
Site Moderator
 
Posts: 30672
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 26 guests