Issues after host resumes from Sleep/Standby: slow video playback and no network connection

Discussions related to using VirtualBox on Windows hosts.

Issues after host resumes from Sleep/Standby: slow video playback and no network connection

Postby xxxyyy » 23. Jul 2019, 18:34

Using the latest VB6 on Windows 7, I consistently have issues with a virtual machine (also W7-based) after the host machine resumes from sleep (standby).

After resuming from standby, the guest virtual machine exhibits the following problems:

• Video playback (in-browser video such as GfyCat/Giphy/YouTube/streaming sites etc.) is in slow motion. Doesn't seem like a performance problem because the video can be "sped up" i.e. set to 2x speed and it plays OK.

• Network adapters lose their connection and have to be reset in order to be used again. I reset them by changing their promiscuous mode and then changing it immediately back again. This lets the adapters work again.

Both of these problems are extremely annoying because they require the guest to be rebooted to fix them.

Any ideas?
xxxyyy
 
Posts: 1
Joined: 5. Jun 2019, 00:04

Re: Issues after host resumes from Sleep/Standby: slow video playback and no network connection

Postby scottgus1 » 24. Jul 2019, 14:08

I'ts been a couple days since you posted, I think this may be an uncommon issue?

Only thing I could suggest is not to let the host sleep or standby. I have always turned off these settings on my hosts. Of course, a laptop rather requires these settings...

When a PC goes to sleep the rest of the world continues turning. So all the hardware needs to be reinitialized and hopefully got back to the correct state that the sleeping OS had it before knocking off for a while. I suspect that having the extra layer of a virtualizer running may be more than the sleeping OS's can handle?

Also try pausing your guest before sleeping the host?

Try google/bing-searching about sleep & standby, with the text:
site:forums.virtualbox.org
added to your search terms to restrict the results to this forum. Maybe others have handled this issue?

Question on the "promiscuous mode" toggle that resets the network: What about just "pulling" the cable (toggling the 'cable connected' checkbox)? What does that do?

Interesting that streaming sites have an issue, because that also depends on a solid network. Is the 2x fix an exact fix, as in precisely the original speed, or is it close but still recognizably off? What happens if you reset the network then refresh the video website page. Does the video still play back half-speed-ish? While the streaming sites are playing slow, does your guest play video files locally saved in the guest disk fine, or slow too?
scottgus1
Site Moderator
 
Posts: 13291
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: fth0, Martin and 47 guests