Page 1 of 1

All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 26. May 2019, 16:59
by szx
Hello,

I updated my Windows 10 x64 Pro machine to 1903 today and it appears that all of my VirtualBox VMs no longer work: every time I try to start any of them the following errors pops up:

Code: Select all   Expand viewCollapse view
Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code:
E_FAIL (0x80004005)
Component:
ConsoleWrap
Interface:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


I don't have Hyper-V enabled. But I did enable Hyper-V at some point after the update, and then disabled it again.

Has anybody had this issue? Will it be solved in an upcoming version of VirtualBox?

VirtualBox version: 6.0.8 and 6.0.9 r130662

Re: All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 26. May 2019, 20:05
by andyp73
As well as disabling Hyper-V itself you also need to disable everything that uses it. The list we currently have is:

  • Application Guard
  • Credential Guard
  • Device Guard
  • <any> * Guard
  • Containers
  • Hyper-V
  • Virtual Machine Platform
  • Windows Hypervisor Platform
  • Windows Sandbox
Release 1903 may well have added others. Microsoft may also have changed something in one of the APIs and VirtualBox needs a tweak to go along with it.

-Andy.

Re: All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 28. May 2019, 17:50
by szx
Thank you for the response. It looks like I needed yet another reboot - I tried to start a VM today and it worked flawlessly. Not sure what changed.

Re: Error Code: Windows 10 v. 1903 and VB 6.0.6, Debian VM

PostPosted: 29. May 2019, 13:40
by vincevan
Got this error too after updating to the latest windows 10. My VBox didn't run anything after I updated and installed Windows Sandbox. Tried to use vmware on friend's pc and got the error, and then i directed to the resolution in microsoft site (sorry i can't post a link, new account).

From there, try to disable the policy settings in gpedit.msc: Computer Configuration -> Administrative Templates -> System -> Device Guard -> Turn On Virtualization Based Security to Disable.

And delete all registers in HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\

Then I downloaded the "Windows Defender Device Guard and Windows Defender Credential Guard hardware readiness tool" (Google it, first link, sorry can't post links, link's end is details.aspx?id=53337), extract and run the ps1 file in powershell as admin using
Code: Select all   Expand viewCollapse view
& DG_Readiness_Tool_v3.6.ps1 -Disable -AutoReboot

After run the script, your computer will restart and will prompt you to disable credential guard on boot and one other prompt (i forgot), press F3 to accept and pc will boot normally.

Cheers.

Re: All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 29. May 2019, 16:16
by socratis
@vincevan
Thank you for the information, I have the suspicion that it's going to come in handy.

You posted in a similar topic in the Windows Pre-Releases area, since when 1903 was in beta. No meaning in posting there, I moved your post to a similar thread in the normal Windows area. And I'm going to fix your URLs...

Re: All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 15. Aug 2019, 13:52
by Lapis_Lazuli
I have the same problem, but my host is Windows 10 Home (not Pro) 1903 build 18362.295. VirtualBox worked before upgrading to 10 from Windows 8.1 Home build 6.3.9600.

Re: All VMs fail to start with VERR_NEM_VM_CREATE_FAILED

PostPosted: 15. Aug 2019, 13:56
by scottgus1
Lapis, see I have a 64bit host, but can't install 64bit guests Carefully go through each command in the 2nd & 3rd posts.

Also, search the forums before posting. If you really do have a VERR_NEM_VM_CREATE_FAILED error, there are a tremendous number of similar posts showing the same solution.

Also, start a new post if you don't have exactly the same characteristics as the OP.