Page 3 of 3

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 9. Jul 2019, 00:14
by Galek
I have the same problem, after various changes i decline to rollout to older windows 1803 and now everything is ok.

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 12. Jul 2019, 14:39
by Ranguno
Had a similar problem after updating to Windows 1903, namely a bluescreen error at virtual machine start. Details: https://forums.virtualbox.org/viewtopic.php?f=6&t=93853&p=452686#p452686

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 13. Jul 2019, 01:14
by Macx
To @Fast_Zombie and @socratis regarding removing VMWare related registry entry:
I had a similar issue (W10H1 upgrade-->VB works-->Windows Sandbox install --> VB don't work --> WS uninstall, reboot, all H-V settings off, but in systeminfo.exe note that A hypervisor has been detected --> VB don't work).

I had also VMWare Player 15 installed (didn't use it in fact), after uninstalling it and rebooting VB works - so it is somehow related to VMWare..

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 28. Jul 2019, 17:06
by soltaran
I've had no issues whatsoever.

I highly doubt that it's possible to have two hypervisors running at the same time, and I'm pretty sure that, knowing Microsoft, Sandbox will be running in the background for whoever is having the problem. Simplest solution? Check the list of running services .. there are 8+ Hyper-V on my system - all stopped.

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 5. Aug 2019, 08:53
by Yikes
caspertone2003n wrote:My case: W10x64, updated to 1903

Finally, all come to normality, just after cleaning registry with CClean.

CT


That was helpful, thanks. Turning Sandbox back off again was not sufficient; I had to also clean the registry. (I used Ace Utilities.) That did the trick.

Without your registry-cleaning tip, I might have spent days working on this.

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 7. Aug 2019, 09:29
by jc508
Hi,
I had the exact same error as reported in the original post, again after Windows 10 updated to 1903 build 18362.267 (without asking I might add)
The difference may be that, seeing I had the update anyway, I might try the 'sandbox' - so it might have turned on hyper-v

I applied the following from another, older, post see topic 87237
Code: Select all   Expand viewCollapse view
bcdedit /set hypervisorlaunchtype off
dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

followed by a re-boot and all the virtuals started to work again.
I have no idea what thise commands do - but hey magic is magic
Currently using version 5.2.30 so its not in vmware simulaton mode.
JC

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 11. Aug 2019, 16:10
by lczub
Thanks for this helpful discussion.
FYI, in my case the solution was the deactivation of the Windows features Hyper-V and Containers, which was enabled after the Win 10 1903 upgrade. All the other settings were still disabled. A de- and reinstallation of VB was not necessary (My VB version was 6.0.10).

My suggestion, why these feature were enabled after the upgrade - I tried some month ago Docker and switch back to VB.
Therefore, I had to activate Hyper-V and deactivate it afterwards - see Stackoverflow - virtualbox Raw-mode is unavailable courtesy of Hyper-V windows 10. This was all done longtime ago before the Win 10 1903 upgrade and VB was running without problems again, but maybe not all feature changes by Docker were reset completely, which then let the Win10 upgrade decide to enable the above features.

Regards LC

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 8. Sep 2019, 16:22
by klausp
Thank you also from my side.

I have VirtualBox 6.0.10 running and a Windows 10 1903 Guest 18362.329 with a 64-Bit Fedora 30 Host.

After Sandbox activating nothing worked in VirtualBox.
I tried all the solutions here, but only the last solution worked for me, regarding the
Code: Select all   Expand viewCollapse view
dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

In this style I deactivated (again) all the features in question, before that I ran
Code: Select all   Expand viewCollapse view
dism.exe /Online /Get-Features

With all these original names I deactivated additionally:
Code: Select all   Expand viewCollapse view
dism.exe /Online /Disable-Feature:HyperVisorPlatform
dism.exe /Online /Disable-Feature:VirtualMachinePlatform

After a restart everything worked and also the systeminfo gave the original detailled feedback.

My impression is that the activation/deactivation of features in the GUI(!) does not work perfectly.
Deactivation in the PowerShell worked then...

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 21. Oct 2019, 16:22
by tush
Having same issue with my VBox not working at all took every steps as said above by experts....
attaching screenshot for more info.... is this some kind of bug or what?

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 21. Oct 2019, 17:39
by socratis
@tush
tush wrote:is this some kind of bug or what?

If you had read the whole thing, you wouldn't be asking if it's a bug or not. Unless you want to call Hyper-V a bug, that's a stretch actually... ;)

Re: VirtualBox fails after Windows 10 1903 upgrade

PostPosted: 3. Nov 2019, 09:53
by MDD
Try running the command
bcdedit / set hypervisorlaunchtype off

and then rebooting...

This worked for me