VirtualBox 6.0 and Hyper-V

Discussions related to using VirtualBox on Windows hosts.

Re: VirtualBox 6.0 and Hyper-V

Postby Dormanil » 6. Jun 2019, 17:49

Hello there, another user trying to get VirtualBox and Hyper-V to behave.

AMD Ryzen 1600 @ 3500 MHz
Windows 10 Pro v1903, Build 18362.145
Hyper-V, Windows Hypervisor Platform, and AMD-V are enabled
VirtualBox Version 6.0.8 r130520
Code: Select all   Expand viewCollapse view
Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Full log in the attachments.
Attachments
Windows 10 Dev-2019-06-06-17-46-58.log
(33.31 KiB) Downloaded 65 times
Dormanil
 
Posts: 1
Joined: 6. Jun 2019, 17:38

Re: VirtualBox 6.0 and Hyper-V

Postby xpusostomos » 8. Jun 2019, 11:54

Hi all, another user here who can't get it working with Hyper-V (Latest Win-10 host, Linux guest) without getting the IO-APIC kernel panic.

I'd just like to be able to run Linux and the Android emulator (from Android Studio) at the same time. I can run the former with Hyper-V disabled, and the latter with it enabled, but not both at once. I can't even run Android Studio emulator on Linux guest, it seems to freeze up with 100% cpu or something.
xpusostomos
 
Posts: 2
Joined: 8. Jun 2019, 11:50

Re: VirtualBox 6.0 and Hyper-V

Postby satabydj » 15. Jun 2019, 11:03

Hola desde españa. a mi tambien me da el error 805. Desde la actualizacion windows 10 may update no me va el virtualbox.
satabydj
 
Posts: 1
Joined: 15. Jun 2019, 11:01

Re: VirtualBox 6.0 and Hyper-V

Postby neobo » 22. Jun 2019, 19:14

Hi all,
I'm trying to configure VirtualBox 6 in the same host machine that I use for Docker (that requires Hyper-V).

I have done the following configurations:

Enabled Windows Feature
  • Hyper-V
  • Windows Hypervisor Platform (sticky notes of this post)
fyi Windows Sandbox and Windows Subsystem for Linux are also enabled (but is not required for this topic)

Host Info
  • CPU: Intel i5-7200 Virtualization Enabled
  • RAM: 16 GB
  • OS: Windows 10 - Version 1903 (Build 10362.30)
Behaviour
  • Docker for windows is working as expected
Goal
  • I want to install Ubuntu Linux x64 on VM
  • Any configuration on System > Acceleration are useless and VM does not start with the following error
    Code: Select all   Expand viewCollapse view
    Failed to open a session for the virtual machine ubuntu.

     (VERR_NEM_MISSING_KERNEL_API).

    VT-x is not available (VERR_VMX_NO_VMX).

    Result Code: E_FAIL (0x80004005)
    Component: ConsoleWrap
    Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
Any hint ?
neobo
 
Posts: 4
Joined: 22. Jun 2019, 18:55

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 22. Jun 2019, 21:26

@neobo
We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby neobo » 23. Jun 2019, 00:13

Thanks for your response.
Here attached VBox log file
Attachments
VBox.zip
VBox log file
(6.5 KiB) Downloaded 43 times
neobo
 
Posts: 4
Joined: 22. Jun 2019, 18:55

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 23. Jun 2019, 02:46

Nothing obvious, I'm sorry...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby neobo » 23. Jun 2019, 12:51

Thanks for your time.

Any advice about additional attempts to do ?
Actually my host could be a good environment to investigate and make the experimental feature (or its documentantion) stronger.
neobo
 
Posts: 4
Joined: 22. Jun 2019, 18:55

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 23. Jun 2019, 13:00

You know what the message the developers put in the log is?
00:00:06.074744 HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
00:00:06.138105 NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...
Which means it's not a certain thing. What makes it tick? I have no idea.

The problem is that the "Missing Kernel API" error that you get tells me that some component of Hyper-V is not there. Can you tell me which components are enabled in the "Control Panel" » "Programs and Features" » "Turn Windows features on or off"? That might be helpful...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby neobo » 23. Jun 2019, 14:38

Here attached a screenshot with all windows features status (the scrollbar is not part of the image, it's a real scrollable image)

You can also find a textual version obtained running the following powershell command (with admin rights)

Code: Select all   Expand viewCollapse view
> Get-WindowsOptionalFeature -Online
Attachments
features.txt
Get-WindowsOptionalFeature -Online
(17.06 KiB) Downloaded 65 times
windows-features.png
windows-features.png (93.16 KiB) Viewed 13265 times
neobo
 
Posts: 4
Joined: 22. Jun 2019, 18:55

Re: VirtualBox 6.0 and Hyper-V

Postby xpusostomos » 24. Jun 2019, 12:09

When a plain vanilla Virtualbox, hyper-v, ubuntu install simply fails to boot, you'd think someone in the know could figure it out.
xpusostomos
 
Posts: 2
Joined: 8. Jun 2019, 11:50

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 25. Jun 2019, 12:28

@neobo
I had an idea... Disable all Hyper-V related services, until you can see a VM starting with proper virtualization and you see the purple V icon (Image) and not the green tortoise (Image) when Hyper-V is active.

Then re-enable the Hyper-V related services/modules. Maybe that will jolt the whole thing back into normalcy.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 25. Jun 2019, 12:31

@xpusostomos
With the amount of information given, not even Zeus himself could figure it out! :)
Where's your log? And please read my message a couple of posts back about how this whole thing "might" work...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby kwinz » 26. Jun 2019, 14:40

I tried to start a container with VirtualBox 6.0.8 on Windows 10.0.1709 with Hyper-V enabled. I finally gave into enabling Hyper-V because I need Kubernetes for work and it's just easier that way.

I got this error from VirtualBox:
Code: Select all   Expand viewCollapse view
VirtualBox 6.0.8 HMR3Init: Attempting fall back to NEM:VT-x is not available [....]
NEMR3Init: Native init failed: VERR_NEM_MISSING_KERNEL_API.

After reading here that I need at least Windows version 10.0.1809
socratis wrote:So, if you can't find the DLL and VirtualBox complains, there's a really valid reason; you're running an older version of Win10 that doesn't have that capability enabled. And mind you, that's the version (17083, pre-1803) that this was enabled. So you'll need Win10 1803 or 1809 to have it work properly. The newer the build, the better I expect it to be supported...

I now forced an upgrade to 10.0.18362.175.

Now when I start the virtual machine I get am prompted in multiple UAC elevated prompts and finally I get an error that is different from before Windows upgrade:

VERR_NEM_VM_CREATE_FAILED
Code: Select all   Expand viewCollapse view
Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Code: Select all   Expand viewCollapse view
00:00:03.410098 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={872da645-4a9b-1727-bee2-5585105b9eed} aComponent={ConsoleWrap} aText={Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED)}, preserve=false aResultDetail=-6805
00:00:03.410877 Console: Machine state changed to 'PoweredOff'
00:00:03.461031 Power up failed (vrc=VERR_NEM_VM_CREATE_FAILED, rc=E_FAIL (0X80004005))

Moreover: it is really annoying that sometimes when I view the log files the VirtualBox application just terminates!!

Full logfile:
https://www.dropbox.com/s/bhy4lyje6qwmb ... 2.log?dl=1
Last edited by kwinz on 29. Jun 2019, 15:03, edited 1 time in total.
kwinz
 
Posts: 10
Joined: 26. Jun 2019, 14:26

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 26. Jun 2019, 14:58

kwinz wrote:[will post link once I have been a forum member for 1 day]

Please ZIP and attach the VBox.log here, locally.

Image
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 36 guests