Page 10 of 20

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 3. Aug 2019, 05:52
by loyukfai
How's the performance? Is Sandbox enabled on your box?

Cheers.

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 4. Aug 2019, 00:20
by TomL12953
That did it for me! It runs incredibly slowly, though.

Tom L

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 4. Aug 2019, 00:40
by TomL12953
How do you enable sandbox mode? Is it in VirtualBox or in Hyper-V?

Tom L

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 5. Aug 2019, 00:32
by jstangroome
How do you enable sandbox mode? Is it in VirtualBox or in Hyper-V?


Windows Sandbox, see attached screenshot. For more information, see December article on Windows Kernel Internals techcommunity (sorry I can't post URLs).

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 5. Aug 2019, 02:38
by TomL12953
WesleyRast wrote:This is what fixed it for me. Hyper-V is just cancer for running anything else related to virtual machines.

Open an admin Powershell and type the following to disable Hyper-V:
Code: Select all   Expand viewCollapse view
bcdedit /set hypervisorlaunchtype off

Then restart your machine. `vagrant up` will now work with no problem.


It's no solution at all. The whole point of this thread is to be able to run Hyper-V AND VirtualBox at the same time.

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 7. Aug 2019, 01:03
by daMaskf
RColbert wrote:To make this work for me on the current 20H1 Insider release of Windows 10, I added the line mentioned in a previous post to the ExtraData section of the %userprofile%\.VirtualBox\VirtualBox.xml config file.

<ExtraDataItem name="VBoxInternal/NEM/UseRing0Runloop" value="0"/>

64bit Windows and Linux VMs are able to run.


After a few days of struggling, this got me up and running. 8)

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 7. Aug 2019, 12:10
by jmar83_the2nd
Thank you for your informations! :-)

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 9. Aug 2019, 06:17
by loyukfai
This customization:

Code: Select all   Expand viewCollapse view
<ExtraDataItem name="VBoxInternal/NEM/UseRing0Runloop" value="0"/>


1. Works with SandBox too?
2. Performance?
3. VB's recommended solution?

Gotta find out :)

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 11. Aug 2019, 23:39
by kwinz
When can I expect a new VirtualBox release that feels less alpha release and supports

  • Running on the same system as Hyper-V
  • automatically suggests enabling or sets the proper Windows settings by itself
  • Has sane error messages
  • Does not need UseRing0Runloop workaround
  • No or little performance penalty
  • just works?

I am generally curious. Thanks for your work!

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 12. Aug 2019, 16:40
by GastlyCold
I got it working on my XPS with "fast ring" on Win10 Pro enabled. (I will post a follow up with logs/settings once I get them collected)

I have Sandbox and WSL2 working already.

What I noticed is that about every 4th time I boot the same Linux guest, it "hangs" with "dracut-initqueue timeout' at startup.

It is not consistent on this. I am using XFS for the filesystem in the guest (MBR, primary partitions... this usually works best).

I see the "turtle" at the bottom. But. performance is certainly acceptable.

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 12. Aug 2019, 16:44
by GastlyCold
loyukfai wrote:This customization:
Code: Select all   Expand viewCollapse view
<ExtraDataItem name="VBoxInternal/NEM/UseRing0Runloop" value="0"/>

1. Works with SandBox too?
2. Performance?
3. VB's recommended solution?

Gotta find out :)

I was getting startup crashes on the instances until I enabled this in my CentOS template image. Now everything is fine.

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 16. Aug 2019, 19:13
by Larswa
Hey guys ... good work digging out this setting.
<ExtraDataItem name="VBoxInternal/NEM/UseRing0Runloop" value="0"/>

One question though. Does this only work on the insider builds of windows 10? I still can't get it to work on my windows 10 1903 build 18362.295

I guess this depends on some future work to make the underlying hyperv apis accessible to 3rd party providers like VirtualBox and VMWare workstation, right?

/Lars

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 16. Aug 2019, 19:44
by GastlyCold
After some long nights of testing and installing from scratch, I suspect that the device drivers in the Linux guest additions is causing unpredictable behavior.

I *believe* this is the culprit with one of the drivers that gets loaded as I am having issues with booting and the Vbox error logs (at the host) are looking mostly normal.

My recommendations to folks is hold off on installing the Guest Additions in their Linux VMs until a useful bug report can be submitted.

The testing I did was with CentOS 7.5.1804 with Virtualbox 6.0.10 on an i7 XPS 9570 running the latest patches.

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 23. Aug 2019, 08:38
by RustyPuma
@BillG Thank you!

If it is better not running VirtualBox while Hyper-V is enabled(i.e. for dockers APPs), and disable Hyper-V and reboot Win10 when VirtualBox needs to run VM?

Will this start the VirtualBox again, and the VMs that had been created be safe to start and run as usual?

Re: VirtualBox 6.0 and Hyper-V

PostPosted: 26. Aug 2019, 04:40
by BillG
Your vms will not be affected, nor will the VirtualBox program (except that it will now work properly because the Windows hypervisor is not running).