[Fixed] Microphone not working on Windows 10 guest inside Windows10 host (#17597)

Discussions related to using VirtualBox on Windows hosts.

[Fixed] Microphone not working on Windows 10 guest inside Windows10 host (#17597)

Postby afs » 20. Mar 2018, 20:52


ModEdit; related ticket: #17597: Audio input broken on Windows 10 v1709 hosts

Hi,

I'm running Windows 10 (64 bit) VM inside windows 10 (64 bit) host using latest Virtualbox 5.2.8r121009. Host machine is microsoft surface book with i7 processor and 16GB RAM.

For some reason microphone is not working inside the guest vm. Audio works fine. I tried with both USB and audio jack headsets. I even tried using the AC97 Audio controller and then installed Realtek driver on the guest (as per other forums) but that didn't resolve the issue either.

I will appreciate any help with this. Please let me know if you require any other information.

Thanks
Last edited by socratis on 27. Dec 2018, 19:48, edited 1 time in total.
Reason: Marked as [Fixed].
afs
 
Posts: 1
Joined: 20. Mar 2018, 20:48

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby JorgenCAB » 21. Mar 2018, 10:54

I have the exact same setup and my microphone does not work. I also tried the AC97 driver but that does not work either. My hardware is a HP ZBOOK G3 so that is the only difference.''

Help is appreciated.
JorgenCAB
 
Posts: 8
Joined: 21. Mar 2018, 10:51

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby Roger Reghin » 25. Mar 2018, 16:24

I have the same problem on my Windows 10 x64 host, Windows 7 x32 guest.

In VBox version 5.2.4 the sound worked poorly, but worked, on both Windows 10 and MacOSX hosts.

In VBox version 5.2.6 the sound just stopped working at all, on both Windows 10 and MacOSX hosts. I had to downgrade to 5.2.4 right after the upgrade to 5.2.6.

Version 5.2.8 solved all MacOSX audio problems (it's very nice and smooth now), and solved the sound output problems on Windows 10 (it's much clear and not noisy anymore), but introduced this sound input problem (no microphone).
Roger Reghin
 
Posts: 1
Joined: 25. Mar 2018, 16:17

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby hmo » 25. Mar 2018, 17:45

afs wrote:For some reason microphone is not working inside the guest vm.

Ticket #17597
hmo
 
Posts: 5
Joined: 16. Apr 2017, 12:32

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby VBoxUser123456 » 3. Jul 2018, 19:01

Same Issue on winxp guest and win10 Host. Last working Version 5.2.6 r120293 (Qt5.6.2)!
Please fix this. Thanx!
VBoxUser123456
 
Posts: 1
Joined: 3. Jul 2018, 18:58

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby ptram » 22. Aug 2018, 03:08

I have the same issue on a Mac Sierra host (Windows 10-64 bit guest). ICH AC97 audio driver selected, but no audio in or out is allowed in Windows. The Device Manager can't even see the connected audio devices.

I'm sure I've used at least the audio in with this same audio in device (on an older Mac OS, VirtualBox and Windows).

Paolo
ptram
 
Posts: 44
Joined: 10. Dec 2008, 18:58

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby socratis » 22. Aug 2018, 09:53

ptram wrote:Windows 10-64 bit guest ... ICH AC97 audio driver selected

Why? Why did you change the default? Please change it back to IntelHDA. There are no drivers for AC97 in Win10, of course it won't work!!! What's next, Sound Blaster 16? :shock:

The defaults are there for a reason; they work. If they don't, then you try to find out why the defaults don't work, you subscribe to the ticket to watch its progress. You don't go around changing hardware randomly and without at least an educated guess...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby ptram » 22. Aug 2018, 15:29

Socratis, sorry, but I didn't even remember having changed that setting. Maybe is was automatically chosen, because I've the ICH9 chipset selected. Why I selected this instead of the default PIIX3 I don't know, but maybe it was because this supported Mac hosts better?

However, choosing the IntelHD sound option reactivated my in and out audio. I can confirm that an old Logitech Quickcam Fusion's mic works fine with its own old Win7 driver (but it might have worked without it, but I could not test it with the audio not working).

Paolo
ptram
 
Posts: 44
Joined: 10. Dec 2008, 18:58

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby socratis » 22. Aug 2018, 17:52

ptram wrote:Maybe is was automatically chosen, because I've the ICH9 chipset selected.
1) No, absolutely not, and 2) Why the ICH9? Your host has absolutely nothing to do with that. You're creating the guest recipe. And ICH9 is experimental, OSX guest only for a good reason; they (OSX guest) don't support PIIX3.

Do *NOT* mess with the defaults if you don't know what you're doing, and then complain that it's broken! ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby ptram » 22. Aug 2018, 19:34

Understood. I'll not touch anything in the room!

Paolo
ptram
 
Posts: 44
Joined: 10. Dec 2008, 18:58

Re: Microphone not working on Windows 10 guest inside Windows10 host

Postby socratis » 22. Aug 2018, 20:33

Oh, *do* experiment. See what breaks things. See if you can revert.
But don't do it with your main VM. Cloning a VM is such a quick operation, that it's literally a no-brainer to clone a VM and test things out there, where you couldn't care less if it breaks or not. Just delete the clone and start anew.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], Martin, qiping and 34 guests