Page 1 of 1

Video won't record (#17307)

PostPosted: 10. Jan 2018, 03:57
by ricecrispies

[ModEdit; related ticket: #17307: Video capture doesn't work after upgrade from 5.1.30 to 5.2.0]

I am running a Windows 95 guest on Windows 10 host. I am trying to record video, but without success. When I choose view—>record-video the first time I get an error saying that video recording cannot be started. The second time I select it, I get the film rolling animation at the bottom of the guest's window, but the size of the output movie file remains at between 0 and 270 bytes. And the same thing happens when I choose view—>record-video to stop the recording. The first time, I get an error saying that recording could not be stopped. The second time, the film rolling animation stops. How can I get video recording to work?

Re: Video won't record

PostPosted: 10. Jan 2018, 10:44
by mpack
This is not a feature that I use, nor is it well documented. It may be that it requires the Guest Additions, which of course do not exist for Win9x guests. If you have screen recording software for the host then you should be able to capture guest graphics that way.

Re: Video won't record

PostPosted: 10. Jan 2018, 12:54
by michaln
It does not require GAs. It's just... not working great. Opening a ticket with actual details might be helpful.

Re: Video won't record

PostPosted: 10. Jan 2018, 13:00
by socratis
michaln wrote:Opening a ticket with actual details might be helpful.
I've been meaning to do that since before the holidays. A quick summary can be found in: viewtopic.php?f=6&t=85660 but I will definitely open a new ticket. Tonight...

Re: Video won't record

PostPosted: 10. Jan 2018, 13:06
by socratis
I just checked, the OP in the other thread actually opened a ticket, "#17307: Video capture doesn't work after upgrade from 5.1.30 to 5.2.0". I'll update the ticket with my findings, and have this discussion (and the other one) pointing to the ticket, and vice versa.

Re: Video won't record (#17307)

PostPosted: 10. Jan 2018, 13:56
by ricecrispies
Thank you.

Re: Video won't record (#17307)

PostPosted: 2. Mar 2018, 00:39
by socratis
The issue has been fixed with 5.2.9 r121058 (or later) from the test builds. Please verify or deny if it works or not in ticket #17307.