Failed to attach USB device... busy with previous request

Discussions related to using VirtualBox on Windows hosts.

Failed to attach USB device... busy with previous request

Postby Admiral » 4. Dec 2017, 07:00

Host: Windows Version 10.0.16299 Build 16299
Virtualbox 5.2.2 with extension pack
Guest: MSEdge Win10 and Kali Linux (kind of irrelevant, I believe it is a host problem)
USB NIC: Realtek 8812au; Alfa AWUS036ACH

This seems to be a problem with my windows host but I have no idea why. I get the following error:
realtek failed to attach.png
realtek failed to attach.png (14.28 KiB) Viewed 109 times


Things I have tried:
- enabled USB 2.0, created a filter with the device attached with guest down, then booted the guest
- deleted upper filters using regedit
- tried different USB ports
- disabled the NIC on the host
- removed the NIC from the host
- uninstalled Vbox and reinstalled as admin

Something that I noticed is that when I remove the NIC, it still shows under the USB tab. I know that VBox on my mac automatically removes the NIC from the USB menu when I disconnect the NIC, but on Windows 10 it still remains. I am not sure why it does that. Screenshot for reference:
realtek device.png
realtek device.png (64.94 KiB) Viewed 109 times


I believe is has something to do with Win10 host. Maybe there's a service that is using it but I have no idea what or why since I already disabled and even removed the device from my host.
I do not have wireshark installed on my host so the USBPS thing doesn't apply.
Any help is greatly appreciated!
Admiral
 
Posts: 4
Joined: 25. Nov 2017, 09:30

Re: Failed to attach USB device... busy with previous request

Postby socratis » 4. Dec 2017, 08:50

Please read the following thread: USB basics and troubleshooting, all of the posts. If you still have a problem after reading through the whole thing, please follow the advice of the last post.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12692
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed to attach USB device... busy with previous request

Postby Admiral » 11. Dec 2017, 11:20

Thanks. I was able to navigate to this post: https://forums.virtualbox.org/viewtopic.php?f=6&t=39104&start=30#p373718

For future reference: make sure to not disable the device on your host. Keep the device enabled, and allow the USB filter to capture the device.
Admiral
 
Posts: 4
Joined: 25. Nov 2017, 09:30


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 52 guests