Sound Problem With VirtualBox -5.2.x branch

Discussions related to using VirtualBox on Windows hosts.

Sound Problem With VirtualBox -5.2.x branch

Postby Ascadix » 30. Nov 2017, 21:03

Hi,

Ok, there is already a thread "Sound Problem With VirtualBox-5.2.0-118431" , but problem persist in 5.2.2.

I have the pb with VBox 5.2.0/5.2.2 , the sound played from VM is higly distorded, present lot of crackling .

- Guest Windows (XP32bits, w7-32bits, w7-64bits, w10-64bits) starting sound is always distorded
- Sound from media player (WMP or other like VLC, MPC-HC, MovierMaker) start ok but goes bad after a few minutes of playing.
- Stop/restart of playing restart the countdow and plays ok for a new few minutes.

Host computer is multi-boot : Win7-64bits or Win10-64 bits, same pb.

Rollback VBox host to 5.1.30 and all sounds plays ok, even without rollback of VMGuest additions.
Ascadix
 
Posts: 1
Joined: 30. Nov 2017, 20:46

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 4. Dec 2017, 21:52

I've just uploaded a new 5.2 test build which contains more fixes regarding "crackling" and audio distortions. Could you please give these
builds a try and report back if these fix the issue for you? You can get the latest 5.2 test builds here: https://www.virtualbox.org/wiki/Testbuilds

Thank you!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby xplicit » 5. Dec 2017, 07:42

I have the same issue with v5.2 of Virtual Box. In v5.1.30 there are no problem with sound. I downloaded and installed test build (VirtualBox-5.2.3-119405-Win.exe), here is the description of issue:

I use Ubuntu mate 16.04 as a guest operating system with vbox guest installed. I start OS and run rhytmbox. I choose the radio and start listening.

First 2 mins and 14 seconds the sound is fine. Then it becomes distorted for 21-23 seconds and then it becomes normal again. After next 2:11 it becomes distorted again. I made measurement for a several minutes with timer and here are my results:

duration (mins:secs)
2:14 - normal sound
0:22 - distorted sound
2:15 - normal sound
0:20 - distorted sound
2:11 - normal sound
0:23 - distorted sound
2:12 - normal sound
0:21 - distorted sound
2:10 - normal sound
0:23 - distorted sound
2:12 - normal sound
0:20 - distorted sound
2:14 - normal sound
0:20 - distorted sound
2:06 - normal sound
0:20 - distorted sound
2:16 - normal sound
0:18 - distorted sound

You can see that the is a loop with total duration ~2:44-2:45 in which sound consequently changed from normal to distorted and then back again.
xplicit
 
Posts: 4
Joined: 5. Dec 2017, 07:23

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 5. Dec 2017, 11:32

Could you please supply the verbose VBox.log file and the .WAV files as shown here: https://www.virtualbox.org/wiki/AudioDebug

Thank you!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby xplicit » 6. Dec 2017, 10:00

How can I attach these files? I made zip archive with wav and log file, but forum does not allow me to upload it, maybe because of its size (38mb)

WAV file is not distorted, however I heard the distortion during the playing near 3:00 from the start

Here is the link to vbox.zip file

https://www.dropbox.com/s/4d47ahs2n22jgxc/vbox.zip?dl=0
xplicit
 
Posts: 4
Joined: 5. Dec 2017, 07:23

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 6. Dec 2017, 10:50

@xplicit Just had a peek at the .zip file you provided, and the VBox.log tells that you're using the AC'97 device instead of HDA one ...can you please retry your tests with the HDA device being selected? Also, please supply *all* .WAV files as described in the article without renaming them. Thanks!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby AlexMK » 6. Dec 2017, 20:19

I've just updated to 5.2.3 r119405 and the problem is still persist (Win 10 host and Ubuntu guest). One small observation that might help. I started the video on Youtube to check the sound and first 2-3 minutes it worked fine, but then the problem came back.
AlexMK
 
Posts: 3
Joined: 23. Nov 2017, 21:13

Re: Sound Problem With VirtualBox -5.2.x branch

Postby xplicit » 6. Dec 2017, 20:45

Here are logs and wav files with Intel HDA device selected. Still hear distortion every 2 minutes.

https://www.dropbox.com/s/0yenmvpxqfc2vk4/vbox.zip?dl=0
xplicit
 
Posts: 4
Joined: 5. Dec 2017, 07:23

Re: Sound Problem With VirtualBox -5.2.x branch

Postby xplicit » 8. Dec 2017, 08:00

@pentagonik were you able to reproduce the issue?
Last edited by xplicit on 11. Dec 2017, 07:17, edited 1 time in total.
xplicit
 
Posts: 4
Joined: 5. Dec 2017, 07:23

Re: Sound Problem With VirtualBox -5.2.x branch

Postby FigNewton » 8. Dec 2017, 23:50

I am having the same issues. I have run the debug process but my files are about 7,5mb so I can't upload them to the problem record #17225 without it being 20 separate files. Either way the audio is distorted when played in the vm and is distorted in the wav files generated. Host - Win10, vm - Win7. Using HD audio driver and the Vbox 5.2.3r119405(Qt5.6.2). There's a bad crackling sound when the audio is being played back. I was at 5.0.40, but had to upgrade to 5.2 because of the hardening issue when my Win10 did a major upgrade.

I am hoping there is somewhere I can upload/email this file since I don't have a dropbox and the VirtualBox ticket system only allows a 512K upload.
FigNewton
 
Posts: 10
Joined: 3. Jun 2015, 00:38

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 11. Dec 2017, 13:00

@xplicit Thanks for the files -- I've downloaded those and reviewed them -- the .WAV files sound ok, I didn't hear any distortions in there. If I've overhead something, can you please point me to the exact time code so that I can re-review them?

Also, does it make any difference if you have any host load (CPU stress or disk I/O, for example) active?
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 11. Dec 2017, 13:35

Also, would you mind in testing yet another 5.2 test build (119577) with audio debugging enabled? This should produce another set of diagnosis .WAV files which hopefully should help us working further on the issue. Thank you!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Air Force One » 11. Dec 2017, 23:51

First of all thank you for still taking care about this issue. Second: you changed the debugging code, so now on both of my Windows systems the sound files are written not to the default temp folder, but to the newly created temp folder in the root of my system drive. Third: looks like your counter system doesn't work, because newly written sound overwrites the old one from the same source, and the old one is then lost. At the end (shutdown) all but two files was erased. So now one should backup the files every time the sound was played in the VM.

Now to the test itself. I tested on both my systems and has no distortion in the files. Everything is clear. But it’s not in the VM itself, as I told before. But the timing is different now: on my Windows 10 guest and host the stream playback is distorted for the two minutes at the beginning, then there was 30 seconds of clear sound and then distortion continued. This isn’t development, which I could call good, it’s get worse. On the Windows 8 host / Windows 7 guest the distortion can be heard for 30 seconds at the beginning and then at 4 minutes and 30 seconds.

If you like to hear the distorted sound, I already posted the direct recording by Audacity in the ticket. Somebody else recorded heavily distorted MP3 playback by some device later in this ticket as M4A. But the dumped files are OK there. Probably we should dump at some other place in the sound playback chain?

Win7 logs and files
Win10 logs and files
Air Force One
 
Posts: 11
Joined: 6. Oct 2017, 16:54

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Air Force One » 12. Dec 2017, 21:30

With audio debug turned on I have an error on shutdown in the host, not in the guest: VirtualBox.exe — Error in Application (the header of message dialog); The command in 0x11cd4255 points at memory 0xffffffff. The read process couldn‘t be executed in the memory. Press OK to close the program (the message).

Of course everything is fine if I don‘t debug the audio. I'v tested with 119620.
Air Force One
 
Posts: 11
Joined: 6. Oct 2017, 16:54


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: BillG, Exabot [Bot], Yahoo [Bot] and 23 guests