[Solved] USB device is busy with a previous request

Discussions related to using VirtualBox on Windows hosts.

[Solved] USB device is busy with a previous request

Postby BobSCA » 7. Nov 2017, 00:02

Upon guest startup, All USB devices are displayed in the Devices | USB menu. Devices which have an enabled filter show status as Captured and are removed from the host as expected. They are not, however attached to the guest, and no checkmark is displayed next to them.
Tried several devices, including a SanDisk Ultra Fit flash drive and a Nook Simple Touch Glowlight, using both USB2 and USB3 ports. When the VM is not running, both devices are recognized by the host in either port.
Tried with both Linux and Windows 10 Guest VMs (running only one at a time), same results.

Clicking on a captured device produces a message such as:
USB device 'SanDisk Ultra Fit' with UUID {c851d433-9399-4170-a131-b5a2e6016da1} is busy with a previous request. Please try again later.
Result code:E_INVALIDARG (0x80070057)

I have been through numerous forum posts on this topic, including (sorry, can't post U-R-Ls yet):
I have:
  • Disabled Windows Driver Signature Enforcement
  • Uninstalled/reinstalled VirtualBox as administrator
  • Manually reinstalled the VirtualBox USB drivers
  • Verified that there is no UpperFilters key in the registry
Yesterday, in desperation, I reinstalled the USB driver for my motherboard, rebooted, started the VM, and suddenly everything was working fine! I could repeatedly plug in various USB devices and those with filters would attach to the guest automatically and those without filters I could click on and attach to the guest manually. After rebooting the host again though, I'm back to the original problem. I tried re-installing the motherboard USB driver again, and rebooting several times, but to no avail. I can't think of anything else I've changed since things started working.

I don't know if this is meaningful, but if I run msinfo with the guest running and look at the System Drivers, it shows:
  • vboxusbmon: System, running
  • vboxusb: Manual, stopped
System specs:
  • VirtualBox Version 5.2.0 r118431 (Qt5.6.2), Extension Pack installed
  • Host: Windows 8.1 Pro with Media Center, 6.3.9600 Build 9600, 64-bit, 32GB RAM
  • Guest: Ubuntu Linux 16.04.2 LTS, 64-bit, 8GB RAM, Guest Additions installed
  • Motherboard: Asus Z87-Plus
lsusb output (guest):
  • Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  • Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
  • Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
VirtualBox logs and log from following host commands are attached:
  • VBoxManage -version
  • VBoxManage list extpacks
  • VBoxManage list usbhost
  • VBoxManage list usbfilters
  • VBoxManage showvminfo "Ubuntu 16.04.2 FlowBlade"

I'll be grateful for any suggestions on how to proceed.
VirtualBox logs
(57.53 KiB) Downloaded 10 times
Host diagnostic commands
(9.48 KiB) Downloaded 14 times
Last edited by socratis on 11. Dec 2017, 10:25, edited 2 times in total.
Reason: Marked as [Solved].
Posts: 2
Joined: 6. Nov 2017, 23:06

Re: USB device is busy with a previous request

Postby BobSCA » 10. Dec 2017, 22:59

I worked around this issue by installing a Mailiya PCIe to USB 3.0 card:

My devices plugged into those ports work flawlessly with VirtualBox.
Posts: 2
Joined: 6. Nov 2017, 23:06

Re: USB device is busy with a previous request

Postby socratis » 11. Dec 2017, 10:25

I missed your original post, but I couldn't have helped in any case, except for the following, which don't seem (at a first glance) related to your USB problem:

  • You have created two filters, one with VendorID=2080 and one with VendorID=2080, ProductID=0007. Same with another one with VendorID=0451 and VendorID=0451, ProductID=d00e. The filters with just the Vendor ID will work with both cases, you don't need the ones that provide the ProductID as well...

  • The fact that you re-installed the USB drivers and then everything was working, while at the next reboot it wasn't, tells me that something was wrong with the drivers and/or your host. Which proved to be true once you installed the PCIe USB3 card.

  • You have a couple of DLLs that are being rejected, keep that in mind if in the future you run into hardening problems. I don't know exactly what they do, but I can imagine:
    • 'C:\Program Files (x86)\Samsung\Easy Printer Manager\SmartScreenPrint\CDAKEYMonitor64.dll'
    • 'C:\Program Files\MozyHome\mozyshell.dll'
Glad you got it going. Marking as [Solved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
Site Moderator
Posts: 18647
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 32 guests