Page 1 of 1

VirtualBox can't operate in VMX root mode.

PostPosted: 9. Jul 2008, 01:07
by george_v_reilly
Host = Vista 32-bit SP1 on a Quad-Core Intel box.
Guest = Kubuntu 8.04

This guest OS worked on this host last week.

I turned it on today and first got an error about VRDP, which I worked around by setting it to port 3391. (I don't think I changed Vista's Remote Desktop settings since last week, but, anyway...)

Now I'm getting the following error as soon as I start the guest OS:

VirtualBox can't operate in VMX root mode.
VBox status code: -4011 (VERR_VMX_IN_VMX_ROOT_MODE).

Result Code:
E_FAIL (0x80004005)
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


Note: VTX is disabled in the Advanced Settings.


General
Name: Kubuntu Hardy
OS Type: Ubuntu
Base Memory: 512 MB
Video Memory: 8 MB
Boot Order: Floppy, CD/DVD-ROM, Hard Disk
ACPI: Enabled
IO APIC: Disabled
VT-x/AMD-V: Disabled
PAE/NX: Disabled

Hard Disks
IDE Primary Master: Kubuntu Hardy.vdi [Normal, 8.00 GB]

Remote Display
VRDP Server Port: 3391

PostPosted: 9. Jul 2008, 08:30
by sandervl
Some other piece of software has turned on VT-x. VirtualBox can't operate safely that way, hence the refusal to start.

PostPosted: 9. Jul 2008, 20:12
by george_v_reilly
Ah! The other piece of software would be Virtual PC 2007. If I have a VPC VM already running, I get the VBox VMX error.

On the other hand, if I start the VBox VM first, Virtual PC starts its VM without complaint. Based on your comment, I'm not sure if that's safe, but it hasn't fallen over yet.

PostPosted: 9. Jul 2008, 22:23
by sandervl
I would advise against running any two virtualization programs at the same time. VT-x and AMD-V complicate matters.

PostPosted: 16. Sep 2008, 17:46
by phasemaster
I had exactly the situation that George described, namely all of a sudden seeing the "VirtualBox can't operate in VMX root mode" error when starting a VM and finding out later that this was due to a running Virtual PC instance.

I think it's perfectly ok to ask for not having two virtualization programs running at the same time. All I would kindly like to request is to replace the error message with a more user friendly one, probably hinting towards closing any other running VM systems? I think this would add to one of the core values of VirtualBox, namely having a user friendly and intuitive interface.

Re: VirtualBox can't operate in VMX root mode.

PostPosted: 14. Aug 2009, 12:33
by aryan
Try disabling kvm module...
"modprobe -r kvm_intel" with root privileges. This worked for me...

Re: VirtualBox can't operate in VMX root mode.

PostPosted: 27. Nov 2009, 03:36
by stinkly
Thanks. That certainly worked for me on Fedora 12, 2.6.31.5-127.fc12.i686.PAE, and is a lot more pleasant option than recompiling the kernel, which I haven't had to do since I was a little girl.

Re: VirtualBox can't operate in VMX root mode.

PostPosted: 22. Nov 2010, 01:39
by Ben2K
Worked like a charm on Ubuntu 10.04. :D

Will I have to do this every time I run VB? If so, is there a "permanent" fix?

Thanks.

Re: VirtualBox can't operate in VMX root mode.

PostPosted: 4. Apr 2011, 19:16
by tuxpower
You may have qemu-kvm installed - that supplies the module.
Remove it, and you don't have to worry anymore... :)

Re: VirtualBox can't operate in VMX root mode.

PostPosted: 5. Jul 2011, 22:55
by vb1909
I encountered this error when switching back and forth between Windows Virtual PC and VirtualBox. It turns out that with Windows Virtual PC, even if you shut down the guest os and by all appearances have stopped using the VM machinery, there is still a process running that uses the VMX stuff. You can use the task manager to view all processes, find the vpc.exe process and kill it. Then VirtualBox will start up just fine.