VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR

Discussions related to using VirtualBox on Windows hosts.

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR

Postby iarsov » 9. Feb 2016, 09:29

Hello,

I am having troubles with VirtualBox 5.0.14.

I keep getting the following error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).
The OS is Windows 10 x64bit - Enterprise
Memory: 16gb
CPU: Intel i7-6700HQ
VT-x is enabled in BIOS also confirmed with Intel Processor Identification Utility
Hyper-v is not configured

Any ideas why VirtualBox doesn't recognize VT-x settings ?


Regards
Ivica Arsov
iarsov
 
Posts: 2
Joined: 9. Feb 2016, 09:24

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby socratis » 9. Feb 2016, 11:01

If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24684
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby danci1973 » 9. Feb 2016, 14:59

Since yesterday I had the same problem. The machine is a dual Xeon x5670 and VT-x / VT-d are both enabled in BIOS (double checked). It's running Windows 7 Professional 64-bit.

The only change I'm aware of was Avast Antivirus update, so I uninstalled it, rebooted the computer and after that, VirtualBox was working again.

After that, just to double check, I re-installed Avast and yes, it broke VirtualBox.

Since running Windows without anti-virus is not a good idea, I tried to install Avast with only the bare essentials (I was especially suspicious of that 'Secure Virtual Machines' option), but even so it breaks VirtualBox.

So I guess I'm loooking for a new antivirus for Windows...
danci1973
 
Posts: 3
Joined: 24. Mar 2015, 10:10

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby iarsov » 9. Feb 2016, 15:06

Yes,

I had avast anti-virus installed, but anyway I re-installed the Windows (cuz it was fresh install) and the problem got fixed.

I would assume that Avast was the issue.

Thank you!
Ivica
iarsov
 
Posts: 2
Joined: 9. Feb 2016, 09:24

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby MDHollinger » 9. Feb 2016, 16:33

I got this working finally.

In Avast, under the Troubleshooting Options page
Uncheck Enable Hardware-Assisted Virtualization.

Seems Avast must be running something in the background to create their "Sandbox" feature, and it locks up the virtualization features from being used by VirtualBox. Once I Unchecked that box and rebooted, my VBox VMs start right up!
MDHollinger
 
Posts: 1
Joined: 9. Feb 2016, 16:24

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby danci1973 » 9. Feb 2016, 19:22

MDHollinger wrote:In Avast, under the Troubleshooting Options page
Uncheck Enable Hardware-Assisted Virtualization.

Seems Avast must be running something in the background to create their "Sandbox" feature, and it locks up the virtualization features from being used by VirtualBox. Once I Unchecked that box and rebooted, my VBox VMs start right up!

Thank you, that did the trick on my machine as well. I did have to reboot, before VirtualBox worked again, even though Avast didn't require it.
danci1973
 
Posts: 3
Joined: 24. Mar 2015, 10:10

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby virtual boyx » 11. Feb 2016, 05:56

MDHollinger wrote:I got this working finally.

In Avast, under the Troubleshooting Options page
Uncheck Enable Hardware-Assisted Virtualization.

Seems Avast must be running something in the background to create their "Sandbox" feature, and it locks up the virtualization features from being used by VirtualBox. Once I Unchecked that box and rebooted, my VBox VMs start right up!


Seriously, thank you so much!

I spent whole day installing program to check vt-x, checking vt-x, installing reinstalling other programs, contacting my notebook support, finding how to enable the virtualization menu in BIOS, etc.

I was ready to give up but today I chanced upon this thread and tried your solution, and it works!

DAMNNNNNNNNNNNNNNNNNN!!!!!!!!!!! AVAST SO DAMNNNNNNNNNNNNNNNNNNNNNNNN!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

edit:
link to avast site -> https://forum.avast.com/index.php?topic=182778.0

Why did they need to turn on this option by default and not ask user? Average user might not need virtualization but I need that for working. I was really stressed yesterday, imagine if I was on tight deadline and this happen.

Sorry for the rant.
virtual boyx
 
Posts: 6
Joined: 3. Jan 2013, 05:22

Re: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX

Postby danci1973 » 14. Feb 2016, 15:04

I just got a reply from Avast today (I reported a bug) - apparently a fix has been released recently.

I don't quite understand whether the fix came from Avast (currently mine shows version 11.1.2253, release date 2.2.2016 which is not new enough) or from Microsoft as my machine received a bunch of updates from MS yesterday.

I went ahead an re-enabled Hardware-Assisted Virtualization, rebooted the machine and lo-and-behold - it works!
danci1973
 
Posts: 3
Joined: 24. Mar 2015, 10:10


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 26 guests