No Internet connection

Discussions related to using VirtualBox on Windows hosts.

No Internet connection

Postby Rob1952 » 2. Aug 2015, 09:10

Hi,

I've updated my computer from Windows 8.1 to Windows 10. Now, the running Windows 7 on virtualbox can not connect to the Internet any more! Bottom right in virtualbox I see that it is connected! Anyone have an idea why this is? Sorry for the bad english, but I am a Dutchman. Thanks for thinking with me.
Rob1952
 
Posts: 6
Joined: 2. Aug 2015, 08:53

Re: No Internet connection

Postby mpack » 2. Aug 2015, 10:24

Probably the bridged adapter was not installed. Try switching the VM to NAT mode. That will have to serve as a workaround until support for Win10 hosts is officially added.
mpack
Site Moderator
 
Posts: 27678
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: No Internet connection

Postby Rob1952 » 2. Aug 2015, 11:22

thanks for your answer. Did the setting changes to NAT, but then there is no connection with the adapter at all. Strangely enough, I put it back to the bridge and now it works again! looking after it the coming days and let you know if it still works!
Rob1952
 
Posts: 6
Joined: 2. Aug 2015, 08:53

Re: No Internet connection

Postby Rob1952 » 3. Aug 2015, 16:43

Today the internet connection is not working again and after trying a few other settings I now get this error starting up the Windows 7 in Virtualbox:


Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter' (VERR_INTNET_FLT_IF_NOT_FOUND).

Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).

Resultaatcode:E_FAIL (0x80004005)
Component:ConsoleWrap
Interface:IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Do not know what to do now!
Rob1952
 
Posts: 6
Joined: 2. Aug 2015, 08:53

Re: No Internet connection

Postby loukingjr » 3. Aug 2015, 16:50

AFAIK, host only networking is not working with Windows 10. Change the adapter for the Windows 7 guest to NAT.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: No Internet connection

Postby Rob1952 » 5. Aug 2015, 17:04

It is not working under NAT either! I have a second PC witch I upgradet to Windows 10 yesterday and their was the same problem, after a uninstall and installing VirtualBox again it is working fine on that PC. So wil make a copy of the important documents on the windows 7 on this PC and uninstall and install the virtualbox again
Rob1952
 
Posts: 6
Joined: 2. Aug 2015, 08:53

Re: No Internet connection

Postby bichu » 6. Aug 2015, 21:25

Version 5 of VirtualBox has a big problem. After installation, I can not access the internet.

Your solution "j03man" does not work, then I can always not access the internet.
"SOLUTION: Uninstall VMWare and Virtualbox, go to device manager and uninstall the LAN driver (to release bridge drivers from both virtualization programs) and installed LAN drivers again (simply right click and select "check for hardware changes).
Installed Virtual Box and problem solved "

pending a new version, you can: I managed to solve the problem and regain my active internet connection.
In Control Panel, Network connection, in the properties of Ethernet, I unchecked the box "virtualbox NDIS6 bridged networking driver".
The host computer has an active internet connection. The virtual machine will have no internet connection.
bichu
 
Posts: 5
Joined: 30. Jul 2015, 14:32

Re: No Internet connection

Postby Rob1952 » 7. Aug 2015, 18:57

Just installed the latest 5.0.1-101957 and then changed the setting from only host to my networkcard (in my case realtek PCIe GBE family controller) and everything is running correctly now.
Rob1952
 
Posts: 6
Joined: 2. Aug 2015, 08:53

Re: No Internet connection

Postby rkulagow » 9. Aug 2015, 05:23

Windows 10 released version.

I've also lost the network connection on my host unless I unselect the NDIS6 bridge on 5.0.1.-109157.

Rob1952: can you give more details about what specifically you're changing so that the host and the guests have internet access?
rkulagow
 
Posts: 2
Joined: 9. Aug 2015, 05:20

Re: No Internet connection

Postby ricksec » 15. Aug 2015, 22:30

VB5.0 team,
disabling the virtualbox NDIS6 bridged networking driver in the properties of the Ethernet card fixed my internet issue. I have a win8.1 64 AMD box. The Internet was hit and miss. Wiresharked it to SSL issues. I can get to h-t-t-p sites just fine but not h-t-t-p-s sites. Disabled NIC and went wireless and all worked OK after that. So the bridge addition to the NIC is at fault. Maybe the NDIS6 has TLS issues ??
ricksec
 
Posts: 1
Joined: 15. Aug 2015, 22:07

Re: No Internet connection

Postby ODesk » 20. Aug 2015, 13:34

I just installed 5.0.2 and had this problem with Windows 7 x64 host (5.0.0 was ok). These posts gave me the clue to open my network interface settings and unselect the VMWare Bridge Protocol service as I also have VMWare player. I also have Kaspersky and I read someone else had the same problem with that for the same reasons, so I also unticked that. I was then able to start my VBox machines no problem, so I enabled the tickboxes again and everything was fine after that.

Seems that VBox is getting its Bridge Driver bound improperly or something like that during install because of these other similar services existing and doesn't untangle itself until rewritten when fiddling with the interface settings. Doing a "diagnose" on the network interface might have fixed this too.

Anyway my problem is fixed because of this article so thanks!
ODesk
 
Posts: 7
Joined: 16. Nov 2014, 08:54


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: BillG and 34 guests