[Solved] Critical Error when opening

Discussions related to using VirtualBox on Windows hosts.
Post Reply
Circa
Posts: 4
Joined: 18. Jul 2015, 21:56

[Solved] Critical Error when opening

Post by Circa »

I've recently been having an error that is preventing me from opening a virtual machine and I don't know how to fix it.
Here is the error;
Failed to create the VirtualBoxClient COM object.

The application will now terminate.

Callee RC:
REGDB_E_CLASSNOTREG (0x80040154)
I've tried an uninstall then a reinstall and it didn't help.
I also tried
"VBoxSVC.exe /ReRegServer
regsvr32.exe VBoxC.dll"
without any luck.

The virtual machine gives this error after the first error:
The virtual machine 'Win 8.1' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\USERNAME\VirtualBox VMs\Win 8.1 redo\Logs\VBoxStartup.log'.

Result Code:
E_FAIL (0x80004005)
Component:
MachineWrap
Interface:
IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}
This was happening with version 4.x and is still happening with 5.0.
Running on Window 7 x64, guest OS is Win 8.1.

I have to have VirtualBox.exe running in Windows Vista (SP2) compatibility mode for it to even launch.

Does anyone know how I can fix this?

Update 1: ran dotNetFix and repaired dotNET, took all windows updates for dotnet. Still not working.
Update 2: I have opened a bug ticket number: 14296 (Sorry, I can't post links yet)
Circa
Posts: 4
Joined: 18. Jul 2015, 21:56

Re: Critical Error when opening

Post by Circa »

A mod can close this thread, I resolved the issue.

Here's what I had to do to fix this:

I did an In-place Upgrade install of windows 7.
Instructions here: http://www.sevenforums.com/tutorials/34 ... stall.html
(It will take a while, as in hours, then more hours to get back up to date.)

After that Virtualbox works again.

For anyone else getting this error, the In-place upgrade was the only option to resolve the issue.
Something seems to have been broken in windows.

Mods can close this thread please.
kirsche40
Posts: 7
Joined: 1. Aug 2014, 10:53

Re: [Solved] Critical Error when opening

Post by kirsche40 »

Maybe you do not need to run such an expensive solution. If the tool is available you can try to run a repair using: C:\Windows\SysWOW64\CCM\SMSCFGRC.cpl > Components > Repair

This solved the same problem on my side.

I added this possible solution to your issue.
kolma
Posts: 1
Joined: 4. Feb 2016, 15:17

Re: [Solved] Critical Error when opening

Post by kolma »

On my windows 7 platform I can find only through C:\Windows\SysWOW64\
There is path further, so for me it is not really solved.

Regards,
Andrej
Post Reply