/sbin/mount.vboxsf: invalid option -- 's'

Discussions about using Linux guests in VirtualBox.

/sbin/mount.vboxsf: invalid option -- 's'

Postby cdragon » 14. Jun 2015, 06:32

When I try to have autofs mount a vboxsf share in the same way that's worked for years, I now get the following error:

Code: Select all   Expand viewCollapse view
sudo automount -f -v
Starting automounter version 5.0.8, master map /etc/auto.master
using kernel protocol version 5.02
mounted indirect on /mnt/auto with timeout 5, freq 2 seconds
ghosting enabled
attempting to mount entry /mnt/auto/hostdownloads
>> /sbin/mount.vboxsf: invalid option -- 's'


I believe the problem is explained in this thread. Basically, autofs always passes the -s option to mount and mount used to only pass the -s option on to nfs mounts, but as of some recent update (not sure when but sometime in 2015), mount passes the -s option to all mount helpers, including /sbin/mount.vboxsf. In the thread above, they're talking about mount.ntfs-3g also balking at the -s option being passed to it, and the solution they decided on was to update mount.ntfs-3g to accept -s. So I propose that mount.vboxsf also be updated to accept the -s option.

I'm using the latest VirtualBox 4.3.28 with Lubuntu 14.10 and the mount version is 2.25.1 after updating with 'apt-get upgrade'. I guess it's possible this has already been fixed in a VirtualBox development branch but I'm not sure how to check that.

Is there any other way I might fix this problem?
cdragon
 
Posts: 3
Joined: 1. Oct 2009, 05:45
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Vista 32, 64, Win 7 32

Re: /sbin/mount.vboxsf: invalid option -- 's'

Postby cdragon » 25. Jun 2015, 00:23

In case anyone else wants a solution, for now I've "solved" the problem by automounting cifs network shares to the local machine rather than virtualbox shares.
cdragon
 
Posts: 3
Joined: 1. Oct 2009, 05:45
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Vista 32, 64, Win 7 32

Re: /sbin/mount.vboxsf: invalid option -- 's'

Postby Ramshankar » 25. Jun 2015, 13:45

Thanks for the report, we'll look into this.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 788
Joined: 7. Jan 2008, 16:17

Re: /sbin/mount.vboxsf: invalid option -- 's'

Postby Ramshankar » 26. Jun 2015, 15:22

Moved this to linux guests forum.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 788
Joined: 7. Jan 2008, 16:17

Re: /sbin/mount.vboxsf: invalid option -- 's'

Postby Ramshankar » 30. Jun 2015, 13:05

Thanks for the report. This should be fixed in trunk (meaning 5.0.x) will backport to 4.3 later.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 788
Joined: 7. Jan 2008, 16:17


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 21 guests