Page 22 of 33

Re: Discussion of Problems due to Hardened Security

PostPosted: 17. Apr 2016, 13:04
by mpack
@Eggs00: your hardening log ends with exit code of zero, indicating that your problem is not hardening related and discussion of it is therefore is off topic here. Please create your own topic in "Linux Guests" to ask your question.

Re: Discussion of Problems due to Hardened Security

PostPosted: 18. Apr 2016, 08:47
by Eggs00
Thank you and sorry for the trouble!!!

:mrgreen:

Re: Discussion of Problems due to Hardened Security

PostPosted: 26. Apr 2016, 09:53
by Kieruns
The issue is resolved after uninstalling and reinstalling an older version ( 4.3.12 ) Virtual box . As the other versions post 4.3.12 has issues with Windows security tethering from versions Windows 7 , 8 & 10 .
Just install the Virtual box 4.3.12 which fixes the issues .

Re: Discussion of Problems due to Hardened Security

PostPosted: 26. Apr 2016, 10:02
by mpack
Kieruns wrote:Just install the Virtual box 4.3.12 which fixes the issues .

In fact that doesn't fix anything. It merely bypasses the issues for VirtualBox only by reverting to a software version that didn't do the checks, and which does not support newer hosts, and will likely have problems with new guests. You are now marooned on the desert island of 4.3.12 and can't go anywhere. It would have been better for you to fix the underlying host problem.

Re: Discussion of Problems due to Hardened Security

PostPosted: 6. May 2016, 18:23
by wind sound
I have some problem as shown below when I run virtualbox:
Failed to open a session for the virtual machine ubuntu-14.04.2-desktop-amd64.
The virtual machine 'ubuntu-14.04.2-desktop-amd64' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'D:\depot\virtualization\ubuntu-14.04.2-desktop-amd64\Logs\VBoxHardening.log'.
Result Code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

My system is
OS: Windows 10 Pro
Anti-virus: Windows Defender

I've tried to find causes but I coudn't.
Even though I tried to analyze VBoxHardening.log, I couldn't get any hint from the file.

Please give me a hand.
Thanks,

Re: Discussion of Problems due to Hardened Security

PostPosted: 12. May 2016, 23:06
by TFF
Here are my findings.
I am running Window 7 and Virtualbox 5.0.20. When I installed 5.0.20 over 4.2 it worked. When I started the computer the next day I got a message about an unidentified device driver not installing. When I tried to start a VM I got a "Error in supR3HardenedWinReSpawn" pop-up. If I uninstall 5.0.20 then restart the computer then install 5.0.20 VirtualBox. VirtualBox 5.0.20 will work again. I have attached my log file.

Re: Discussion of Problems due to Hardened Security

PostPosted: 27. May 2016, 01:29
by mhou
I have the same issue and I am running Windows 7 with Virtual Box 5.0.20.

OS: Winodws 7 Enterprise SP1
AntiVirus: McAfee VirusScan Enterprise + AntiSpyware Enterprise 8.8
VPN: Cisco AnyConnect Secure Mobility Client 3.1.05170

Running CentOS 7 as a guest OS.

The only version which works for me is 4.3.12. Anything else running >= 4.3.14 do not work for me.

2016-05-26 16_18_53-VirtualBox - Error In supR3HardenedWinReSpawn.png
2016-05-26 16_18_53-VirtualBox - Error In supR3HardenedWinReSpawn.png (16.92 KiB) Viewed 3309 times

2016-05-26 16_19_04-VirtualBox - Error.png
2016-05-26 16_19_04-VirtualBox - Error.png (25.88 KiB) Viewed 3309 times

VBoxHardening.zip
(10.09 KiB) Downloaded 20 times

Re: Discussion of Problems due to Hardened Security

PostPosted: 27. May 2016, 09:54
by mpack
I see that you have McAffee AV. Test what happens when you disable it.

Re: Discussion of Problems due to Hardened Security

PostPosted: 1. Jun 2016, 03:22
by mhou
I cannot disable McAfee since it is a corporate machine. I don't have the enough permission to disable it. However, I do have our System Admin team looking into it. Disabling it does not help.

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 12:55
by Hyroko
Windows 10 version 1511
AV: Windows Defender + Malwarebytes (tried uninstalling the last one, didn't work)

Tried different solutions I found in forums, none of them worked so far:

- Installing an old version => BSOD with CRITICAL_STRUCTURE error
- Setting number of processors to 1 => no result
- Running as admin => no result

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 13:30
by mpack
I don't see why any of those "solutions found on forums" would be relevant. I'd like to see a log without Malwarebytes present.

I'm using VirtualBox myself, on a Windows 10 Pro host running Windows Defender - with no problem. I'm not running any theme hacks either.

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 13:50
by Hyroko
There u go:

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 14:04
by mpack
That log still shows Malwarebytes DLLs being loaded. Look through the log yourself, and come back to me when it doesn't include the word "Malwarebytes".

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 14:06
by Hyroko
Malwarebytes is uninstalled, how am I suppose to make that disappear?

Re: Discussion of Problems due to Hardened Security

PostPosted: 11. Jun 2016, 14:07
by mpack
Ultimately that question should be aimed at Malwarebytes support. Did you try rebooting the host?