Page 11 of 33

Re: Discussion of Problems due to Hardened Security

PostPosted: 25. Aug 2015, 20:14
by WildBill64
I have not been able to run Virtual Box since version 4.3.26. Every time I try and start I get this error message:

The virtual machine 'Linux Mint' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'C:\Users\william.coats\VirtualBox VMs\Linux Mint\Logs\VBoxStartup.log'.


Result Code:
E_FAIL (0x80004005)
Component:
MachineWrap
Interface:
IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

I have upgraded to VB 5.0.2r102096. I am using System Center Endpoint Protection.

Re: Discussion of Problems due to Hardened Security

PostPosted: 26. Aug 2015, 06:11
by Industrial
My problem turned out to be modified system files because I was using a custom theme. If you use uxtheme multipatcher it will patch the files in memory and won't cause problems for Virtualbox.
I don't know why the devs made virtualbox so restrictive and paranoid though.

Re: Discussion of Problems due to Hardened Security

PostPosted: 3. Sep 2015, 16:21
by rnewman
Hello,
No go with the latest builds...

OS - Win7 Professional 64bit - SP1 (patched)
Trendmicro Office Scan - 11.0.4150 sp1

Virtualbox - 4.3.31-102328
Virtualbox - 5.0.3 -102467

Screen shot and startup log attached.

I am happy to assist with debugging. Are there any switches or process that would provide additional diagnostic information?

Thanks,
Richard

Re: Discussion of Problems due to Hardened Security

PostPosted: 10. Sep 2015, 14:45
by zhudock
VirtualBox 5.04

OS:
Windows 7 Pro 64-bit with Service Pack 1

Security (I do not have the ability to disable either of these on my system):
McAfee Virus Scan Enterprise v8.8.0.1385
DigitalGuardian

Error Details:
Code: Select all   Expand viewCollapse view
supHardenedWinVerifyProcess failed with VERR_SUP_VP_REPLACE_VIRTUAL_MEMORY_FAILED:  (rc=-5673)

where: supR3HardNtChildPurify
what:  5
VERR_SUP_VP_REPLACE_VIRTUAL_MEMORY_FAILED (-5673) - Process Purification Failure: NtAllocateVirtualMemory failed to get us suitable replacement memory for a chunk of executable memory that shouldn't be present in our process. (You will only see this message if you got potentially fatally buggy anti-virus software installed.).


Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine CentOS_Cart.

The virtual machine 'CentOS_Cart' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'C:\Users\zrh535\VirtualBox VMs\CentOS_Cart\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}


VBoxStartup.zip
(2.29 KiB) Downloaded 189 times

Re: Discussion of Problems due to Hardened Security

PostPosted: 10. Sep 2015, 14:47
by mpack
If you have buggy AV then you need to take that up with the AV vendors and/or your own IT support people.

Re: Discussion of Problems due to Hardened Security

PostPosted: 16. Sep 2015, 03:30
by Torchwood
Well, I have been away from this thread since May, having had to fall back to v4.3.12 on my Windows 7-SP1 Pro 32-bit host. Looks like I have missed a lot of the fun!

*** Good News ***

I am happy to report that I just installed v4.3.30 and it is running flawlessly right now :-)

Originally I noted that I was running Avira free as antivirus. So just FYI, Avira pushed out a version update on Aug 26th to 15.0.12.420 to fix some other bugs.

It just occurred to me to try the newer Virtualbox v4.3.30 to try get rid of the annoying nag that a newer version was available... and. it. just. worked!

So maybe somewhere in the last 4 months Microsoft or Oracle or Avira got this cleaned up?

Everything is all sunshine and rainbows and unicorns here now ... YMMV :D

Re: Discussion of Problems due to Hardened Security

PostPosted: 16. Sep 2015, 15:46
by rnewman
Hello,
No go with the latest build...

OS - Win7 Professional 64bit - SP1 (patched)
Trendmicro Office Scan - 11.0.4150 sp1

Virtualbox - 5.0.5 -102676

Screen shot and startup log attached.

I am happy to assist with debugging. Are there any switches or process that would provide additional diagnostic information?

Thanks,
Richard

Re: Discussion of Problems due to Hardened Security

PostPosted: 20. Sep 2015, 21:11
by Torchwood
Hmmmm... Well that didn't last long. Posted 4 days ago that all is well after Virtualbox upgrade from v4.3.12 to v4.3.30, running Virtualbox v4.3.30 on Windows7 host, with Avira free antivirus.

But, this morning Avira refused to update for some odd reason. Ended up re-installing the latest version of Avira free.

Then on first try at launching a guest VM, got the same old error, VM failed to start... ( [lacks WinVerifyTrust], etc).

Uninstalled Avira, VM is starting OK again. Weird.

Installed Avast Free and all is running well again. Weird.

Re: Discussion of Problems due to Hardened Security

PostPosted: 22. Sep 2015, 00:22
by wunjo
Latest news from here;

I can run 5.05 now and probably older versions too.
Just have to do a workaround; before shutting down Win7, first de-install vbox.
After startup, re install vbox again. :mrgreen:

Re: Discussion of Problems due to Hardened Security

PostPosted: 22. Sep 2015, 14:50
by rnewman
Hello,
No go with the latest builds...

OS - Win7 Professional 64bit - SP1 (patched)
Trendmicro Office Scan - 11.0.4150 sp1

Virtualbox - 4.3.31-102733
Virtualbox - 5.0.5 -102800

Screen shot and startup log attached.

I am happy to assist with debugging. Are there any switches or process that would provide additional diagnostic information?

Thanks,
Richard

Re: Discussion of Problems due to Hardened Security

PostPosted: 27. Sep 2015, 22:31
by midix
Moved my post from other topic because this one seems to be more active and relevant to the issue.

Does Virtualbox conflict with VMWare Player? Or Avira?

I had all of them (Virtualbox, Avira Free, VMWare Player) installed and running happily for some months but then one day I could not launch my VBoxes any more - all of them failed with supR3HardenedWinReSpawn. Some time ago I updated to 5.0.2. Still the same error. Then I made sure I don't have that Windows KB update which was mentioned in other threads about the same issue with 4.xx. Still no luck.

Then I uninstalled Virtualbox completely but before rebooting I decided to disable VMWare network drivers because I have already experienced some issues related to them; see this article:
https://stijndewitt.wordpress.com/2014/ ... angs-ie11/

This is useful for network adapters with broken driver support, as well as some virtual network providers such as vpn drivers, or spam, virus or spyware filters.



BTW, how would VirtualBox react to such broken drivers?

Anyway, I disabled the drivers (using Sysinternals Autoruns) and restarted the host and reinstalled Virtualbox 5.0.2. Hooray! It worked!

Then to make sure that the VMWare network drivers are the cause, I enabled the drivers again and rebooted. Yeah, VirtualBox crashes again with the same issue. Disabled the drivers, rebooted... oh, no, VirtualBox still crashes!

Now I'm not so sure, what's the problem, why did VirtualBox start crashing again - because I had enabled the VMWare network drivers once and then later disabled again or because I rebooted the computer after installing VirtualBox :?

Anyway, VirtualBox is broken again.

Running it on Windows 64 bit Pro with 8GB of RAM.

The log file is attached.

VMWare information, if relevant:

Code: Select all   Expand viewCollapse view
VMware® Player
6.0.3 build-1895310

vmnetuserif.sys
Allows VMware applications to use virtual networks.   VMware, Inc.   
c:\windows\system32\drivers\vmnetuserif.sys
4.2.1.0 build-1895310
Modified: 2014.06.12


I have Avira Free antivirus, and it does not make any difference whether I have Real-time protection enabled or not.

Maybe it's time for more serious hacking with Autoruns and disabling all non-crucial drivers to see what happens.

I tried disabling every non-Microsoft driver with Autoruns and got carried away and got some BSODs pointing to hard drive problems :D
Restored from Last Known Good Configuration and started over, this time leaving AHCI and other, possibly storage related drivers enabled. Avira drivers were disabled, too. My sound stopped working and video reverted to low res, but still the same error from VirtualBox. It seems, there is no chance to find the problematic driver using lucky guess approach, if it's a drivers fault at all.

Unfortunately even if hide all Microsoft drivers, there are lots of crucial system drivers which cannot be disabled, and Autoruns does not tell which drivers have been recently added or updated, therefore it's hard to find anything.

Still I have gotten it working just that single time, straight after installing without VMWare drivers. Not sure, if it does mean anything.

Now I have just updated to 5.0.4, but still the same issue, see the attached VBoxStartup5.0.4.zip

Re: Discussion of Problems due to Hardened Security

PostPosted: 1. Oct 2015, 16:25
by sdrost
Hi,

I seem to have the same problem: I'd like to run Ubuntu in Virtualbox on my Windows 7 PC, but it keeps giving me this "Error in supR3HardenedWinReSpawn" whenever I try to start Ubuntu.
Some more details:
- my PC runs Windows 7 Professional SP1, with System Center Endpoint Protection and firewall. I attached a screenshot of my update history as well.
- I installed VirtualBox 5.0.4, which is my first ever attempt at using a virtual machine, so I don't have any experience using previous versions.
- The version of Ubuntu I was trying to install is ubuntu-14.04.3-desktop-amd64
- The full text of the error message is:

Error relaunching VirtualBox VM process: 5
Command line: '60eaff78-4bdd-042d-2e72-669728efd737-suplib-3rdchild --comment Ubuntu-14.04.3-desktop-amd64 --startvm 716f3512-1a82-4210-ab98-23afba3e692e --no-startvm-errormsgbox "--sup-startup-log=C:\Users\sita.drost\VirtualBox VMs\Ubuntu-14.04.3-desktop-amd64\Logs\VBoxStartup.log"' (rc=-104)

where: supR3HardenedWinReSpawn
what: 5
VERR_INVALID_NAME (-104) - Invalid (malformed) file/path name.

- For the VBoxStartup.log, please see the attached zip-file

Re: Discussion of Problems due to Hardened Security

PostPosted: 3. Oct 2015, 21:38
by rilves
1) Host OS and version
Windows 10.0 (build 10240) x64, fully patched as of October 3 2015.

2) VBoxStartup.log (zipped)
It's not created.

3) Mention any host anti-virus, firewalls, protection software, and debugging programs etc which might be relevant.
Bitdefender Total Security 2015

Error message
The virtual machine 'Windows XP (32 bit)' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\VirtualBox\Windows XP (32 bit)\Logs\VBoxHardening.log'.

Result Code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

Re: Discussion of Problems due to Hardened Security

PostPosted: 9. Oct 2015, 08:00
by Gloix
1) Host OS and version
Windows 8.1 x64

2) VBoxStartup.log (zipped)
Logs.rar
(85.05 KiB) Downloaded 29 times


3) Mention any host anti-virus, firewalls, protection software, and debugging programs etc which might be relevant.
MalwareBytes 2.1.8.1057
Windows Defender

Error message
Code: Select all   Expand viewCollapse view
NtCreateFile(\Device\VBoxDrvStub) failed: 0x00000034
STATUS_OBJECT_NAME_NOT_FOUND (0 retries) (rc=-101)

Make sure the kernel module has been loaded successfully.

where: supR3HardenedWinReSpawn what: 3 VERR_OPEN_FAILED (-101) -
File/Device open failed. Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help.


Executing sc.exe yields:
Code: Select all   Expand viewCollapse view
SERVICE_NAME: vboxdrv
        TYPE               : 1  KERNEL_DRIVER
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 31  (0x1f)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

Re: Discussion of Problems due to Hardened Security

PostPosted: 12. Oct 2015, 16:35
by rnewman
Hello,
No go with the latest builds...

OS - Win7 Professional 64bit - SP1 (patched)
Trendmicro Office Scan - 11.0.4150 sp1

Virtualbox - 4.3.31-103278
Virtualbox - 5.0.7 -103278

Screen shot and startup log attached.

I am happy to assist with debugging. Are there any switches or process that would provide additional diagnostic information?

Thanks,
Richard