Windows 4.3.18 specifically for errors due to security

Discussions related to using VirtualBox on Windows hosts.

Windows 4.3.18 specifically for errors due to security

Postby bird » 12. Oct 2014, 00:35

This topic is now obsolete. A 4.3.20 sticky topic has now been created. Please move the discussion there.

---- Original opening post

This topic is specifically for Windows users that may still have issues seen in version 4.3.18 when the security was strengthened.

Please note that to be taken seriously you need to post a few items as attachments (compressed is preferred)

    1) Host and version
    2) VBoxStartup.log
    3) Host anti-virus, firewalls, protection software, and debugging programs.

Note that, as in the previous (4.3.14, 4.3.16) discussions, the purpose of this topic is to gather diagnostic data needed to solve the hardening issues, and nothing else. Wibble posts, opinion posts, and posts that don't include necessary diagnostics will most likely be deleted. If a test build is created then you'll be expected to have tried it before you post.

Please be explicit about errors. Don't say "same as xxxxx". See list above for what's required.



Test build #1: VirtualBox-4.3.19 (rev 96923)

Relevant changes since 4.3.18:
* Fixes problem loading some 3D related graphics DLLs (associated with drivers).
* Fixes VBoxDrv BSOD caused by race during process creation.
* Fixes VBoxManage crash when getting shared folders from saved state (++).


Please give the test build a spin before posting.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 108
Joined: 10. May 2007, 10:27

Re: Windows 4.3.18 specifically for errors due to security

Postby yuriks » 12. Oct 2014, 04:22

Latest version crashes when Qt Creator is launched with 3D accel on: "The instruction at 0xc562dc72 referenced memory at 0x00001680. The memory could not be read." I have a screenshot, but anti-spam protection does not let me post it.

This crash can be reliably reproduced. The second time it happened, VirtualBox corrupted part of my disk image. It doesn't happen if 3D acceleration is disabled, or with 4.3.16 on the exact same setup.

Running glxgears produces only a black window, but does not crash.

Host: Windows 8.1, Intel HD 4000
Guest: Arch Linux, Linux 3.16.4-1-ARCH, Mesa 10.3.0-3

For the moment I'm downgrading VirtualBox to 4.3.12, which was the last version that wasn't laden with crashes. These crashes have already caused me data loss on two occasions. I appreciate the sentiment of trying to protect users from malicious software, but a hypervisor that crashes most of the time is all but useless.
yuriks
 
Posts: 1
Joined: 12. Oct 2014, 04:12

Re: Windows 4.3.18 specifically for errors due to security

Postby RelakS » 12. Oct 2014, 10:42

Unfortunately, I wasn't able to try the last test build, so I went with this one. Without success.

On Windows 7 SP1 64bit with McAfee pack: Host Intrusion Precention 8.0 (8.0.0.2151), McAfee Agent 4.6.0.3122, Endpoint Encription Agent 1.2.1.315, Endpoint Encryption for PC 6.2.1.315, GTI Proxy Agent 1.1.0.550, Virus Scan Enterprise 8.8.0 (8.8.0.849)
VM extension pack 4.3.12 build93733

Host BSoD
I attacched the VBoxStartup as well, however it is an about 8kB file with only 0 bytes.
Attachments
VBoxStartup.zip
(153 Bytes) Downloaded 928 times
Minidump.zip
(33.74 KiB) Downloaded 347 times
RelakS
 
Posts: 15
Joined: 15. Sep 2014, 09:53

Re: Windows 4.3.18 specifically for errors due to security

Postby Doom Mortal » 12. Oct 2014, 13:39

Hello everbody I have tested the new 4.3.18 Build and I have the same problems with installing the new Windows 10 Preview.
The Logs are in the Attachment.
I hope there will be a fix soon. Thank you for you work.

My System is :
Windows 7 Ultimate 32bit
ZoneAlarm Firewall
Attachments
VBoxStartup.zip
(88.94 KiB) Downloaded 359 times
Doom Mortal
 
Posts: 2
Joined: 12. Oct 2014, 13:30

Re: Windows 4.3.18 specifically for errors due to security

Postby mpack » 12. Oct 2014, 16:08

@Doom Mortal, please be explicit about errors. I have no idea what you might mean by "same problems", though I suspect you have a problem with Windows 10, and not a problem related to hardening issues which is the sole reason for this discussion topic.
mpack
Site Moderator
 
Posts: 24493
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Windows 4.3.18 specifically for errors due to security

Postby wbedard » 12. Oct 2014, 19:48

VirtualBox Support Staff,

The issue that I am experiencing is being carried over from the following posts in the 4.3.16 thread:
https://forums.virtualbox.org/viewtopic ... 45#p298870
https://forums.virtualbox.org/viewtopic ... 45#p298898

This problem has remained unchanged through all the 4.3.16 test builds. Although my test system remains basically the same (Win7 64-bit host w/ a FreeBSD 10-derived guest), I have taken the step of completely uninstalling my anti-virus software in an effort to further simplify the problem. One area in which I could use some advice is how to obtain better (i.e. more detailed?) debugging info while the guest is running. I have submitted the normal VBox logs (see posts referenced above) but they seem to basically end once the guest has booted up. Whether that is technically correct or not, I have never seen anything committed to those logs at the time the problem manifests itself on the guest (i.e. my USB NIC disconnects...). If anyone can advise me on how to collect more informative logs, I would be more than happy to provide them to aide the troubleshooting.

As it is now, I run this guest "day-to-day" under 4.3.12 with no problems. Because of the effort required to install VirtualBox test builds for troubleshooting and then rolling back to 4.3.12 in order to restore normal operations, I usually won't spend time on this during the week unless there is pretty compelling evidence that a fix might have been implemented. As always though, any effort from the VB devs or broader community is greatly appreciated in helping me to resolve this.

R/
wbedard
wbedard
 
Posts: 4
Joined: 12. Sep 2014, 00:25

Re: Windows 4.3.18 specifically for errors due to security

Postby Doom Mortal » 12. Oct 2014, 22:55

mpack wrote:@Doom Mortal, please be explicit about errors. I have no idea what you might mean by "same problems", though I suspect you have a problem with Windows 10, and not a problem related to hardening issues which is the sole reason for this discussion topic.


@mpack
Im sorry I thought that my information that I provided weren´t enough to solve this problem.
I have a problem in installing Windows 10. It apears the Loading-Screen of WIndows 10 and after a few seconds there will apear an error screen.
The message of the error screen is in the .zip data as a picture file.

Before this thread started it only was said that it is a continuation of the old thread where i encountered the same descussion with Windows 10.
Im sorry for that misunderstanding.
Doom Mortal
 
Posts: 2
Joined: 12. Oct 2014, 13:30

Re: Windows 4.3.18 specifically for errors due to security

Postby Perryg » 13. Oct 2014, 00:04

Doom Mortal wrote:
mpack wrote:@Doom Mortal, please be explicit about errors. I have no idea what you might mean by "same problems", though I suspect you have a problem with Windows 10, and not a problem related to hardening issues which is the sole reason for this discussion topic.


@mpack
Im sorry I thought that my information that I provided weren´t enough to solve this problem.
I have a problem in installing Windows 10. It apears the Loading-Screen of WIndows 10 and after a few seconds there will apear an error screen.
The message of the error screen is in the .zip data as a picture file.

Before this thread started it only was said that it is a continuation of the old thread where i encountered the same descussion with Windows 10.
Im sorry for that misunderstanding.


00:00:15.866429 Host RAM: 3066MB total, 906MB available
00:00:16.830039 RamSize <integer> = 0x0000000040000000 (1 073 741 824, 1 024 MB)
00:00:18.831679 HM: NX not enabled on the host, unavailable to PAE guest.
00:00:51.325932 !! Guru Meditation -4014 (VERR_VMX_INVALID_GUEST_STATE)

Memory over committed and IIRC Windows 10 suggest 2048MB

But the missing NX is going to stop the Win-10 guest from working IMHO and why you are getting the guru mediation message.
Make sure that your bios has this feature and that it is enabled in your hosts bios.
Perryg
Site Moderator
 
Posts: 33876
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Windows 4.3.18 specifically for errors due to security

Postby TheNawaKer » 13. Oct 2014, 00:17

Hello everybody,
i have tested the new version of virtualbox (4.3.18) but i have an error when i launch any VM.
Unable to load R3 module C:\Program Files\Oracle\VirtualBox/VBoxDD.DLL (VBoxDD): GetLastError=1790


On Windows 7 Ultimate 64bit SP1 with Avast 2014.9.0.2021 (Free) and Malwarebytes 2.0.2.1012

I have tried with avast and MBAM deactivated but no change, same error :x
Attachments
Logs.zip
(34.35 KiB) Downloaded 96 times
TheNawaKer
 
Posts: 1
Joined: 12. Oct 2014, 14:47

Re: Windows 4.3.18 specifically for errors due to security

Postby ElTopo » 13. Oct 2014, 03:05

I am not sure if this error was caused by the security issue but let me post here in this topic.

Host: Windows 7 64-bit English, AMD processor with 8GB RAM. Windows system is updated with all latest patches.
Guest: debian testing 32-bit, with all latest updates.

When I started the debian VM I got this:
Screenshot - 10_12_2014 , 5_43_21 PM.jpg
error dialog
Screenshot - 10_12_2014 , 5_43_21 PM.jpg (90.5 KiB) Viewed 93004 times


error log:
VBoxStartup.7z
error log
(2.71 KiB) Downloaded 148 times


The same systems (Host+Guest) used to work with VB 4.3.12, had problems with 4.3.14 (seemed to be the security issue, although I only have Microsoft's Security Essentials installed).
ElTopo
 
Posts: 5
Joined: 20. May 2010, 00:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Debian Testing

Re: Windows 4.3.18 specifically for errors due to security

Postby MikeDiack » 13. Oct 2014, 11:27

ErrorMsg.jpg
The error message
ErrorMsg.jpg (19.65 KiB) Viewed 92813 times
StuckAtStartup.jpg
Stuck in the startup process.
StuckAtStartup.jpg (50.39 KiB) Viewed 92813 times
Host machine is (very high spec, 16 CPU, 16GB) Windows 7 SP1 x64 fully patched up to date.
Symantec Endpoint Protection: Version 12.1.5 (12.1 RU5) build 5337 (12.1.5337.5000) (Note: This is a very recent version of SEE, released mid Sept 2014)
Virtual Box 4.3.18.96516

1) Select a virtual machine e.g. XP SP3 VM.
2) Start it.
3) There's a long pause (20-30 secs approx) before the Starting VM "Creating process for virtual machine ..... (GUI/Qt)" message appears.
4) This message stays up, but stuck with progress bar at 0%, which doesn't progress.
5) Then eventually a message is seen: "VirtualBox - Error in supR3HardNtChildWaitFor".
Timed out after 60009 ms waiting for child request #1 (CloseEvents). (rc=258).
with an Abort button.
6) On clicking Abort, a Virtual Box error is shown:
Failed to open a session for the virtual machine WS_XP.

The virtual machine 'WS_XP' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\MDiack\VirtualBox VMs\WS_XP\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

7) Vboxstartup.Log is attached.

Note: The problem does NOT occur with the test builds Virtual Box 4.3.17.96101 and 4.3.17.96342, so this appears to be some regression
between the two VBOX versions (4.3.17 test and 4.3.18 release).
Attachments
VBoxStartup.log
Startup log on VBox 4.3.18.96516 with SEE 12.1.5 on a Win 7 SP1 x64 host, trying to start a Win XPSP3 guest.
(83.2 KiB) Downloaded 421 times
MikeDiack
 
Posts: 66
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win 7, Vista, XP, Linux, Win 8/ Win 8.1, Win 2000, Win NT 4

Re: Windows 4.3.18 specifically for errors due to security

Postby rnewman » 13. Oct 2014, 19:07

Windows 7 Professional SP1 64bit
TrendMicro OfficeScan 11.0.1454
Virtualbox 4.3.18

Well making progress, the host doesn't hang and reboot any more.
However, I do get an error starting a VM. The error dialog box and virtualbox startup logs are attached.
Attachments
VirtualBox-4.3.18.zip
(27.17 KiB) Downloaded 195 times
rnewman
 
Posts: 37
Joined: 11. Sep 2014, 19:58

Re: Windows 4.3.18 specifically for errors due to security

Postby nobook » 13. Oct 2014, 21:03

VirtualBox version:
VirtualBox-4.3.18-96516-Win.exe

other version which got the same error:
VirtualBox-4.3.17-96342-Win.exe
VirtualBox-4.3.17-96101-Win.exe
VirtualBox-4.3.16-95972-Win.exe
VirtualBox-4.3.14-95030-Win.exe

My host computer runs:
Windows 7 ultimate sp1 64bits

Anti-virus Software:
Microsoft Security Essentials

Turn on an existing VM show error:
The virtual machine 'Funtoo' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'VBoxStartup.log'.
code: E_FAIL (0x80004005)
Machine
IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
Attachments
VBoxStartup-4.3.18.zip
E_FAIL (0x80004005) on vb-v4.3.18 release
(2.89 KiB) Downloaded 127 times
nobook
 
Posts: 14
Joined: 25. Oct 2008, 11:31

Re: Windows 4.3.18 specifically for errors due to security

Postby KHG » 14. Oct 2014, 04:42

Windows 7 Enterprise service pack 1(version: 6.1.7601)
Virtualbox 4.3.18
Microsoft Forefront endpoint protection 2010

Code: Select all   Expand viewCollapse view
Failed to create the VirtualBox COM object.

The application will now terminate.

Callee RC: E_INVALIDARG (0x80070057)



Failed to open a session for the virtual machine test debian.

The virtual machine 'test debian' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'C:\Users\KGH\VirtualBox VMs\test debian\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
Attachments
VBoxStartup.7z
(24.08 KiB) Downloaded 67 times
KHG
 
Posts: 4
Joined: 10. Sep 2014, 17:40

Re: Windows 4.3.18 specifically for errors due to security

Postby MikeDiack » 14. Oct 2014, 17:30

Further to my earlier post (13 Oct 2014) about VM's hanging during startup on:
Host machine is (very high spec, 16 CPU, 16GB) Windows 7 SP1 x64 fully patched up to date.
Symantec Endpoint Protection: Version 12.1.5 (12.1 RU5) build 5337 (12.1.5337.5000) (Note: This is a very recent version of SEE, released mid Sept 2014)
Virtual Box 4.3.18.96516

I posted that VirtualBox-4.3.17-96342-Win.exe DOES work correctly in this environment.

I've now discovered the several test builds of 4.3.17 that occured AFTER 4.3.17.96342 (over at the Windows 4.3.16 specifically for errors due to security) thread.

Results are as follows:

Most/All builds of 4.3.17 after 96342 (I'ved tried 96426, 96468, 96495) cause the VM process to hang at startup and eventually timeout on the system with Symantec Endpoint Protection: Version 12.1.5 (12.1 RU5) build 5337 (12.1.5337.5000) as follows:

1) Select a virtual machine e.g. XP SP3 VM.
2) Start it.
3) There's a long pause (20-30 secs approx) before the Starting VM "Creating process for virtual machine ..... (GUI/Qt)" message appears.
4) This message stays up, but stuck with progress bar at 0%, which doesn't progress.
5) Then eventually a message is seen: "VirtualBox - Error in supR3HardNtChildWaitFor".
Timed out after 60009 ms waiting for child request #1 (CloseEvents). (rc=258).
with an Abort button.
6) On clicking Abort, a Virtual Box error is shown:
Failed to open a session for the virtual machine WS_XP.

The virtual machine 'WS_XP' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\MDiack\VirtualBox VMs\WS_XP\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Conclusion

So the regression for my version of SEP at least has occured between the code of 4.3.17-96342 which worked with SEP 12.1 (RU5) and 4.3.17-96426 and later which appear not to work with SEP 12.1 (RU5).
MikeDiack
 
Posts: 66
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win 7, Vista, XP, Linux, Win 8/ Win 8.1, Win 2000, Win NT 4

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 41 guests