Windows 10

Discussions related to using VirtualBox on Windows hosts.

Windows 10

Postby GlennChugg » 2. Oct 2014, 07:00

Just a note to say Virtualbox 14.3.16 does not work when installed on a Windows 10 host, installs fine, executes fine, but will not boot a VM (Kernel driver may not be loaded error).

I'll test any beta's, let me know when this is fixed please.
GlennChugg
 
Posts: 6
Joined: 2. Oct 2014, 06:58

Re: Windows 10

Postby KennethF » 2. Oct 2014, 08:44

Yep. Same problem here - Tried reinstalling too.

The error is 'VERR_SUPDRV_HARDENING_EVIL_HANDLE (rc=-3738) - Make sure the kernel module has been loaded successfully'.

Willing to test drive any beta or alpha release.

[EDIT] - Added log file
Attachments
VBoxStartup.zip
VBoxStartup.log
(8.69 KiB) Downloaded 870 times
KennethF
 
Posts: 3
Joined: 2. Oct 2014, 08:42

Re: Windows 10

Postby ReneR » 2. Oct 2014, 09:56

I am facing the same issue trying to start a virtual machine. (If someone needs his virtual machines urgently: VMware Workstation 10 seems to work fine on Windows 10 hosts.)
ReneR
 
Posts: 3
Joined: 2. Oct 2014, 09:56

Re: Windows 10

Postby Scotty920 » 2. Oct 2014, 11:42

Same issue here on v4.3.17 (r96342).
Scotty920
 
Posts: 1
Joined: 2. Oct 2014, 11:31

Re: Windows 10

Postby vipiny35 » 2. Oct 2014, 12:36

Hi, I'm Using Windows 10 preview edition to run Vbox, my Existing Guests fails to start throwing the error "Make sure the kernel module has been loaded successfully". I have tried reinstallation of Vbox but it doesn't work. Creating new guest OS have same problem.
vipiny35
 
Posts: 1
Joined: 2. Oct 2014, 12:28

Re: Windows 10

Postby Pollux321 » 2. Oct 2014, 13:09

Same issue on Windows 10 trying to run Vagrant

Failed to open a session for the virtual machine Homestead_default_1412246587955_75464.

The virtual machine 'Homestead_default_1412246587955_75464' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\John\VirtualBox VMs\Homestead_default_1412246587955_75464\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Pollux321
 
Posts: 3
Joined: 2. Oct 2014, 13:06

Re: Windows 10

Postby Pollux321 » 2. Oct 2014, 13:40

I was searching for fixes and in older version of windows the fix was to manually install these two files.

C:/Program Files/Oracle/VirtualBox/drivers/USB/filter/VBoxUSBMon.inf
C:/Program Files/Oracle/VirtualBox/drivers/vboxdrv/VBoxDRV.inf

Now when I right click these files it gives me the option to install and after I do it says successful but then when I right click them again it still shows the option to install. I don't know if that's normal but either way it doesn't solve the problem.
Pollux321
 
Posts: 3
Joined: 2. Oct 2014, 13:06

Re: Windows 10

Postby arfonzo » 2. Oct 2014, 14:19

Hi,

We have tried the testing build 4.3.17 r96342, and we still get the same error as KennethF. For what it's worth, we have also tried the manual installation of drivers, without any difference.

Logs attached, refer to multiple errors of "[lacks WinVerifyTrust]".

Kind regards,
arfonzo
Attachments
VBoxStartup.zip
VBoxStartup.log
(9.54 KiB) Downloaded 250 times
arfonzo
 
Posts: 1
Joined: 2. Oct 2014, 14:15

Re: Windows 10

Postby ptyork » 2. Oct 2014, 14:46

Just adding one more voice to this. Hoping someone finds a workaround. I really need VBox guests and hate the idea of rolling back...self-inflicted wounds...<sigh>
ptyork
 
Posts: 1
Joined: 2. Oct 2014, 14:41

Re: Windows 10

Postby KennethF » 2. Oct 2014, 18:50

ReneR wrote:I am facing the same issue trying to start a virtual machine. (If someone needs his virtual machines urgently: VMware Workstation 10 seems to work fine on Windows 10 hosts.)


Can confirm this. Glad my company had a VMware Workstation 10 license floating around. Despite the buzzwords from VMware though, I still prefer Vbox ...but, it solves the problem for now.
KennethF
 
Posts: 3
Joined: 2. Oct 2014, 08:42

Re: Windows 10

Postby dmittleider » 2. Oct 2014, 18:59

Same problem. I've tried running as admin, running in compatibility mode, uninstall/reinstall, booting a brand new vm with as little as installed as possible.
dmittleider
 
Posts: 14
Joined: 18. Dec 2013, 21:34

Re: Windows 10

Postby Pollux321 » 3. Oct 2014, 10:12

I had an update for my Homestead box prompted when I tried to run vagrant up. I was hoping that was the fix but NOPE. Still with the "THe guest machine entered an invalid state while waiting for it to boot.
Pollux321
 
Posts: 3
Joined: 2. Oct 2014, 13:06

Re: Windows 10

Postby mrnewrochelle » 3. Oct 2014, 16:25

I installed VirtualBox 4.3.12 and it works great!!!!!! (I have Windows 10 as a host 64 bits, Dell xps)
Something is something...
Last edited by mrnewrochelle on 3. Oct 2014, 22:54, edited 1 time in total.
mrnewrochelle
 
Posts: 1
Joined: 3. Oct 2014, 16:21

Re: Windows 10

Postby wye » 3. Oct 2014, 22:49

I installed Windows 10 Preview build 9841 on a new VBox 4.3.12 VM running on a Win 7 64bit Host running on AMD Phenom(tm) II X6 1075T processor.
Host PC has 16 GB RAM.

I installed the preview in a new VM using the ISO and it installed properly and it runs.

I tried to install Guest Additions and that failed (but the mouse capture works properly). https://forums.virtualbox.org/posting.p ... 6&t=63923#

An error message pop-up window opens saying:

Title bar says: "Oracle VM VirtualBox Guest Additions 4.3.12 Setup"

Error message says: "The VirtualBox Guest Additions cannot be installed on this version of Windows"

I didn't know where to look to see if anything was logged.
Windows System and Application EventLogs show nothing I can relate to this issue.

The real problem here for me is that Shared Folders won't work without Guest Additions installed.

Anyone find a way around this?
wye
 
Posts: 25
Joined: 10. May 2014, 23:05
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows 10

Re: Windows 10

Postby Jacob Klein » 4. Oct 2014, 23:11

Of course 4.3.12 is going to work -- that is a version before Oracle added all of this security hardening to VirtualBox.
So, 4.3.14 and onward, are having problems launching VMs in Windows 10 Technical Preview.

Because it is due to the security hardening, I also posted in the stickied 4.3.16 security thread.

I sure hope bird fixes it promptly!
Jacob Klein
 
Posts: 612
Joined: 20. Nov 2013, 01:07

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 14 guests