Windows 4.3.16 specifically for errors due to security

Discussions related to using VirtualBox on Windows hosts.

Re: Windows 4.3.16 specifically for errors due to security

Postby rexcat » 13. Sep 2014, 16:21

I installed VirtualBox-4.3.17-96047-Win(VirtualBox-4.3.16-95972-Win also), Virtualbox.exe can not run. But VirtualBox-4.3.12 is fine.

System error
Code: Select all   Expand viewCollapse view
Faulting application name: VirtualBox.exe, version: 0.0.0.0, time stamp: 0x5411ea62
Faulting module name: VirtualBox.exe, version: 0.0.0.0, time stamp: 0x5411ea62
Exception code: 0xc0000005
Fault offset: 0x0000000000016418
Faulting process id: 0xd68
Faulting application start time: 0x01cfcf5a458a21d3
Faulting application path: C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
Faulting module path: C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
Report Id: 8380bec1-3b4d-11e4-9806-902b343974b0



Host Windows 7 x64
Host virus software Symantec Endpoint Protection 12.1.4112.4156
rexcat
 
Posts: 12
Joined: 13. Sep 2014, 16:11

Re: Windows 4.3.16 specifically for errors due to security

Postby jt61 » 13. Sep 2014, 16:27

can the 4.3.16-95972 extension pack be used with 4.3.17-xxxxx?
jt61
 
Posts: 1
Joined: 13. Sep 2014, 16:25

Re: Windows 4.3.16 specifically for errors due to security

Postby KHG » 13. Sep 2014, 18:12

bird wrote:@numb3rs666: VBoxDrv.sys has trouble loading (or maybe unloading). Have you tried rebooting the system as suggested by the message? Or could you give me the output of 'sc query vboxdrv', at least?

@derscherjm: Sorry, I misread the first log. I see the problem sysfer.dll again, probably my favorite nemesis. :-) I've got SEP on a system here, so I'll see what I can figure out.

@sydbarrett74, @fhoff2: You're experiencing the same issue as @quiettime. I'm working on a possible fix, should hopefully be available within the next 48 hours.

Kind Regards,
bird.


Hi Bird,

It seems that my issue is the same with numb3rs666, but I have tried to reboot several times, I still get the same messages with what I reported earlier.
The test build 4.3.17 doesn't fix my problem.

Windows:Microsoft Windows [Version 6.1.7601], Windows 7 Enterprise, Services pack 1
Antivirus: Microsoft Forefront Proctection
Other tools may inspect process: Websense endpoint, EMET

The error dialog box was shown as following:

Code: Select all   Expand viewCollapse view
Failed to create the VirtualBox COM object.
The application will now terminate.
Callee RC:
E_INVALIDARG (0x80070057)

Failed to open a session for the virtual machine test debian.
The virtual machine 'test debian' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'VBoxStartup.log'.
Result Code:
E_FAIL (0x80004005)
Component:
Machine
Interface:
IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}



In VboxSVC:

Code: Select all   Expand viewCollapse view
00:01:16.191675          ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={Machine is not locked for session (session state: Unlocked)}, preserve=false

00:01:19.404083 Watcher  ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={The virtual machine 'test debian' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'VBoxStartup.log'}, preserve=false


And VboxStarup.log is also attached.

Thank for your great support.
Attachments
VBoxStartup.7z
(21.72 KiB) Downloaded 77 times
Last edited by KHG on 14. Sep 2014, 02:55, edited 1 time in total.
KHG
 
Posts: 4
Joined: 10. Sep 2014, 17:40

Re: Windows 4.3.16 specifically for errors due to security

Postby LangTuBuon » 13. Sep 2014, 19:39

1. Windows Server 2003 R2 SP2 + VirtualBox-4.3.16-95972-Win.exe
2. Attachments
3. Symantec Endpoint Protection v11.0.5002.333

Note: Unikey (Vietnamese Keyboard for Windows - unikey (.) org )
Attachments
VBoxStartup.zip
(23.81 KiB) Downloaded 51 times
LangTuBuon
 
Posts: 1
Joined: 13. Sep 2014, 19:31

Re: Windows 4.3.16 specifically for errors due to security

Postby Michichael » 13. Sep 2014, 21:39

One thing to note. I started seeing these issues on what I thought was 4.3.16, as the "Check for Updates" button returned that I was at the latest version. This is not true. 4.3.14 was installed, but 4.3.16 is out. Upon manually downloading and installing this, my issue is resolved.

For search engine purposes, I'm listing the error messages and codes in hopes that it guides people to this thread (which I had discounted since it I don't run anti-virus and figured it didn't apply to me).

After the 9/10 batch of Windows Updates I was no longer able to boot VM's.

Debugging found that no VM Logs were being generated, and only these two lines were in the VBoxSVC.log's tail. I would also receive a cryptic error message with an abort button that suffered graphical artifacts.

00:05:59.168543 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={Machine is not locked for session (session state: Unlocked)}, preserve=false
00:06:01.270663 Watcher ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={The virtual machine 'Siebel System' has terminated unexpectedly during startup with exit code 1}, preserve=false

I was unable to boot VM's as all would have similar errors. The only solution was to install Virtualbox 4.3.16, and upgrade from the 4.3.14.

I hope this helps anyone else in this position find this thread.
Michichael
 
Posts: 2
Joined: 13. Sep 2014, 11:12

Re: Windows 4.3.16 specifically for errors due to security

Postby byronhawkins » 14. Sep 2014, 08:49

I don't have any security software installed, but I was not able to start any VM in VirtualBox 4.3.16 after the latest Windows 7 64-bit update today. Everything works fine in 4.3.17. So the problem is not necessarily related to security products.
byronhawkins
 
Posts: 7
Joined: 10. May 2011, 07:22
Primary OS: Ubuntu 12.04
VBox Version: PUEL
Guest OSses: Windows 7, Kubuntu

Re: Windows 4.3.16 specifically for errors due to security

Postby rexcat » 14. Sep 2014, 10:02

Security products have been victims of :wink:
rexcat
 
Posts: 12
Joined: 13. Sep 2014, 16:11

Re: Windows 4.3.16 specifically for errors due to security

Postby ggmbira » 14. Sep 2014, 11:46

Virtualbox 4.3.17 r96047 on windows 7 sp1. Comodo firewall 7.0.317799.4142

On version 4.3.15 i had the error
Unable to load R3 module C:\Program Files\Oracle\VirtualBox/VBoxDD.DLL (VBoxDD): GetLastError=1790 (VERR_UNRESOLVED_ERROR).
(https://forums.virtualbox.org/viewtopic ... 26#p297126)
but now with 4.3.16 and 4.3.17 i get

---------------------------
VirtualBox - Error In supR3HardenedWinReSpawn
---------------------------
<html><b>Error relaunching VirtualBox VM process: 5<br>Command line: '60eaff78-4bdd-042d-2e72-669728efd737-suplib-3rdchild --comment "windows 8.1" --startvm f6468e6f-145a-44b8-a2a3-dbaee09c262d --no-startvm-errormsgbox "--sup-startup-log=D:\VirtualBox\Development\windows 8.1\Logs\VBoxStartup.log"' (rc=-104)</b><br/><br/></html>
Failed to open a session for the virtual machine windows 8.1.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

The strangest thing is that just after the installation of 4.3.16 i could start the vm but after i rebooted the host the above errors started.
I then tried 4.3.17 where after 1-2 host reboots it was just fine but when a crush occurred with the ati drivers after the reboot i got the errors again.
Besides including the latest errorlog I have included the log when the vm was starting.
Regards
Attachments
Good and Bad logs.zip
(43.34 KiB) Downloaded 20 times
ggmbira
 
Posts: 3
Joined: 23. Aug 2014, 08:14

Re: Windows 4.3.16 specifically for errors due to security

Postby mpack » 14. Sep 2014, 12:05

byronhawkins wrote:So the problem is not necessarily related to security products.

Nobody said that it was. The "security" in the title refers to the hardening features built into VirtualBox.
mpack
Site Moderator
 
Posts: 24482
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Windows 4.3.16 specifically for errors due to security

Postby rexcat » 14. Sep 2014, 14:02

some test ---

Previous installation, the command line like 'vboxmanage list' is cannot be run.
This time, I'll start Procmon.exe, then install VirtualBox-4.3.17-96047-Win. VBoxManage command can be run (Virtualbox.exe stall can not run), but still starts the virtual machine still wrong .

Error message is as follows
Code: Select all   Expand viewCollapse view
C:\Program Files\Oracle\VirtualBox>vboxmanage startvm "xp 64"
Waiting for VM "xp 64" to power on...
VBoxManage.exe: error: The virtual machine 'xp 64' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component Machine, interface IMachine

C:\Program Files\Oracle\VirtualBox>vboxmanage debugvm "xp 64" log --debug
VBoxManage.exe: error: Failed to assign the machine to the session (RPC_E_SERVERFAULT)
VBoxManage.exe: error: Details: code VBOX_E_VM_ERROR (0x80bb0003), component Machine, interface IMachine, callee IUnknown
VBoxManage.exe: error: Context: "LockMachine(pArgs->session, LockType_Shared)" at line 641 of file VBoxManageDebugVM.cpp

C:\Program Files\Oracle\VirtualBox>
C:\Program Files\Oracle\VirtualBox>
C:\Program Files\Oracle\VirtualBox>vboxmanage debugvm "xp 64" log --debug
VBoxManage.exe: error: Argument a_bstrSettings is empty or an invalid pointer
VBoxManage.exe: error: Details: code E_INVALIDARG (0x80070057), component MachineDebugger, interface IMachineDebugger, callee IUnknown
VBoxManage.exe: error: Context: "ModifyLogGroups(bstrSettings.raw())" at line 215 of file VBoxManageDebugVM.cpp


VBoxSVC.log
Code: Select all   Expand viewCollapse view
VirtualBox COM Server 4.3.17 r96047 win.amd64 (Sep 11 2014 20:23:55) release log
00:00:00.007000 main     Log opened 2014-09-14T11:59:54.735241700Z
00:00:00.007000 main     Build Type: release
00:00:00.007000 main     OS Product: Windows 7
00:00:00.007000 main     OS Release: 6.1.7601
00:00:00.007000 main     OS Service Pack: 1
00:00:00.031001 main     DMI Product Name: To be filled by O.E.M.
00:00:00.043002 main     DMI Product Version: To be filled by O.E.M.
00:00:00.043002 main     Host RAM: 8150MB total, 5063MB available
00:00:00.043002 main     Executable: C:\Program Files\Oracle\VirtualBox\VBoxSVC.exe
00:00:00.043002 main     Process ID: 8928
00:00:00.043002 main     Package type: WINDOWS_64BITS_GENERIC
00:00:00.045002          Loading settings file "C:\Users\Rex.Gu/.VirtualBox\VirtualBox.xml" with version "1.12-windows"
00:00:00.280016          HostDnsMonitorProxy: Host's DNS information updated:
00:00:00.497028          VDInit finished
00:00:00.502028          Loading settings file "E:\vm\xp 64\xp 64.vbox" with version "1.12-windows"
00:00:23.314333 Watcher  ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={The virtual machine 'xp 64' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005)}, preserve=false
00:00:28.329620 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Medium 'E:\vm\x64.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:00:28.329620 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Medium 'E:\vm\xp 64\x64_2.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:00:28.352621 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={fafa4e17-1ee2-4905-a10e-fe7c18bf5554} aComponent={VirtualBox} aText={The object is not ready}, preserve=false
rexcat
 
Posts: 12
Joined: 13. Sep 2014, 16:11

Re: Windows 4.3.16 specifically for errors due to security

Postby Papolytic » 14. Sep 2014, 20:50

I know it's tradition to only post complaints and bugs, but in case you wanted to know one instance where this "update" just worked (4.3.16):

I had been running 4.3.14 until I think the last windows update which killed it and gave the -104 error. Software: OS: Win 7 x64 Ultimate SP1 / vbox 4.3.16 updated from 4.3.14 / guests 12.04 ubuntu and 14.04 ubuntu full development systems both 64 bit.

No problems after update to 4.3.16, all updates, 4.3.16 guest tools. I realize this seems like a useless post and maybe it is, but in case you're tracking things that worked as well as those that didn't.

Thanks.
Papolytic
 
Posts: 52
Joined: 15. Apr 2013, 02:01

Re: Windows 4.3.16 specifically for errors due to security

Postby te777 » 14. Sep 2014, 21:23

I am using VBox 4.3.12 on Windows 7 SP1 64 bit Home Premium host. Tried 4.3.16 but VMs wouldn't launch. Spinning circle only. I am using Norton Internet Security 2014. I used a Windows 7 SP1 32 bit virtual machine to install VBox 4.3.16 on. That VM has no anti-virus except the stock Windows Defender. Windows updates on it hadn't been done since 7/21/2014. I then created a small Windows XP VM inside that Windows 7 VM and it ran fine. I then did the Windows Updates on that Windows 7 VM and the XP VM still ran fine inside the Windows 7 VM. Hope this info helps.

Tom
te777
 
Posts: 27
Joined: 15. Jul 2014, 19:09

Re: Windows 4.3.16 specifically for errors due to security

Postby bird » 15. Sep 2014, 00:11

Hi!

Test build #2: https://www.virtualbox.org/download/tes ... 87-Win.exe

This hopefully fixes the VERR_SUPDRV_APIPORT_OPEN_ERROR problem some of you have been seeing.
@quiettime, @sydbarrett74, @fhoff2: Would be cool to get feedback on that.

I've also tweaked the kludges for the asynchronous process invasion employed by avast, and apparently for some symantec endpoint users too.
@derscherjm, @RobBrownNZ: Would be cool if you could take the new build for a spin.

Cheers,
bird.

PS. @Papolytic thanks for the positive feedback. It's very welcome after almost 2 months of mostly the opposite.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 108
Joined: 10. May 2007, 10:27

Re: Windows 4.3.16 specifically for errors due to security

Postby te777 » 15. Sep 2014, 01:13

Test build #2 fixed my problems. Windows 7 SP1 64 bit Home Premium host using Norton Internet Security 2014. Worked with 2 VMs: Windows 7 SP1 32 bit and Linux Mint 17 Cinnamon 32bit. It also fixed my Linux Mint 17 Cinnamon VM problem of running in software rendering mode when using 3D acceleration in the VBox settings for the VM.

Tom
te777
 
Posts: 27
Joined: 15. Jul 2014, 19:09

Re: Windows 4.3.16 specifically for errors due to security

Postby somnang » 15. Sep 2014, 04:59

HOST: Windows 7 Ultimate x64
GUEST: Windows 7 Ultimate x64
A/V: SEP 12.1.671.4971

I was using VirtualBox-4.3.15-95713-Win.exe but upgraded to VirtualBox-4.3.16-95972-Win.exe. After installation, I restarted the computer without firing up the VirtualBox. After the system restart, VM started without any glitch. VB 4.3.16 worked flawlessly. I was planning to install the 4.3.17 but looks like it's no necessary.

Thanks for a great product, Oracle.
somnang
 
Posts: 6
Joined: 16. Jul 2014, 20:19

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 29 guests