Virtualbox 4.3.14 error with Nvidia DLL on launch

Discussions related to using VirtualBox on Windows hosts.
Locked
Leonard4
Posts: 1
Joined: 18. Jul 2014, 02:24

Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by Leonard4 »

Have two weird oddities happening, just installed v4.3.14 and when I launch the main program I get an error:
Error I get when I launch VirtualBox directly.
Error I get when I launch VirtualBox directly.
virtualbox.png (21.99 KiB) Viewed 13676 times
And then everything opens fine and works fine. I've reinstalled the latest Nvidia drivers and it still comes up. When I try to launch a shortcut to a virtual machine I get a completely different error:
Error I get when I launch the VM directly.
Error I get when I launch the VM directly.
debian.png (14.19 KiB) Viewed 13676 times
But it works fine once I hit ok, so while these don't prevent me from using the software it sure is annoying! I have an MSI GT70-0NE laptop, with an Nvidia 680M GTX and Intel HD 4000 graphics cards. I've never seen these errors popup on any other piece of software before or after installing VB. Has anyone run into something similar? I couldn't find anything regarding that "detoured.dll" in the forums here. :(
ThetaPhi
Posts: 8
Joined: 18. Jul 2014, 14:08

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by ThetaPhi »

I have the same problem after upgrading to 4.3.14 on a Thinkpad T530 with Intel/nVidia combo graphics adaptor
ThetaPhi
Posts: 8
Joined: 18. Jul 2014, 14:08

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by ThetaPhi »

I filed this issue #13200
yohanesgultom
Posts: 1
Joined: 18. Jul 2014, 15:30

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by yohanesgultom »

Same issue. Reverted to 4.2.0-80737 and it works :D
S.SubZero
Volunteer
Posts: 123
Joined: 5. Oct 2007, 21:30

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by S.SubZero »

I'm getting a similar thing but the offending dll is c:\windows\system32\nvinitx.dll. I upgraded to the latest nVidia drivers but it still does it.

I also notice it loads considerably slower. But the VM still seems to run alright otherwise.

This is Windows 8.1 on a very lean system (no additional AV or loaded things)
mpack
Site Moderator
Posts: 39134
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by mpack »

I suggest that you guys read the anti-virus sticky at the top of this forum.
ThetaPhi
Posts: 8
Joined: 18. Jul 2014, 14:08

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by ThetaPhi »

Thanks mpack. I don't have such anti-virus software. But as the referred sticky post, you suggested, tells me, in fact NVIDIA drivers on many laptops do similar things.

I explained that in the linked issue (https://www.virtualbox.org/ticket/13200): On many laptops you have dual-graphics adaptors (Intel ones in combination with NVIDIA). For normal work, it uses Intel Graphics to save power, but once an application starts 3D stuff that would better use the NVIDIA graphics, the system switches to the NVIDIA GPU. To detect this "behaviour change" in some applications, the NVIDIA driver uses "Microsoft Detours" (http://research.microsoft.com/en-us/projects/detours/) to hook into every process (like the Anti-Virus software does). By that it can intercept calls to graphics APIs in the Windows API and on the fly enable the NVIDIA GPU.

In contrast to Antivirus Software that I can easily uninstall and replace by Windows own Defender/Security Essentials, I cannot uninstall NVIDIA drivers.
mpack
Site Moderator
Posts: 39134
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Virtualbox 4.3.14 error with Nvidia DLL on launch

Post by mpack »

Please copy that explanation into the preferred thread, that way I'm sure the devs will see it even if they take a while to get around to your ticket. In the meantime I will lock this thread.
Locked