4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby moe » 18. Jul 2014, 07:36

Using F-Secure Client Security 11.60. Tested on both W8.1 & W7.
Error pops up during the software's startup.
Attachments
VirtualBox - Error In supR3HardenedWinVerifyProcess.png
VirtualBox - Error In supR3HardenedWinVerifyProcess.png (24.79 KiB) Viewed 27122 times
moe
 
Posts: 8
Joined: 28. Feb 2014, 13:38

Re: 4.3.14 conflicts with anti-virus packages.

Postby teschl » 18. Jul 2014, 09:00

Protection: KES 10 (10.2.1.23 (a)

Error on starting up a vm.

1.jpg
1.jpg (40.07 KiB) Viewed 27102 times
teschl
 
Posts: 5
Joined: 16. Jul 2014, 11:25

Re: 4.3.14 conflicts with anti-virus packages.

Postby BrollyLSSJ » 18. Jul 2014, 11:12

mpack wrote:Interesting post in the beta forum. I don't use resident antivirus so I've not tested it :-

JayEm wrote:Ok, i've researched the problem and found the solution.

It is caused by the following entry in the registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files\\Oracle\\VirtualBox\\VirtualBox.exe"="DISABLEUSERCALLBACKEXCEPTION"

Delete this entry, and everything works as expected.

The registry key is not present on my Windows 8.1 64 Bit System. So something else is causing the "Failed to install ntCreateSection monitor" message.
BrollyLSSJ
 
Posts: 5
Joined: 9. Jun 2007, 19:28

Re: 4.3.14 conflicts with anti-virus packages.

Postby MT » 18. Jul 2014, 12:58

Hi,

I've also a similar issue with Trend Micro Office Scan client version 10.6.2195 sp1 on Windows 7 Pro 64 bits with all windows update at this day.
Please see screenshot in attachment file.
For my case, the error appear when I open VirtualBox.

I've tried to unload Officescan client and then run VirtualBox: same issue.
Then I've tried to launch VB as administrator: same pb

The registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
"C:\\Program Files\\Oracle\\VirtualBox\\VirtualBox.exe"="DISABLEUSERCALLBACKEXCEPTION"
does not exist on my system.
Attachments
vbox4.3.14_issue.png
This file contains the screencap of my issue.
vbox4.3.14_issue.png (38.4 KiB) Viewed 27002 times
MT
 
Posts: 2
Joined: 18. Jul 2014, 12:43

Re: 4.3.14 conflicts with anti-virus packages.

Postby djk » 18. Jul 2014, 15:20

Is this confirmed to be an issue with anti-virus?

As I posted I removed all A/V and turned off the firewall still could not start the new release even with uninstall and fresh install reboot between each process. The previous release still works. Are any files or other information that would assist? It was mentioned a similar issue happened with 4.2 any chance whatever that was somehow got implemented again?

Thank you to the team for the attention on this.
djk
 
Posts: 11
Joined: 22. Nov 2008, 18:43

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 18. Jul 2014, 15:39

I already gave a similar summary in an earlier message: the actual problem is with any program that injects DLLs into the VirtualBox address space. VirtualBox thinks this is spyware. It turns out that many antivirus apps use this trick, probably to intercept Windows API calls - but there's at least one optional Windows feature which does it too (see the registry hack mentioned).

And of course, if you've been trojaned or rootkitted then that too could be responsible.

Basically, VirtualBox isn't making this up: if you get one of the described errors then something is attempting to spy on your VMs. The devs initially seemed to be taking the moral high ground - we shouldn't be allowing other apps to take liberties! But I'm sure that real world practicalities will win out soon.

A firewall is a networking filtering tool - I don't immediately see why having one enabled should contribute to this problem.
mpack
Site Moderator
 
Posts: 25471
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby Chelmers » 18. Jul 2014, 16:09

Same error here.
Can't start anything.
Without Avast Antivirus Free (Uninstalling, disabling isn't enough), Virtualbox works fine.

Version:
Virtualbox: VirtualBox-4.3.14-95030-Win + Oracle_VM_VirtualBox_Extension_Pack-4.3.14-95030.vbox-extpack
Avast Free: 2014.9.0.2021 (Program)
OS: Windows 7 Ultimate 64 (Sp1 / all Updates)
CPU: Phenom-II X4 840
RAM: 4 GByte DDR-II 800
Attachments
Virtualbox.jpg
Virtualbox.jpg (15.3 KiB) Viewed 26900 times
Chelmers
 
Posts: 1
Joined: 18. Jul 2014, 11:22

Re: 4.3.14 conflicts with anti-virus packages.

Postby heitkergm » 18. Jul 2014, 16:54

I'm seeing the same sort of error messages. Win 7 x64 Ultimate. AVG free version. Fully patched and up to date.

I had the initial startup issue with the .dll files, until I deleted the registry key.

Now the program starts, but I can't get any VM to start. I got the re-spawn error. On Linux VMs (Centos 6, FC 20).

Uninstalled and re-installed 4.3.12, all works great...
heitkergm
 
Posts: 12
Joined: 15. Jul 2014, 15:06

Re: 4.3.14 conflicts with anti-virus packages.

Postby eric55555 » 18. Jul 2014, 17:08

How do I get 4.3.12? I don't see it on Oracle. All I see there is 4.3.14.
eric55555
 
Posts: 1
Joined: 18. Jul 2014, 17:06

Re: 4.3.14 conflicts with anti-virus packages.

Postby Jacob Klein » 18. Jul 2014, 17:16

eric55555 wrote:How do I get 4.3.12? I don't see it on Oracle. All I see there is 4.3.14.

On Download page, go to Older Builds, and choose 4.3... To get 4.3.12.
Jacob Klein
 
Posts: 278
Joined: 20. Nov 2013, 01:07

Re: 4.3.14 conflicts with anti-virus packages.

Postby djk » 18. Jul 2014, 17:35

mpack wrote:I already gave a similar summary in an earlier message: (see the registry hack mentioned).


That registry does not exist in Windows 8.1 or a reference the value. Do you know what the equivalent would be?
djk
 
Posts: 11
Joined: 22. Nov 2008, 18:43

Re: 4.3.14 conflicts with anti-virus packages.

Postby supremo13 » 18. Jul 2014, 17:49

I am also receiving the "Error In supR3HardenedWinVerifyProcess" error on a corporate laptop running AV and have received many reports from my users.
Attachments
vboxerror1.PNG
vboxerror1.PNG (45.96 KiB) Viewed 26837 times
supremo13
 
Posts: 1
Joined: 18. Jul 2014, 17:40

Re: 4.3.14 conflicts with anti-virus packages.

Postby Trysis » 18. Jul 2014, 18:24

I have McAfee, so I assume that's why I'm having the issue, but it could be something else. I tried running as Administrator (from the GUI and CLI with Git Bash), but got the same error. I don't have the registry key mentioned. I don't want to uninstall/turn off McAfee, so I'm just downgrading to 4.3.12 and waiting for this "fix" to be fixed.
Trysis
 
Posts: 51
Joined: 12. Apr 2013, 22:06
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Linux, assorted; Windows 7; Windows 8.1

Re: 4.3.14 conflicts with anti-virus packages.

Postby djk » 18. Jul 2014, 18:33

Trysis wrote:I have McAfee, so I assume that's why I'm having the issue, but it could be something else.


I have Windows 7 Enterprise with McAfee the registry entry does not exist and 4.3.14 upgrade worked. Continue to wonder if the anti-virus is the issue. Are there any other debugging tools we can use to better identify what is causing the issue.
djk
 
Posts: 11
Joined: 22. Nov 2008, 18:43

Re: 4.3.14 conflicts with anti-virus packages.

Postby Anunes » 18. Jul 2014, 19:19

djk wrote:.... and 4.3.14 upgrade worked.


What you mean with "upgrade"? Did you simple overwrite the previous Version of 4.3.14? Or, as me, did first uninstall the previous version and install the new?
Anunes
 
Posts: 71
Joined: 17. Jul 2014, 18:49

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot], socratis and 37 guests