4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 24. Aug 2014, 16:32

Edward wrote:It failed to start the Ubuntu guest operating system

If you don't provide details then no one can help you, and I doubt the devteam will be interested either.
mpack
Site Moderator
 
Posts: 29925
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby VirtualBoxer63525 » 24. Aug 2014, 17:33

Version 4.3.15r95663 - still no luck.

Can start GUI but none of the virtual machines.

The virtual machine 'every-vm-failed' has terminated unexpectedly during startup with exit code 1 (0x1).
E_FAIL (0x80004005)
Interface:IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Code: Select all   Expand viewCollapse view
e64.be4: Log file opened: 4.3.15r95663 g_hStartupLog=0000000000000190 g_uNtVerCombined=0x611db110
e64.be4: Calling main()
e64.be4: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x2
e64.be4: SUPR3HardenedMain: Respawn #1
e64.be4: System32:  \Device\HarddiskVolume1\Windows\System32
e64.be4: WinSxS:    \Device\HarddiskVolume1\Windows\winsxs
e64.be4: ProgDir:   \Device\HarddiskVolume1\Program Files
e64.be4: ComDir:    \Device\HarddiskVolume1\Program Files\Common Files
e64.be4: ProgDir32: \Device\HarddiskVolume1\Program Files (x86)
e64.be4: ComDir32:  \Device\HarddiskVolume1\Program Files (x86)\Common Files
e64.be4: '\Device\HarddiskVolume2\VirtualBox\VirtualBox.exe' has no imports
e64.be4: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\VirtualBox\VirtualBox.exe)
e64.be4: supR3HardenedWinDoReSpawn(1): New child 454.a88 [kernel32].
e64.be4: supR3HardenedWinPurifyChild: PebBaseAddress=000007fffffdf000 cbPeb=0x380
e64.be4: supR3HardNtPuChFindNtdll: uNtDllParentAddr=00000000773f0000 uNtDllChildAddr=00000000773f0000
e64.be4: supR3HardNtPuChTriggerInitialImageEvents: uLdrInitThunk=000000007741c340 uNtTerminateThread=00000000774417e0
e64.be4: supR3HardNtPuChTriggerInitialImageEvents: kernel32.dll mapped at 00000000772d0000 LB 0x11f000
e64.be4: supR3HardNtPuChTriggerInitialImageEvents: KernelBase.dll mapped at 000007fefd2c0000 LB 0x6c000
e64.be4: supR3HardNtPuChTriggerInitialImageEvents: Startup delay kludge #1: 16 ms
e64.be4: Error (rc=-5640):
e64.be4: More than one thread in process
e64.be4: Fatal error:
e64.be4: More than one thread in process


Used third party software:

Avast (AV only, no sandbox etc)
Comodo (FW only, no sandbox, AV etc)
EMET 5.0 (exclusion of VirtualBox.exe doesn't matter)
VirtualBoxer63525
 
Posts: 4
Joined: 2. Aug 2014, 14:13

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 24. Aug 2014, 20:00

Hi All!

Here's a new test build, the 6th: https://www.virtualbox.org/download/tes ... 13-Win.exe

Fixes compared to the 5th:
* Fixed 3D regression that often manifested itself as a zero division crash.
* Relaxed ownership requirements a little to allow Tumbleweed Desktop Validator CAPI dlls to load. (DLL owner must be TrustedInstaller or System now.)

Hope this solves the outstanding issues for most of you.

Enjoy,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 24. Aug 2014, 20:26

SteveLF wrote:Using latest 4.3.15-95663 on Windows 7 Ultimate
VirtualBox installs and starts. When starting a VM, get a CERT_E_REVOCATION_FAILURE error and I have to click the Abort.
Attached is the VBoxStartup log.

Sure hope this helps you out.


SteveLF, could you check out the latest build, please? I think I've addressed the issue, but I don't have the software (Thumbleweed Desktop Validator) available for testing.

Many thanks in advance,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby cwahlgren » 24. Aug 2014, 20:41

4.3.15 r95711 now works with 3D enabled (didn't work in r95663 and earlier).
Thanks!
cwahlgren
 
Posts: 17
Joined: 10. Jul 2014, 17:24
Location: Stockholm, Sweden
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: CentOS 5,6,7

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 24. Aug 2014, 21:25

VirtualBoxer63525 wrote:Version 4.3.15r95663 - still no luck.

Code: Select all   Expand viewCollapse view
e64.be4: Log file opened: 4.3.15r95663 g_hStartupLog=0000000000000190 g_uNtVerCombined=0x611db110
e64.be4: Error (rc=-5640):
e64.be4: More than one thread in process
e64.be4: Fatal error:
e64.be4: More than one thread in process



This build should hopefully address the above issue: https://www.virtualbox.org/download/tes ... 13-Win.exe
(Seems NtQueryInformationThread confusing the calling process for the process the specified thread is associated with.)

VirtualBoxer63525: Could you please check if this helps you?

Kind Regards,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby VirtualBoxer63525 » 24. Aug 2014, 22:02

Could you please check if this helps you?


Still downloading 95713, very slow (max 10KB/s). Forum seems to be slow too.

Will install and reply Monday evening (CEST).
VirtualBoxer63525
 
Posts: 4
Joined: 2. Aug 2014, 14:13

Re: 4.3.14 conflicts with anti-virus packages.

Postby Cognizant » 25. Aug 2014, 00:02

Windows 8.1 64b
Avast
With your latest build I was able to run fedora. Mint 17 as long as I unchecked USB 2.0, but not any other session, (Kububtu no bodhi no Manjaro no, android86 no)

Failed to open a session for the virtual machine Kubuntu.

The virtual machine 'Kubuntu' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users********\VirtualBox VMs\Kubuntu\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
Attachments
VBoxStartup.log
(41.4 KiB) Downloaded 45 times
Cognizant
 
Posts: 5
Joined: 17. Nov 2013, 19:36
Location: Lake Sarasota FL. USA
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Fedora LinuxMint, PC-BSD, Kububtu

Re: 4.3.14 conflicts with anti-virus packages.

Postby stefan.becker » 25. Aug 2014, 00:06

Last version looks good.

95713 is a usable Version.

Host Win 8.1 64 Bit, AMD Radeon

Guests (Win7, 8.1 32/64) are working with 2D and 3D enabled, Aero in Win7 is working.

Thanks for fixing the errors!
stefan.becker
Volunteer
 
Posts: 7543
Joined: 7. Jun 2007, 21:53

Re: 4.3.14 conflicts with anti-virus packages.

Postby somnang » 25. Aug 2014, 05:47

I think I got errors because USB2.0 was turned on which is why it require the Extension Pack I mention earlier. I do not believe I turned it on cos I don't normally use VM with USB2 ticked.

VirtualBox-4.3.15-95713-Win.exe works flawlessly without the Extension Pack installed. And that is probably because I checked everything else before I started the VM this time. And yes, I had to unticked the USB2.0 which I do not believe I turned that on.

Trying to install 4.3.14, the VM somehow may have alter the USB2.0 by itself. Don't want to install 4.3.14 to confirm my mistake tho... now that this version works flawlessly.
somnang
 
Posts: 6
Joined: 16. Jul 2014, 20:19

Re: 4.3.14 conflicts with anti-virus packages.

Postby Dorobo18jp » 25. Aug 2014, 09:46

running emsisoft anti malware Microsoft security essentials and spybot
I stopped all of them but same problem.

The error is VirtualBox - Error In supR3HardenedWinVerifyProcess

Sorry i cant put photo yet.

It was running fine until I cleaned my PC and removed some Malware.

Thanks for the help.
Dorobo18jp
 
Posts: 1
Joined: 25. Aug 2014, 09:35

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 25. Aug 2014, 11:48

Cognizant: Looks like the avast tricks doesn't quite make it on your system.

winchester: The driver is stuck unloading or loading. Afraid rebooting is the only way to solve that issue.

Dorobo18jp: I need VBoxStartup.log for that failure, not a screen shot. Should be mentioned in the error message. (If not, you'll find it in the Logs folder of the VM you tried to start.)

-bird
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby Edward » 25. Aug 2014, 13:23

Hi Virtual Box Devteam,

The 6th test build VirtualBox 4.3.15 (build 95713) work flawlessly without any problems on my machine now.
Thank you very much.
Edward
 
Posts: 3
Joined: 23. Aug 2014, 14:45

Re: 4.3.14 conflicts with anti-virus packages.

Postby Dean » 25. Aug 2014, 14:30

OS: Windows 7 x64

VirtualBox: 4.3.14 & 4.3.15

CPU: i5-3570

Motherboard: Gigabyte GA-H77M-D3H

AV: BitDefender

I receive the error below when I try to run a virtual machine with Enable VT-x/AMD-V on. With this setting off the virtual machine runs successfully.

Failed to open a session for the virtual machine
MachineName

VT-x is being used by another hypervisor.
(VERR_VMX_IN_VMX_ROOT_MODE).

Virtualbox can't operate in vmx root mode. Please close all other virtualization programs.
(VERR_VMX_IN_VMX_ROOT_MODE).
I have the virtulization settings set to on in BIOS.

I tried updating BIOS, it didn't fix the problem.

When my BIOS was updated virtulization was off by default, and going into VirtualBox the Enable VT-x/AMD-V option wasn't there, I turned virtulization back on and the option was back - so VirtualBox appears to correctly know when my virtulization is on.

I tried updating VirtualBox from 4.3.14 to 4.3.15, still the same problem.

Downgrading to 4.3.12 fixed the problem however, so it appears to be a bug in 4.3.14 & 4.3.15 possibly related to the AV problem.
Dean
 
Posts: 1
Joined: 25. Aug 2014, 14:25

Re: 4.3.14 conflicts with anti-virus packages.

Postby Milo.name » 25. Aug 2014, 14:59

cwahlgren wrote:4.3.15 r95711 now works with 3D enabled (didn't work in r95663 and earlier).
Thanks!

Does not work (r95711). r95713 does not work either.

Failed to open a session for the virtual machine Test.

This VM was configured to use 3D acceleration. However, the 3D support of the host is not working properly and the VM cannot be started. To fix this problem, either fix the host 3D support (update the host graphics driver?) or disable 3D acceleration in the VM settings (VERR_NOT_AVAILABLE).

Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Video driver has been updated to the latest version.
Milo.name
 
Posts: 1
Joined: 25. Aug 2014, 14:06
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 8.1 x64

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 40 guests