Page 21 of 40

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 05:56
by just_to_report_a_bug
Test build VirtualBox-4.3.15-95226-Win.exe still fails for me:

Code: Select all   Expand viewCollapse view
c94.374: Log file opened: 4.3.15r95226 g_hStartupLog=000017d0 g_uNtVerCombined=0x510a2830
c94.374: Calling main()
c94.374: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x0
c94.374: SUPR3HardenedMain: Respawn #1
c94.374: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume1\PROGRAMS\Oracle\VirtualBox\VirtualBox.exe)
c94.374: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume1\PROGRAMS\Oracle\VirtualBox\VirtualBox.dll)
c94.374: supR3HardenedWinDoReSpawn(1): New child bc4.19c [kernel32].
c94.374: supR3HardenedWinPurifyChild: PebBaseAddress=7ffdf000 cbPeb=0x20c
c94.374: supR3HardNtPuChFindNtdll: uNtDllParentAddr=7c900000 uNtDllChildAddr=7c900000
c94.374: supR3HardNtPuChTriggerInitialImageEvents: pvLdrInitThunk=7c901166 pvNtTerminateThread=7c90de7e
c94.374: supR3HardNtPuChSanitizeImage: 00400000 '\Device\HarddiskVolume1\PROGRAMS\Oracle\VirtualBox\VirtualBox.exe'
c94.374: supR3HardNtPuChSanitizeMemory: Freeing exec mem at 71b00000 (71b00000 LB 0x1000)
c94.374: supR3HardNtPuChSanitizeImage: 7c900000 '\Device\HarddiskVolume1\WIN\system32\ntdll.dll'
c94.374: supR3HardenedWinDoReSpawn(1): Quitting: ExitCode=0xc0000005 rcNt=0x0


Host: Windows XP SP3, with application injectors: Comodo Firewall (guard32.dll) and WindowFX (wfx.dll)

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 09:54
by dracula
After installing the first test build I was able to start Virtualbox. After the the second one I was able to start the vms. But the performance compared to 4.3.12 is worse.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 10:27
by MikeDiack
Update:

I can confirm the newest build VirtualBox-4.3.15-95226-Win.exe works for me on Windows 7 SP1 x64, with Symatec Endpoint 12.1.4100.4126, but NOT with Comodo Internet Security 7.0.317799.4142.

Message when running on Comodo:
Failed to open a session for the virtual machine XP.
The virtual machine 'XP' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'C:\Users\Mike\VirtualBox VMs\XP\Logs\VBoxStartup.log'.
Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}


BUT:
Like others I've noticed two problems with the 2nd 4.3.15 test build.

SIGNIFICANT PROBLEM:
1) Running a Windows 7 SP1 x86 Guest on the Win 7 SP1 x64 Host (Symantec Endpoint Protection) - the guest Win 7 PC very rarely boots successfully and the guest Win 7 PC often hangs during shutdown (which also hangs virtualbox - needing a reboot of the host machine!). Note - it doesn't seem to happen for XP guests on the host PC.

SMALLER PROBLEM/ANNOYANCE:
2) It is taking longer for the VM's to go to their virtualbox BIOS (i.e. slower startup)

Mike

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 11:59
by BrollyLSSJ
The "Failed to install ntCreateSection monitor" message is gone with the latest VBox Test Builds. But my VM does not start. I probably have a special VM (no VMDK / VDI, but a USB Thumbdrive which contains the data) though.

Failed to open a session for the virtual machine FedoraUSB.

The virtual machine 'FedoraUSB' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'S:\VirtualBox VMs\FedoraUSB\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}


I directly installed Fedora on my USB drive through VB and use that to boot the VM. I hope the attached log helps.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 13:29
by mpack
Yikes2000 wrote:Latest 4.3.15 didn't work for me. Still same error, couldn't start VMs.

Please don't say "same error", don't make us search back: it's best to give a precise error message every time you post.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 26. Jul 2014, 19:55
by greggilo
Thanks James!
The 4.3.15 update fixed all the issues I had listed in the 4.3.14 conflicts with anti-virus packages.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 06:48
by J.L.
They missed it because apparently their testing machines are clean to the extent of not having NVIDIA drivers installed. Or did those specific DLL injections ever cause a crash? Well they clearly didn't test compatibility with antivirus and other common products. P.S. It's a feature, not a bug.

Anyhow, progress update on Avast and hopefully other issues I've reported? New builds ETA if any?

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 13:08
by luisdev
I installed VirtualBox-4.3.14-95030-Win.exe on my Windows 7 Ultimate SP1 x64 machine which is running Comodo Internet Security Premium 7.0.317799.4142.

The VirtualBox installation completed without any problems. But when I click the Oracle VM VirtualBox shortcut in my Start menu I get a "Error In supR3HardenedWinInstallHooks" error saying: "Failed to install NtCreateSection monitor". I've attached a screenshot of the full error message.

Disabling Comodo anti-virus does not help.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 13:12
by mpack
How much of this thread did you read before posting? E.g. the first post gives a link to a new build for you to try.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 15:20
by MikeDiack
Further update on my tests with 4.3.15

I said earlier of the 2nd test build: VirtualBox-4.3.15-95226-Win.exe

SIGNIFICANT PROBLEM:
1) Running a Windows 7 SP1 x86 Guest on the Win 7 SP1 x64 Host (Symantec Endpoint Protection) - the guest Win 7 PC very rarely boots successfully and the guest Win 7 PC often hangs during shutdown (which also hangs virtualbox - needing a reboot of the host machine!). Note - it doesn't seem to happen for XP guests on the host PC.

However, I've now noticed that this hang on shutdown ONLY seems to occur if I have the 4.3.15 guest additions installed for the Win 7 SP1 x86 Guest (configured to run the WDDM drives for Aero support). If I uninstall the guest drivers - the hang on shutdown problem (for the guest) goes, if I reinstall the guest drivers, the hang on shutdown problem (for the guest) reappears.

Mike

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 15:39
by luisdev
mpack wrote:How much of this thread did you read before posting? E.g. the first post gives a link to a new build for you to try.


All of it. But I did make one mistake in my post - I installed 4.3.15-95226 and not 4.3.14-95030 as I indicated in my post. Sorry about that. I'll rollback the installation and reinstall everything (using 4.3.15-95226).

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 18:46
by RichardDawkins
Hi!

I re-installed my host machine from Windows 7 to Windows 8.1, I cannot launch my VMs through VirtualBox anymore.

I am using test release 4.3.15.

Same problem on two VMs: Windows 7 64bit and RedHat 64bit:

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 20:33
by awesome_cool
I am using win 8.1 update 1 and facing similar problem. I tried installing 4.3.14, and 4.2.26 and still facing the problem. I am using avast and will be trying 4.3.12

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 21:26
by awesome_cool
The only way to resolve this issue would be to install Virtualbox 4.3.12 -93733 win.exe

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 27. Jul 2014, 23:31
by Bunatl
I installed versions:
4.3.12
4.3.14
even 4.3.15
all these versions failed on:

Failed to open a session for the virtual machine Ubuntu.

No error info.

Result Code: RPC_S_SERVER_UNAVAILABLE 0x800706BA (0x800706BA)
Component: ProgressProxy
Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}


Image

Have Win 7, 64bit

Any ideas ? Thx :)