Page 14 of 40

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 02:53
by MarcSant
socratis wrote:@MarcSant
It's not just about antivirus. It's about any process that (...) injects a DLL in another process. Graphic card drivers like NVidia for example have been known of doing that, as well as window (re)management utilities. That is not an exclusive list by any means.


I got it! I read all posts by now... You're right.

Well, let's wait them!

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 02:58
by MarcSant
J.L. wrote:
MarcSant wrote:Sorry for the dumb question but, what about the people that don't have an AV product installed? I made a factory recover for my Dell machine, without any program of fix installed, just OS (Windows 8 Professional), installed VB and restored VM images, and in the end I got the same error.

So, I presume that Av incompatible are not the point here: we are facing some kind of bug in the product, and in my opinion will be fixed soon. For those that need VB up and running again just remove the newer version and install the old one. Simple as that.

Not really a dumb question, but are you sure you're replying to the right post? I only said AV as an example in that case. Any non-whitelisted DLL injection could be the cause, as I've said before.

Unfortunately, I have a feeling they will treat it as a feature instead of a bug. Don't forget to download new guest additions if you want some more bugs fixed.


Alright, I got the point. Well, In my opinion since this 'bug' in this release could be break some stable environments, why the download package still available for download? Since they understand that we have a bug (dll injection, or something else) the download links should be removed and a warning issued to inform the users to stay with the old version until a fix is not applied.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 03:13
by J.L.
Are you sure you've read all the posts?: https://forums.virtualbox.org/viewtopic ... 35#p293652

Don't know why they haven't issued a warning though.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 10:53
by ktr
as kindly being asked in thread "Windows hardening in version 4.3.14" I can supply the following informations:

  • I just updated to VirtualBox 4.3.14r95030
  • I use Windows 7 with the lastest updates installed as host system and want to run Windows XS 32 bit as guest systems
  • I use AVG Antivirus Business Edition 2012
  • German setup
here come two screen shots showing the error messages...

Hope that helps :)

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:01
by bird
Here's a test build of 4.3 that include fixes that should address the following issues:
  • Startup time, especially the VM selector.
  • Issues that the DISABLEUSERCALLBACKEXCEPTION registry change fixes.
  • supR3HardenedWinReSpawn error -104.
  • Norton Endpoint Protect / sysfer.dll
It may address issues 4.3.14 has with other protection software solutions too, feedback on what's fixed is appreciated (no need to reiterate what's not fixed and already reported).

Link: https://www.virtualbox.org/download/tes ... 71-Win.exe

Enjoy!
- bird

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:07
by yesoos
As Frank requested in different post:

My configuraiont windows 8.1 64-bit, Kaspersky Internet Security 14.0.0.4651(g).

Screenshots of the issue:

https://forums.virtualbox.org/viewtopic ... 15&t=62556

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:30
by jefke
bird wrote:Here's a test build of 4.3 that include fixes that should address the following issues:
  • Startup time, especially the VM selector.
  • Issues that the DISABLEUSERCALLBACKEXCEPTION registry change fixes.
  • supR3HardenedWinReSpawn error -104.
  • Norton Endpoint Protect / sysfer.dll
It may address issues 4.3.14 has with other protection software solutions too, feedback on what's fixed is appreciated (no need to reiterate what's not fixed and already reported).

Link: https://www.virtualbox.org/download/tes ... 71-Win.exe

Enjoy!
- bird


Hi bird,




Can I be so curious as to ask how this issue was solved? Is it indeed some kind of whitelisting approach that you are following, or did you apply a generic fix?

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:31
by ktr
bird wrote:Here's a test build of 4.3 that include fixes that should address the following issues:
  • Startup time, especially the VM selector.
  • Issues that the DISABLEUSERCALLBACKEXCEPTION registry change fixes.
  • supR3HardenedWinReSpawn error -104.
  • Norton Endpoint Protect / sysfer.dll
It may address issues 4.3.14 has with other protection software solutions too, feedback on what's fixed is appreciated (no need to reiterate what's not fixed and already reported).

Link: h t t p s : / / www . virtualbox . org / download / testcase / VirtualBox-4.3.15-95171-Win.exe

Enjoy!
- bird


Thanks for this test version. Unfortunately, not quite :-)
This time there is only one error dialog, pls see attachment. No successful VM launch :-(

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:40
by LotharL
Same problem here (for a Windows-Guest and for a Linux-Guest), running on Windows 7/64-SP1 and
VirtualBox-4.3.15-95171-Win with "Oracle_VM_VirtualBox_Extension_Pack-4.3.14-95030.vbox-extpack"
installed:
VBox-Issue.jpg
VBox-Issue.jpg (34.36 KiB) Viewed 4883 times

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 11:56
by michaln
MarcSant wrote:Did you got it? Again, why they won't remove this since we cannot estimate when a fix will be released? I'm a developer too, working with JD Edwards, and in an Corporate Environment this is not acceptable. My manager probably will fire me (at least) if we wrote some wrong code that stop any customer critical process.

You'd be fired for using software with no support contract for critical processes, surely? And deploying an upgrade before fully verifying that it works for you?

If you are an Oracle customer and have problems, please do contact your support representative.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 12:01
by cwahlgren
bird wrote:Here's a test build of 4.3 that include fixes that should address the following issues:
  • Startup time, especially the VM selector.
  • Issues that the DISABLEUSERCALLBACKEXCEPTION registry change fixes.
  • supR3HardenedWinReSpawn error -104.
  • Norton Endpoint Protect / sysfer.dll
It may address issues 4.3.14 has with other protection software solutions too, feedback on what's fixed is appreciated (no need to reiterate what's not fixed and already reported).

Link: https://www.virtualbox.org/download/tes ... 71-Win.exe

Enjoy!
- bird


Hi,

This version does install and I can run the Manager GUI (couldn't even start with .14), but I can't start any VM:
Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine centos7.

The virtual machine 'centos7' has terminated unexpectedly during startup with exit code 1.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

I have Windows 7 Enterprise, Symantec Endpoint Protection 12.1.2100.2093

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 12:30
by michaln
If anyone is wondering... the reason why VirtualBox 4.3.14 will not be withdrawn is here: http://www.oracle.com/technetwork/topic ... 72956.html

Please note that any further detail cannot be and will not be provided via this forum, but Oracle customers may request additional information through existing support channels.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 13:07
by MarcSant
michaln wrote:
MarcSant wrote:Did you got it? Again, why they won't remove this since we cannot estimate when a fix will be released? I'm a developer too, working with JD Edwards, and in an Corporate Environment this is not acceptable. My manager probably will fire me (at least) if we wrote some wrong code that stop any customer critical process.

You'd be fired for using software with no support contract for critical processes, surely? And deploying an upgrade before fully verifying that it works for you?

If you are an Oracle customer and have problems, please do contact your support representative.


You didn't get the point here: my complain is about a company that knows the problem and DO NOTHING to avoid harm more people. If I haven't proper support using VB I will switch to Vmware, or another VM solution, but, that is not the point. I just gave to you an example in a corporate situation that you DELIVER a software (paid or not) without fully verified as we saw here.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 13:14
by kaesii
Hi,

VB running on Windows 7 \ 8.1 - created a VM and getting the following error.

Please let me know.

Thanks.

Markus

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 23. Jul 2014, 13:23
by michaln
MarcSant wrote:If I haven't proper support using VB I will switch to Vmware, or another VM solution, but, that is not the point.

Translation: I will continue not giving you any money and I'll stop complaining! I'm afraid this is not going to be very effective...

Once again... if you're an Oracle customer, please contact your support representative. If you're not, please understand that you can take a free product or leave it, but you have no leverage to make any demands.

We are not happy about the problems 4.3.14 is causing for Windows users either, but we unfortunately have no choice. All we can do is fix the issues one by one, and we are working on that.