Page 2 of 40

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 15:56
by ekaye
mpack wrote:Interesting post in the beta forum. I don't use resident antivirus so I've not tested it :-

JayEm wrote:Ok, i've researched the problem and found the solution.

It is caused by the following entry in the registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files\\Oracle\\VirtualBox\\VirtualBox.exe"="DISABLEUSERCALLBACKEXCEPTION"

Delete this entry, and everything works as expected.
I'm running TREND MICRO OfficeScan 10.6.5372 SP3, centrally managed, and I'm having the same error. I don't have the registry key in question. I have the keys up to AppCompatFlags, but no Layers key. So this isn't a universal solution.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 16:20
by NilexBM
cremor wrote:I get the following error with McAfee when starting the Manager. I can't disable McAfee since this is a corporate PC and the scanner is configured by Domain settings.

Image


I got exactly the same error with Symantec Endpoint Protection.

Re: Error in supR3HardenedWinReSpawn

PostPosted: 16. Jul 2014, 16:51
by prowin
downgraded Virtuabox to 4.3.12 resolved issue for me, I am using Windows 7 Host (base OS) and Solaris as guest OS.
teekaytee5 wrote:I am observing same error raised by VirtualBox after 1st start of Ubuntu from iso.

VirtualBox 4.3.14r95030

Host:
Windows Vista Home Premium 32-bit
Service Pack 2
Intel Core2 Duo P8600 2.4 GHz

Target:
ubuntu-14.04-desktop-i386

Abort Dialog Title
---------------------
VirtualBox - Error In supR3HardenedWinReSpawn

Abort Dialog Message
-------------------------
Error relaunching VirtualBox VM process: 5
Command line: '81954AFS-4D2F-31EB-A142-B7AD187A1C41 -suplib-2ndchile --comment "Ubuntu 14 server" --startvm f2c461eb-6004-4956-9c2f-08280f6c8026 --no-startvm-errormsgbox' (rc=-104)

Abort Dialog screenshot
----------------------------
virtualbox 1.JPG



OnAbort Message
---------------------
Failed to open a session for the virtual machine Ubuntu 14 server.
The virtual machine 'Ubuntu 14 server' has terminated unexpectedly during startup with exit code 1.

OnAbort Details
-------------------
Result Code:
E_FAIL (0x80004005)
Component:
Machine
Interface:
IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

OnAbort screenshot
-----------------------
virtualbox 2.JPG

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 18:21
by mpack
We (mods and volunteers) have put together an official statement about this new feature, see Windows hardening in version 4.3.14.

I should also clarify that what the issue actually is, is VirtualBox detecting that its process space is being invaded by some malign influence (ie. DLL injection). It could be something trying to spy on what you do inside the VM! Typically this will turn out to be antivirus packages, but it could be other things, such as certain kinds of debugger, or actual malware. However I'll keep things simple and leave this topic name as it is, since it reflects what the typical user will see as the problem.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 18:25
by larsen
Posting in thread to mention "supR3HardenedWinVerifyProcess" so that search engines will find this error. So far, Google and the forum search only shows another thread.
Unfortunately, it isn´t possible to copy the text from the error message so of course everybody´s posting screenshots...

Hopefully, mpack doesn´t have to lock anymore threads now.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 18:26
by mpack
I thought that word occurred already in this topic, but come to think of it - maybe only in images. So that was helpful, thanks.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 18:41
by larsen
You´re welcome. Would be good to improve the error dialog to be able to copy the text.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 19:22
by dirkt
When you want to grab the text from an error dialog try Ctrl-C, it will sometimes work. This is the text from the error that I am getting when I start the VB Manager:

---------------------------
VirtualBox - Error In supR3HardenedWinVerifyProcess
---------------------------
<html><b>Failed to verify process integrity: More than one thread in process (rc=-5640)</b><br/><br/>Please try reinstalling VirtualBox.</html>
---------------------------
Abort
---------------------------

64-bit Windows 7
Symantec Endpoint Protection version 12.1.3001.165

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:04
by cathsaigh
VirtualBox-Error.png
Screenshot
VirtualBox-Error.png (23.94 KiB) Viewed 12086 times

topic: supR3HardenedWinVerifyProcess

Same Error:

Symantec Endpoint Protection (v. 12.1.2015.2015)
VirtualBox (v. 4.3.14r95030)

Error:
VirtualBox - Error In supR3HardenedWinReSpawn

Error relaunching VirtualBox VM process: 5
Command line:'81954AF5-4D2F-31EB-A142-B7AF187A1C41-suplib-2ndchild
--comment xbuntu-13.04 --startvm 80d8950e-f77e-413c-
a065-648c6fcc2a64 --no-startvm-errormsgbox' (rc=-104)

Failed to open a session for the virtual machine xbuntu-13.04.

The virtual machine 'xbuntu-13.04' has terminated unexpectedly during startup with exit code 1.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:09
by dirkt
I reinstalled a utility that manages windows in Windows 7, 64-bit WindowSpace. Now when VB Manager is started the following error occurs 10 times:
---------------------------
VirtualBox.exe - Bad Image
---------------------------
C:\Program Files\WindowSpace\wspace64.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.
---------------------------
OK
---------------------------

Then the previous error I reported which comes up immediately when WindowSpace is not installed:
---------------------------
VirtualBox - Error In supR3HardenedWinVerifyProcess
---------------------------
<html><b>Failed to verify process integrity: More than one thread in process (rc=-5640)</b><br/><br/>Please try reinstalling VirtualBox.</html>
---------------------------
Abort
---------------------------

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:13
by ElQuia
cremor wrote:I get the following error with McAfee when starting the Manager. I can't disable McAfee since this is a corporate PC and the scanner is configured by Domain settings.

Image


Installed 4.3.14 yesterday. Got the same (or similar error) Virtual Box will not run only shows a screen like this. Using Eset ESS 7, had to uninstall and reinstall 4.3.12 which works with NO sort of problems
Host is Win 7 x64, LOTS of guests, linux, windows, bsd, about 12 guests ALL work OK with .12

Agree with the roll back motion. I am OBVIOUSLY staying with .12 as .14 does not run :twisted:

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:23
by somnang
This is what I got... never got pass this error...
VBerror.PNG
VBerror.PNG (41.93 KiB) Viewed 12073 times


Only option is to "Abort". VirtualBox never started due to that error.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:27
by gupsgrotto
Same issue with 4.3.14. Conflicts with Oracle Enterprise Single Signon, Avecto Privilege Guard, SafeCom Print Client, and who know what else at this point

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 16. Jul 2014, 20:43
by gupsgrotto
Same error as everyone else. Please include Oracle Enterprise Single Signon, Avecto Privilege Guard, Safecom Print, and just about any hardening software used by enterprise, any password manager (single signon style app), etc. There are significant number of applications that inject themselves into processes in the enterprise level. This seems like Virtualbox dev's made a significant decision without involving the end users. How about an install for with/without hardening process.

Re: 4.3.14 conflicts with anti-virus packages.

PostPosted: 17. Jul 2014, 00:32
by rseiler
MikeDiack wrote:Microsoft Security Essentials Pre-release (4.6) is compatible with Virtual Box 4.3.14.
As of the moment, this appears (to my knowledge) to be the only (common) AV that IS compatible with VB 4.3.14

Probably no coincidence, but Windows Defender in Win81 (client ver 4.5.218.0) also has shown no problem for me in running XP, 7, and 8.1 clients.

This suggests that the release version of MSE on Win7 (as host) also wouldn't show the problem, but I haven't tested that.