4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby BrianG61UK » 14. Aug 2014, 18:23

I tried VirtualBox 4.3.15 build 95286 today.
I'm running it on Windows 7 Ultimate 64 bit.
I'm using Microsoft Security Essentials (latest version) and MalwareBytes Anti-Malware 2.0.2.1012 Premium together as my anti virus. Most features of both programs are enabled.
I also have Sandboxie 4.12 (64 bit) installed (probably not relevant but thought I'd say anyway).
My virtual machines are all 32 bit. One is Windows 7 Home Premium and the other in Linux Mint.
The virtual machines all start okay once I've installed the 4.3.14 extension pack (which I had to work out how to do since the usual method of just double clicking the file didn't seem to work). I installed the 4.3.14 guest additions.
Then I found the Windows 7 virtual machine would not reboot. In fact it can't complete a shutdown at all.
I tried shutting down the Linux VM too and it got stuck at the end of shutting down.

So it nearly works, much better than 4.3.14 anyway.
BrianG61UK
 
Posts: 50
Joined: 21. Mar 2014, 02:15
Location: Reading. Berkshire. UK.
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, DOS, Linux

Re: 4.3.14 conflicts with anti-virus packages.

Postby GKDemo » 15. Aug 2014, 02:31

VirtualBox Staff,

This reply confirms that 4.3.15 resolves the issue identified. Verified on Windows 7 Enterprise with SP1 (x64).

Any idea when this and the version-specific extension pack may be coming out?

Thank you.
GKDemo
 
Posts: 8
Joined: 8. Nov 2013, 00:17

Re: 4.3.14 conflicts with anti-virus packages.

Postby perat » 15. Aug 2014, 16:09

I'm using Windows 8.1 Pro x64.
Today I've upgraded from 4.3.14 to VirtualBox 4.3.15 (build 95286). And now I get error message when trying to start any old or new VMs:
"NtCreateFile(\Device\VBoxDrvStub) failed: 0x0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries) (rc=-101)
Make sure the kernel module has been loaded successfully."

And then:
"Failed to open a session for the virtual machine Test.

The virtual machine 'Test' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\perebeynosov\VirtualBox VMs\Test\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
"

Log-file and screenshots attached.
Attachments
VirtualBox 4.3.15 build 95286 error 2.PNG
VirtualBox 4.3.15 build 95286 error 2.PNG (14.68 KiB) Viewed 10075 times
VirtualBox 4.3.15 build 95286 error 1.PNG
VirtualBox 4.3.15 build 95286 error 1.PNG (11.03 KiB) Viewed 10075 times
VBoxStartup.log
(20.43 KiB) Downloaded 114 times
perat
 
Posts: 3
Joined: 5. Sep 2013, 21:13

Re: 4.3.14 conflicts with anti-virus packages.

Postby AnrDaemon » 15. Aug 2014, 17:52

Not only Antivirus package, but even something as simple as keyboard layout indicator or Now Playing plugin cause 3.14/3.15 to crash.
AnrDaemon
 
Posts: 134
Joined: 7. Feb 2010, 23:41
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu Linux, Windows

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 15. Aug 2014, 18:03

Yes, it can be anything that injects DLLs into another process. Some details of your problem would have been nice.
mpack
Site Moderator
 
Posts: 33703
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby th1b.taylor@att.net » 16. Aug 2014, 10:04

I downloaded the Beta from the link and installed it and as I reached the point that it would be writting the files I got;
The exception Breakpoint
A breakpoint has been reached.
(0x80000003)occurred in the application at location 0x186961b7.

I am running a week old HP Presario Slim Line 499-224 with an AMD A5000 quad, 6gig RAM with windoze8. The Anti-Virus is AVG and Adaware.
Killer Spade 806
CE 1969
Bill Taylor
th1b.taylor@att.net
 
Posts: 3
Joined: 16. Aug 2014, 08:26
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Mint17

Re: 4.3.14 conflicts with anti-virus packages.

Postby ac.paulo » 16. Aug 2014, 13:30

Hi,

I'm having same problem. I'm using Windows 8.1 64 bits.
I'm able to use my virtual machines if I use Virtual Box 4.3.6 r91406

with that version I've no problem executing any of the machines.

I've tried version 4.3.12, 4.3.14 and they don't work
with 'special' version 4.3.15 I have an error when installing.

best regards,
ac.paulo
 
Posts: 1
Joined: 16. Aug 2014, 13:23

Re: 4.3.14 conflicts with anti-virus packages.

Postby olemars » 16. Aug 2014, 14:37

4.3.15.95286 solved startup issues for me, Win8.1 host, WinXP guests, Norton Internet Security.
olemars
 
Posts: 1
Joined: 28. Jun 2010, 11:15
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win XP, OpenSUSE

Re: 4.3.14 conflicts with anti-virus packages.

Postby kpl05 » 16. Aug 2014, 15:44

The suggested test build of VirtualBox 4.3.15 fixes the problem for me too. My PC runs Windows 8.1 with Trend Micro Titanium Internet Security installed.
kpl05
 
Posts: 1
Joined: 16. Aug 2014, 15:41

Re: 4.3.14 conflicts with anti-virus packages.

Postby mesosteros » 16. Aug 2014, 17:18

I also got the problem fixed with the 4.3.15 build. Running Windows 8.1 and Norton Internet Security as my anti-virus.
mesosteros
 
Posts: 1
Joined: 16. Aug 2014, 17:17

Re: 4.3.14 conflicts with anti-virus packages.

Postby VickersNick » 16. Aug 2014, 20:54

Got a refurb laptop and loaded Windows 8.1 32bit and VirtualBox 4.3.14 which worked without a problem until I installed AVG 2014. Then I got the errors described in this thread.

When I tried to install VB 4.3.15, the installation froze. After that I tried to repair the installation (see enclosed) and it froze in the same spot. I next tried to completely uninstall VB and reinstall it...same thing.
Attachments
4.3.15_repair_frozen.png
4.3.15_repair_frozen.png (12.38 KiB) Viewed 9746 times
VickersNick
 
Posts: 41
Joined: 10. Jan 2014, 21:38
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: XP, 7, Ubuntu, Mint

Re: 4.3.14 conflicts with anti-virus packages.

Postby macro » 17. Aug 2014, 04:22

Since somebody feels like it is a good idea to keep posting to a thread whose subject has become irrelevant instead of starting a new one to identify the current status of our predicament with VirtualBox on Windows, I will just pretend to overlook the obvious and post my two cents worth here as well, hoping, as it were, that my contribution is helpful in some way and that I can expect to get support for this issue at some point. I installed on a 64-bit Windows 7 Pro OS, which has no third-party AV, but only Microsoft Security Essentials, as well as MS Enhanced Mititgation Experience Toolkit 4.1.

I have tried the now defunct 4.3.14 version but had no better luck than the others had, failing to get it even installed. Moving on to the newer 4.3.15 version lately, I am happy to say that it installed, but, unfortunately, it would not launch any of my VMs, neither Windows nor Linux VMs. This popup occured with a Windows VM:

"Failed to open a session for the virtual machine W2K8 Server.

The virtual machine 'W2K8 Server' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'E:\VirtualMachines\VirtualBox\W2K8 Server\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}"
----------------------
I looked at the VBoxStartup.log, and this is it:

14fc.428: Log file opened: 4.3.15r95286 g_hStartupLog=00000000000000c4 g_uNtVerCombined=0x611db110
14fc.428: Calling main()
14fc.428: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x0
14fc.428: SUPR3HardenedMain: Respawn #1
14fc.428: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\Program Files\Oracle\VirtualBox\VirtualBox.exe)
14fc.428: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\Program Files\Oracle\VirtualBox\VirtualBox.dll)
14fc.428: supR3HardenedWinDoReSpawn(1): New child 1134.49c [kernel32].
14fc.428: supR3HardenedWinPurifyChild: PebBaseAddress=000007fffffde000 cbPeb=0x380
14fc.428: supR3HardNtPuChFindNtdll: uNtDllParentAddr=0000000077c20000 uNtDllChildAddr=0000000077c20000
14fc.428: supR3HardNtPuChTriggerInitialImageEvents: pvLdrInitThunk=0000000077c4c340 pvNtTerminateThread=0000000077c717e0
14fc.428: Error (rc=-5640):
14fc.428: More than one thread in process
14fc.428: Fatal error:
14fc.428: More than one thread in process
------------------------------------
That's about all I know at this point, and I would really like to hear any suggestions of how to get over it. Aside from that, I will just continue using the last known working version until the problem is managed. Thanks.
macro
 
Posts: 64
Joined: 11. Apr 2013, 05:02

Re: 4.3.14 conflicts with anti-virus packages.

Postby managedkaos » 17. Aug 2014, 07:52

I installed 4.3.14 on Windows 8.1 and was getting the following error:

Failed to open a session for the virtual machine vm.

The virtual machine 'vm' has terminated unexpectedly during startup with exit code 1.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}


Screen shots follow:
Virtual Box_Screenshot_1.png
Virtual Box_Screenshot_1.png (17.72 KiB) Viewed 9653 times

Virtual Box_Screenshot_2.png
Virtual Box_Screenshot_2.png (17.69 KiB) Viewed 9653 times


Installed 4.3.15 on the same system and was able to create a VM without error. Thanks all for the input and Oracle for the support.

Cheers,

Michael J
Managed Kaos
managedkaos
 
Posts: 1
Joined: 17. Aug 2014, 07:47

Re: 4.3.14 conflicts with anti-virus packages.

Postby arualex@gmail.com » 18. Aug 2014, 12:39

My Virtualbox 4.3.14 was running on Windows8 and faced the same problem.
Temporarily disabling the firewall in my McAfee Antivirus resolved the issue for me.
arualex@gmail.com
 
Posts: 1
Joined: 18. Aug 2014, 12:36

Re: 4.3.14 conflicts with anti-virus packages.

Postby Derragen » 18. Aug 2014, 15:59

I have this error:
Image
When i click on "Abort" a new window opens with the following text:
The opening of the working process of the virtual machine was unsuccessful: Windows XP.

The virtual machine 'Windows XP' has terminated unexpectedly during startup with exit code 1.

Result code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
I use Virtualbox 4.3.14 r95030
on Windows 7 Home Premium x64
with ESET Smart Security Home Edition and i don't have the
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files\\Oracle\\VirtualBox\\VirtualBox.exe"="DISABLEUSERCALLBACKEXCEPTION"
registry entry. I also tried to disable eset smart security but nothing changed.
Derragen
 
Posts: 12
Joined: 30. Mar 2014, 19:43

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 47 guests