Windows 2012 + 4.3.8 Additions

Discussions related to using VirtualBox on Windows hosts.

Windows 2012 + 4.3.8 Additions

Postby Xylex » 28. Feb 2014, 20:42

I do apologize in advance if there was a post about this already. I did search couldn't find anything related to my issue.

I just installed windows 2012 to VirtualBox 4.3.8 r92456
I am attempting to install the Guest Additions and every time I try, server 2012 Suddenly restarts.
It appears to be directly after an attempt to install the video driver.

I re-downloaded the Guest Additions from the website, and it didnt make any difference.

My Host machine is an Intel i7-3820 Quad Core.
24Gbs of DDR3 1600
Running Windows 7 x64 Pro.

If you need any screen caps or further info, I can provide them.
Thanks!
Xylex
 
Posts: 4
Joined: 28. Feb 2014, 20:19

Re: Windows 2012 + 4.3.8 Additions

Postby Perryg » 28. Feb 2014, 21:20

The guests log file and perhaps any information that you can glee from the guests event viewer would help.
Perryg
Site Moderator
 
Posts: 29277
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Windows 2012 + 4.3.8 Additions

Postby Xylex » 28. Feb 2014, 22:01

Here's the error generated after logging back into windows, from a failure.
Code: Select all   Expand viewCollapse view
The computer has rebooted from a bugcheck. The bug check was 0x000000d1 (0x0000000000000114, 0x0000000000000008, 0x0000000000000000, 0xfffff80002245247). A dump was saved in C:\Windows\MEMORY.DMP Report Id: 022814-37718-01.


I have attached the log file, as its over 100KB of text.
Let me know if you need more information.
Attachments
VBox.log
Entire Log for Server 2012 VM
(105.12 KiB) Downloaded 16 times
Xylex
 
Posts: 4
Joined: 28. Feb 2014, 20:19

Re: Windows 2012 + 4.3.8 Additions

Postby Perryg » 28. Feb 2014, 23:12

00:00:01.010821 NumCPUs <integer> = 0x0000000000000008 (8)

00:00:01.788077 Logical host processors: 8 present, 8 max, 8 online, online mask: 00000000000000ff
00:00:01.788204 Physical host cores: 4

First VirtualBox uses cores ( physical cores ) and not threads ( logical processors ). If you commit all of the cores to the guest the host will not only struggle weird things can happen.
Do you see an invalid setting in the guests settings?


I also see a lot of suspend and resume in the log. are you doing this ,or is it the guest?
Perryg
Site Moderator
 
Posts: 29277
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Windows 2012 + 4.3.8 Additions

Postby Xylex » 1. Mar 2014, 00:06

You were right. I did have too many CPU cores selected.
But, it seems like its still crashing.

Would it be a good idea to simply re-install the OS and start over?

Also, I actually don't know anything about the suspend and resume.
I am letting it idle for 20-60 minutes at a time, but I am not making it sleep or standby.
Xylex
 
Posts: 4
Joined: 28. Feb 2014, 20:19

Re: Windows 2012 + 4.3.8 Additions

Postby Perryg » 1. Mar 2014, 00:16

You may want to look at the power management section of the guest. Usually it is not a good idea to use much more that the suspend video on a virtual guest
As whether on not you need to reinstall, that would be up to you.

Me I would find out why, but I also love a challenge. What I do know is the error code could be anything from a defective HD to a USB issue.

You could try to disable the usb2 in the guest and see what happens.

Also a corrupt GA install could cause this. Try to boot into safe mode and remove the guest additions and see if everything works. If so then you can always try to install them again, hopefully fixing your issue.
Perryg
Site Moderator
 
Posts: 29277
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Windows 2012 + 4.3.8 Additions

Postby Xylex » 1. Mar 2014, 01:57

Alright. I removed the USB controller, to no avail. I could not locate any trace of the GA files. It looks like it was crashing windows before it could finish.

I booted into safe mode and installed the GA successfully. Unfortunately, Windows no longer boots.
I returned to safe mode and uninstalled them. I do not know what steps to take from here at this point.
Xylex
 
Posts: 4
Joined: 28. Feb 2014, 20:19

Re: Windows 2012 + 4.3.8 Additions

Postby Perryg » 1. Mar 2014, 02:02

Does it work without the guest additions?
Perryg
Site Moderator
 
Posts: 29277
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Windows 2012 + 4.3.8 Additions

Postby cerjzc » 1. Mar 2014, 06:54

Just wanted to reply to this thread that I saw the exact same problem when I tried to upgrade from 4.3.6 to 4.3.8 on Windows 2012 server standard. It would boot fine until I installed the additions then it would crash right away and start trying to reboot and crash again and again. I didn't have time to troubleshoot any further yet so I had to reinstall 4.3.6 and the additions for it and it is running fine again.

I will give it another try when I have a chance and grab the logs from it.

Jeff
cerjzc
 
Posts: 11
Joined: 19. Oct 2013, 04:36

Re: Windows 2012 + 4.3.8 Additions

Postby jerome.raffalli » 1. Mar 2014, 09:43

Hello,
I have the same problem too. My Windows 2012 guest can't start anymore since I installed 4.3.8 additions. It crashed just after the step where we are asked to confirm the installation of the system peripheral driver.

Jérôme
jerome.raffalli
 
Posts: 2
Joined: 1. Mar 2014, 09:38

Re: Windows 2012 + 4.3.8 Additions

Postby echristopherson » 4. Mar 2014, 03:53

I get the same sort of thing when I try to install the 4.3.8 Additions in Windows 8.1 Pro Version 6.3 (Build 9600), 32-bit on a 64-bit Mac OS X 10.9 host.

I've just gotten it twice; here are the entries from the Windows Event Viewer:

Code: Select all   Expand viewCollapse view
The computer has rebooted from a bugcheck.  The bugcheck was: 0x000000d1 (0x00000114, 0x00000006, 0x00000000, 0x8e62f696). A dump was saved in: C:\WINDOWS\MEMORY.DMP. Report Id: 030314-8671-01.


Code: Select all   Expand viewCollapse view
The computer has rebooted from a bugcheck.  The bugcheck was: 0x000000d1 (0x00000114, 0x00000006, 0x00000000, 0x8e668696). A dump was saved in: C:\WINDOWS\MEMORY.DMP. Report Id: 030314-21000-01.


Additional details:
1. Both times I tried upgrading Additions, the VM crash happened when the installer tried upgrading the WDDM(?) video drivers. The screen changed video modes a few times in rapid succession when that happened; I almost think for a moment there my window decorations looked like Windows XP ones, but everything happened so quickly I'm not sure. The virtual screen went black right after those changes, and in a few seconds I got the VirtualBox boot screen.
2. After the first time, I took Windows's advice and restored the system to a previous state (within the VM; not through VB snapshots).
3. The second time, when the video mode changed I also got a repetitive sound happening. I believe it was probably Windows sounding an alert, with the VM's audio hardware choking on it and repeating a short snippet of it over and over.
4. I restored the system within the VM a second time.
5. Now I notice that my Windows volume icon in the systray shows a white X in red circle badge. When I hover over it, a tooltip says "No Audio Output Device is installed." Clicking it brings up a wizard that tries and fails detect problems with the audio. Upon rebooting the VM, the audio is fine.

My VBox.log is attached.
Attachments
VBox.log
(64.57 KiB) Downloaded 11 times
echristopherson
 
Posts: 1
Joined: 4. Mar 2014, 03:38

Re: Windows 2012 + 4.3.8 Additions

Postby jkoreska » 13. Mar 2014, 16:52

I would like to report a similar issue with Guest Additions 4.3.8 on Windows 8.1 and 2012 R2 guests, host is Windows 8.1 x64.

My 8.1 guest was running great until I upgraded VBox and installed GA 4.3.8 . Now it no longer boots. I also created 2 new VMs, an 8.1 and a 2012 R2 - both show the same symptoms.

In all instances, during the installation of GA (I think, the video driver) the screen went black with a choppy green box and the VM froze. Upon reboot, the normal Windows spinner shows when booting and then the display freezes. In VBox Manager, the guest preview shows shifting, garbled video after the freeze. The guest is completely unresponsive and my CPU revs up after this until I kill it.

I tried booting in various safe modes, running system restore, etc. but I cannot boot to desktop or uninstall GA. The new guests are functional (but limited) before installing GA.

I've reverted to 4.3.6 and am running new VM guests until the issue is resolved and I can (hopefully) recover the one I installed GA 4.3.8 on.

*edit: host is Windows 8.1 x64
Attachments
VBox.log
(105.35 KiB) Downloaded 15 times
jkoreska
 
Posts: 1
Joined: 13. Mar 2014, 16:37

Re: Windows 2012 + 4.3.8 Additions

Postby Legorol » 25. Mar 2014, 02:31

I believe this is the same problem as discussed in this thread: https://forums.virtualbox.org/viewtopic.php?f=2&t=60333

Here is the bug report already submitted on this issue: https://www.virtualbox.org/ticket/12745
Legorol
 
Posts: 55
Joined: 11. Mar 2014, 21:40

Re: Windows 2012 + 4.3.8 Additions

Postby jerome.raffalli » 27. Mar 2014, 21:51

I confirm the problem is solved with the new release 4.3.10. After installing the new gest additions, I disabled 3D and Windows didn't crashed.
Many thanks to support team !!

Jérôme
jerome.raffalli
 
Posts: 2
Joined: 1. Mar 2014, 09:38


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 41 guests