Error after upgrade:VT-x is not available. (VERR_VMX_NO_VMX)

Discussions related to using VirtualBox on Windows hosts.

Error after upgrade:VT-x is not available. (VERR_VMX_NO_VMX)

Postby yellowduck » 30. Nov 2013, 14:48

VB 4.3.4 on Win7 64bit

I installed the 4.3.4 update this morning and now get an error when opening any guests. I have been running VB for many years on the same computer and the same guests, no problems until I installed the update.
Guests are WinXP, Win7, Win2008. Guest additions are installed on the guests.

Error message:
Failed to open a session for the virtual machine Windows XP.
VT-x is not available. (VERR_VMX_NO_VMX).
Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Attached is the VM log file.
Attachments
Windows XP-2013-11-30-07-26-58.zip
(4.92 KiB) Downloaded 949 times
yellowduck
 
Posts: 4
Joined: 30. Nov 2013, 14:41

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby noteirak » 30. Nov 2013, 19:20

Make sure Virtualization is enabled in your BIOS and that nothing uses it already - Hyper-V is a very common issue.
Hyperbox - Virtual Infrastructure Manager - http://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 4546
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby yellowduck » 30. Nov 2013, 19:35

BIOS does not have VT-x. Note that I have been running VB on this computer for about 5 years without problems - yes the same computer. No Hyper-V installed either.
This problem started after the latest VB update 4.3.4.
yellowduck
 
Posts: 4
Joined: 30. Nov 2013, 14:41

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby yellowduck » 30. Nov 2013, 19:36

Question: does VB 4.3.4 run on computers that does not have VT-x?
yellowduck
 
Posts: 4
Joined: 30. Nov 2013, 14:41

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby mpack » 30. Nov 2013, 19:47

The log says that you have VT-x enabled in this VM recipe, hence the VM can't run without VT-x and it gives an error saying so. AFAIK this has not changed recently.

VBox.log wrote:00:00:01.477592 Guest OS type: 'WindowsXP'
00:00:01.480662 fHMForced=true - 64-bit guest


64bit guests require VT-x. I suspect you selected the "XP-64bit" template when you installed the OS, or you tried that "longmode" command line tweak that's been discussed recently.

Make sure you don't have a 64bit template selected in <settings>|General|Basic, and turn off VT-x in <settings>|System|Acceleration.
mpack
Site Moderator
 
Posts: 17770
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby Perryg » 30. Nov 2013, 20:07

I believe this type of problem was added when they tightened/changed the way VT-x is used. You should see long mode off in the settings ( VBoxManage showvminfo vmname )
You can test this by doing the following:
Code: Select all   Expand viewCollapse view
VBoxManage modifyvm <vmname> --longmode off

And see if it will boot. Remember the guest needs to be off for this to work.
Perryg
Site Moderator
 
Posts: 29579
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby yellowduck » 30. Nov 2013, 23:22

Thank you perryg, setting longmode off did the trick.

These VMs were setup many years ago on a 32 bit computer. I guess it's just old stuff catching up with new software and somewhere something was forgotten.
yellowduck
 
Posts: 4
Joined: 30. Nov 2013, 14:41

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby Perryg » 1. Dec 2013, 01:33

Its a nasty little bug since you can not disable VT-x on a system that doesn't have it ( setting grayed out ) from the GUI. Easy to fix when you know what to do though.
I thought they fixed this in 4.3.4 but if you tried to use the guests with 4.3.0, or 4.3.2, it is already set wrong in the settings.
Perryg
Site Moderator
 
Posts: 29579
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby sergiomb » 3. Dec 2013, 19:13

Perryg wrote:I believe this type of problem was added when they tightened/changed the way VT-x is used. You should see long mode off in the settings ( VBoxManage showvminfo vmname )
You can test this by doing the following:
Code: Select all   Expand viewCollapse view
VBoxManage modifyvm <vmname> --longmode off

And see if it will boot. Remember the guest needs to be off for this to work.


Code: Select all   Expand viewCollapse view
VBoxManage modifyvm <vmname> --longmode off

Also worked here , my Box is Linux , and yes, I already know, this CPU doesn't have VT-x , so it is a 64-bits machine, but all vms just work in 32 bits . this issue happens on all vms: Linux , WindowsXP and Windows 7.

Thanks,
sergiomb
 
Posts: 6
Joined: 1. Dec 2011, 03:11
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: windows Fedora rawhide

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby jakeochs » 3. Dec 2013, 21:53

Also, still broken w/vbox 4.3.4
jakeochs
 
Posts: 1
Joined: 29. Nov 2013, 19:18

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby Perryg » 3. Dec 2013, 21:55

jakeochs wrote:Also, still broken w/vbox 4.3.4

From the hosts terminal/command window type VBoxManage showvminfo <VM Name> --details and post here. Replace <VM Name> with the actual name of the VM. Use " " if the name has a space in it.

Note if the host is Windows you need to be in the directory that has VBoxManage.exe for the command to work.
Perryg
Site Moderator
 
Posts: 29579
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby 21grams » 4. Dec 2013, 07:48

Exactly same problem here. Unfortunately, I can't use the workaround like "VBoxManage modifyvm <vmname> --longmode off" to avoid it because last time I saved the machine but shutdown it, so the property can't be changed in this way.
I've got stuck here for a while, I truly hope your guys can fix this severe bug ASAP.
21grams
 
Posts: 1
Joined: 4. Dec 2013, 07:40

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby OldBloke » 4. Dec 2013, 08:13

I am having a similar problem since the last upgrade. I'm running a Win8.1 host on an old 64bit processor that doesn't have virtualization.

I tried the modifyvm workaround but got the following error message:
VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execu
tion failed (extended info not available)
VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or
failed to start.


showvminfo also produces a similar error.

Oddly, I was able to start a machine using a vhd originally created in VMWare. None of my VBox machines now work, they all give the VT-x error.

OB
OldBloke
 
Posts: 2
Joined: 4. Dec 2013, 08:09

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby alsov » 4. Dec 2013, 08:30

Try to change setting HardwareVirtEx in your virtual machine config file (<machine nme>.vbox).

It's a CPU section/ Looks like this

<Hardware version="2">
<CPU count="1" hotplug="false">
<HardwareVirtEx enabled="false"/>
<HardwareVirtExNestedPaging enabled="true"/>
<HardwareVirtExVPID enabled="true"/>
<HardwareVirtExUX enabled="true"/>
<PAE enabled="false"/>
<HardwareVirtExLargePages enabled="true"/>
<HardwareVirtForce enabled="false"/>
</CPU>
alsov
 
Posts: 1
Joined: 4. Dec 2013, 08:27

Re: Error after upgrade:VT-x is not available. (VERR_VMX_NO_

Postby OldBloke » 4. Dec 2013, 09:11

Try to change setting HardwareVirtEx in your virtual machine config file (<machine nme>.vbox).


Thanks alsov.

Do I only need to set HardwareVirtEx to false or should I set all the VirtEx* settings to false?

OB

Edit: It helps to experiment. :-) I only needed to change the first one, HardwareVirtEx to false.

OB
OldBloke
 
Posts: 2
Joined: 4. Dec 2013, 08:09

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: pawelfaron87@wp.pl and 75 guests