4.3 still breaks ALL USB windows host again

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3 still breaks ALL USB windows host again

Postby Ice » 3. Apr 2015, 10:09

Any news on the new version 4.3.26? I'd like to update but I'm a little anxious since I had to go back to 4.2 from any 4.3.x I tried so far... :(
Ice
 
Posts: 4
Joined: 6. Jul 2014, 10:55

Re: 4.3 still breaks ALL USB windows host again

Postby blakejohnson86 » 23. May 2015, 21:53

So the people that are having this issue, do you have Intel USB chipsets? I think some of you may be suffering from the same problem that plagues Android developers on Windows 8.x as well. I was having the same problem described here with the host USB ports not functioning until I remembered that Windows 8.x uses the Microsoft USB 3.0 USB stack, which is not ideal. I replaced my USB 3.0 drivers with the modded Intel ones, and all is good.

Standard Disclaimer: Just because it works for me, that does not mean it will work for you. This is purely for informational purposes. If you choose to proceed, you do so at your own risk.

Guide: ht tp : / / plugable . com /2012/12/01/windows-8-and-intel-usb-3-0-host-controllers (I can't post URLs, so you'll have to improvise.)

But to sum it up...
  1. Download official Intel USB 3.0 drivers for Windows 7
  2. Download modded INI files from website above.
  3. Extract Intel drivers (7-zip works well for this.)
  4. Replace the Windows 7 ini files with the the modded Windows 8 ini files.
  5. Reboot into Driver Enforcement Disabled mode.
  6. Replace drivers in Control Panel (PLEASE NOTE THAT THIS WORKS BEST WITH A PS/2 KEYBOARD OR OVER A REMOTE SESSION. USB MAY BE TEMPORARILY DISABLED. )
  7. Reboot & Rejoice

If there are any Windows 7 users having this same problem, make sure you have the ideal drivers installed for your system.

TL;DR: This problem may not be entirely the fault of VirtualBox, but rather incomplete Microsoft drivers.
blakejohnson86
 
Posts: 1
Joined: 23. May 2015, 21:33
Location: Plymouth, MN
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: 4.3 still breaks ALL USB windows host again

Postby willemd » 3. Dec 2015, 16:47

I have the same problem with 5.0.10. Using host USB devices doesn't work, saying it's 'busy'. Is that normal?
I'm also on a machine with USB3, not Intel but AMD.

It worked with 4.2.16, but unfortunately I can no longer use that version under Windows 10 1511 (the latest Windows Update), because it breaks the host only network facility.



Using the 4.2.16 USB drivers on 5.0 does not appear to work (and doesn't seem like the best solution anyway).

Any ideas?
willemd
 
Posts: 2
Joined: 3. Dec 2015, 16:42

Re: 4.3 still breaks ALL USB windows host again

Postby CaptainBeyond » 4. Jan 2016, 19:41

Hello Folks,
I'm using XPSp3 as guest on an Win7 64Bit host. My Problem: My Canon FB630U Scanner ist busy... since VirtualBox 4.2.16.
Some Mails ago (Page 4) Frank Mehnert posted a Testversion 4.3.13 which I was lucky to get. This Version fixed my Problem. Frank talks about reverting
a Change they did in 4.2.18 ...
Frank, if you are still reading here, this change seems to cause this Problem by many Users. Would it be very difficult to fix it in the actual version...
It would be very sad, and it would be bad for nature if I and some more guys have to throw away their old scanners and other devices because of this "error"
BTW Happy New Year to all ...
CaptainBeyond
 
Posts: 1
Joined: 4. Jan 2016, 19:28

Re: 4.3 still breaks ALL USB windows host again

Postby timur » 28. Jan 2016, 10:14

I guess this is the same problem as with this solution https://forums.virtualbox.org/viewtopic ... 04#p176270 that worked for me in VB 5.0.14.
With what I added in https://forums.virtualbox.org/viewtopic ... 15#p353425.
Except it's not explained what exactly it does, and whose bug is it.
timur
 
Posts: 12
Joined: 28. Aug 2014, 14:39

Re: 4.3 still breaks ALL USB windows host again

Postby zackerysobin » 12. Jul 2016, 17:00

I've been using 4.2.16 for a long time now.

Recently I've tried 5.0.24 but USB passthrough still seems to be broke for me. My company forces me to have Mcafee. I wonder if this is related to my problem. I've tried various filters, rebooting, disabling/enabling USB 3.0 in bios, installing the usb inf file, and other workarounds.

The only thing that seems to work is 4.2.16. I wish the developers could find out why all newer version are broke on my computer.
zackerysobin
 
Posts: 1
Joined: 11. Jul 2016, 22:42

Re: 4.3 still breaks ALL USB windows host again

Postby socratis » 12. Jul 2016, 17:16

zackerysobin wrote: I wish the developers could find out why all newer version are broke on my computer.

Unless you send them your computer, no, it's not going to happen. Furthermore, I don't think you have a problem with USB, otherwise you wouldn't mention McAfee. And to top it off, the title of this thread has to do with VirtualBox 4.3 and nothing to do with 5.0.24.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Previous

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 34 guests