Page 3 of 6

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 6. Feb 2014, 13:33
by FıratBilir
klaus wrote:Sorry, you apparently missed that I was asking for the USB controller details. Complete failures are generally not related to specific devices, and in VirtualBox 4.2.18 we did make changes to the USB code on Windows, as anyone can see who looks at the ChangeLog. This change has been tested with the controllers and drivers (yes, the silly Windows USB controller driver design requires that the VirtualBox USB support uses different locations for different controller drivers), and many users confirmed that this works. Not saying you must be wrong, we just need to get the necessary information...

The easiest way to find the USB controller in question, use the device manager, and in the "View" menu select "Devices by connection", and then start unfolding "ACPI based PC", "Microsoft ACPI-Compliant System", "PCI bus", and from there each USB controller until you find where your devices live. Then open the properties of the controller (not the device), get the driver details. Then open the properties of a USB device, go to the "Details" tab, and get the value of the "Physical Device Object name".

With this information we should at least understand a lot better what the situation is, and if it should work or not.


The structure in device manager:

ACPI x86 based PC
----Microsoft ACPI-Compliant System
--------PCI bus
------------Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D
----------------USB Root Hub
--------------------Generic USB Hub
------------------------OMNIKEY 3x21
------------------------OMNIKEY 3x21
------------------------USB Input Device
----------------------------HID Keyboard Device
------------------------USB Input Device
----------------------------HID compliant mouse

I opened the Properties - Driver tab of "Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D"
Driver Provider: Intel
Driver Date: 16.09.2010
Driver Version: 9.2.0.1013
Driver Signer: Microsoft Windows Hardware Compatibility Publisher
In Driver Details:
Driver Files: C:\Windows\system32\drivers\usbehci.sys, C:\Windows\system32\drivers\usbhub.sys, C:\Windows\system32\drivers\usbport.sys
Provider: Microsoft Corporation
File Version: 6.1.7601.17586 (win7sp1_gdr.110324-1501)

I opened the properties of OMNIKEY 3x21 smartcard readers, in Details tab Physical Device Object names are \Device\USBPDO-6 and \Device\USBPDO-7.
Then I opened the properties of HID Keyboard Device, in Details tab Physical Device Object name is \Device\00000088

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 7. Feb 2014, 03:50
by wayne.zhang
The easiest way to find the USB controller in question, use the device manager, and in the "View" menu select "Devices by connection", and then start unfolding "ACPI based PC", "Microsoft ACPI-Compliant System", "PCI bus", and from there each USB controller until you find where your devices live. Then open the properties of the controller (not the device), get the driver details. Then open the properties of a USB device, go to the "Details" tab, and get the value of the "Physical Device Object name".


This is the USB device controller that failed on my Machine (but now it works on 4.3.6 with 4.2.16 USB monitor driver):
<General TAB> USB Mass Storage Device
Device Type: Universal Serial Bus Controllers
Manufacture: Compatible USB storage device
Location: Port_#0001.Humb_#00004

<Driver TAB>
Driver Provider: Microsoft
Driver Date: 21/06/2006
Driver Version: 6.1.7601.17514

Dirver Details > Driver files: c:\windows\system32\hdlpdbk.sys, USBSTOR.SYS

Note: hdlpdbk.sys is what somebody suggested that it should be delete from registry key UpperFilters in a controller set to workaround this issue.


Pysical Device Object name of my USB is: \Device\000000c1 (Note: it works now with 4.2.16 USB monitor, don't know if there is any impact).

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 19. Feb 2014, 09:11
by tcouey
I have the problem too. Win 7 x64. v4.3.6 r91406.

The error I get in VirtualBox is:

Failed to attach the USB device Kingston DataTraveler 112 [0100] to the virtual machine Ubuntu.

USB device 'Kingston DataTraveler 112' with UUID {fbad04a8-bcf2-4cc0-b2a9-5f3678dd2b30} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

----

The "Physical Device Object name" is \Device\000000d6 but no devices will work. This just happens to be the most recent that I've tried.

---

UPDATE: I just installed the same version of VirtualBox on my Win 7 x64 laptop and it works fine. It's clearly hardware dependent problem.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 21. Feb 2014, 06:53
by Scott Harman
I was having a very similar issue, and it looks like VirtualBox only addresses the first two root hubs
Either my USB device would crash in the manner described, or it would report that it mounted, but simply not appear.

I moved my USB3 thumbdrive to a USB2 controller, and voila, works perfectly.
I suspect at least part of this issue is minimising the number of hubs that are reported to the guest operating system.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 23. Feb 2014, 05:01
by tcouey
Yeah, I've tried all of the USB ports on the computer. I've also tried uninstalling and re-installing VirtualBox. No go. Everything shows "Busy" or "Captured" (without a check mark) and you get the same error if you click on any USB devices.

This sucks. I really need this to work right now.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 24. Feb 2014, 22:52
by jet123
Has anyone else tried wayne.zhang's suggestion? Seems reasonable to me.

wayne.zhang wrote:I have the same issue on Windows 7 Enterprise 64bit. I have tried all of 4.3 releases and 4.2.18, none of them works. But I have confirmed 4.2.16 works.

I found a work around to make it works on 4.3.6. (NAYASIS's method don't work for me as I can't delete that registry key - it will be back again. A group policy? I am on a workstation of my office).

1. Install VirtualBox 4.2.16 (we know this is the latest release that works);
2. Backup VBox drivers in some where (c:\programs files\Oracle\VirtualBox\drivers\USB), for example, c:\program files\Oracle\VirtualBox-4.2.16-USB;
3. Uninstall VirtualBox 4.2.16;
4. Install latest VirtualBox 4.3 release 4.3.6;
5. Go to the backup USB driver folder (e.g c:\program files\Oracle\VirtualBox-4.2.16-USB);
6. Go to filter folder;
7. Right click file VBoxUSBMon.inf;
8. In the popup menu, click 'Install';
9. Ignore the warning message (something like a lasted version has been installed);
10. Reboot your Windows system;
11. USB should work for you VBox now.

It seems this is regression on VBox USB monitor filter.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 26. Feb 2014, 12:08
by tcouey
Yeah... I tried installing 4.2.16 on a fresh install of Win 7 x64 Ultimate and it doesn't work either. Everything either shows "Busy" or "Captured" (with no check). *sigh*

UPDATE: I just upgraded that 4.2.16 installation to 4.2.8 (which I just downloaded) and I think... IT'S WORKING! I need to do a little more testing, but I successfully mounted my flash drive!

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 5. Mar 2014, 16:09
by CLS
Wayne.zhang's solution does the trick!
USB works with old 4.2.16 driver.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 5. Mar 2014, 16:13
by mpack
If you mix and match VirtualBox executable files from different versions then you're stoking up trouble for the future, and you'll basically get no support here.

A better course of action would be to raise a bugtracker ticket and mention this experiment. It may give the devs a clue.

Also, this thread's title is worryingly vague - i.e. there is no VirtualBox version called 4.3.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 6. Mar 2014, 17:00
by jet123
mpack wrote:If you mix and match VirtualBox executable files from different versions then you're stoking up trouble for the future, and you'll basically get no support here.

A better course of action would be to raise a bugtracker ticket and mention this experiment. It may give the devs a clue.

Also, this thread's title is worryingly vague - i.e. there is no VirtualBox version called 4.3.


This is why I have been hesitant in doing that. Although I said the suggestion seemed reasonable, the more I thought about it, the more what you stated started to concern me.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 7. Mar 2014, 03:47
by wayne.zhang
Is there a bug reported for this issue?

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 7. Mar 2014, 04:02
by wayne.zhang
This is a similar one:

https://www.virtualbox.org/ticket/11251

Don't know if it is exactly same as it mentioned in the comment that OSX has this issue too. Also, it mentioned it is a USB 3 related issue?

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 12. Mar 2014, 23:59
by jet123
tcouey wrote:Yeah... I tried installing 4.2.16 on a fresh install of Win 7 x64 Ultimate and it doesn't work either. Everything either shows "Busy" or "Captured" (with no check). *sigh*

UPDATE: I just upgraded that 4.2.16 installation to 4.2.8 (which I just downloaded) and I think... IT'S WORKING! I need to do a little more testing, but I successfully mounted my flash drive!

So, I wonder if this issue was fixed in 4.3.6. Is USB still working for you with this version? I may give it a try when I get the time.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 14. Mar 2014, 09:46
by wayne.zhang
4.3.8 is same as as 4.3.6 - it doesn't work on my machine, and 4.2.16 driver works.

Re: 4.3 still breaks ALL USB windows host again

PostPosted: 14. Mar 2014, 11:31
by FıratBilir
wayne.zhang wrote:4.3.8 is same as as 4.3.6 - it doesn't work on my machine, and 4.2.16 driver works.


Same for me too, I'm still having the same error in 4.3.8 version. I cannot understand why this problem is not solved yet. Every kind of logs or information have been sent to the developers and more can be send if requested. Also there is a version (4.2.16) which was working properly and after this version, the USB error began. I think the cause of the problem must be the modifications done on this version. I hope the developers can solve the problem quickly.