4.3 still breaks ALL USB windows host again

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3 still breaks ALL USB windows host again

Postby hubi » 22. Dec 2013, 12:52

Yes, I have the same Problem in 4.3.6. It would be good, to solve this Problem, so we can use the vbox completely
hubi
 
Posts: 35
Joined: 14. Sep 2013, 10:30

Re: 4.3 still breaks ALL USB windows host again

Postby socratis » 22. Dec 2013, 14:02

hubi wrote:Yes, I have the same Problem in 4.3.6. It would be good, to solve this Problem, so we can use the vbox completely

Yes, you and a dozen others. But NONE has followed "noteirak"'s advice:
noteirak wrote:If you have a reproducible scenario with a VM log to back up your claims, you can still post on the tickets you mention to provide further evidence that this is not yet fixed.

Please read the following: Minimum information needed for assistance.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: 4.3 still breaks ALL USB windows host again

Postby FıratBilir » 25. Dec 2013, 13:52

socratis wrote:
hubi wrote:Yes, I have the same Problem in 4.3.6. It would be good, to solve this Problem, so we can use the vbox completely

Yes, you and a dozen others. But NONE has followed "noteirak"'s advice:
noteirak wrote:If you have a reproducible scenario with a VM log to back up your claims, you can still post on the tickets you mention to provide further evidence that this is not yet fixed.

Please read the following: Minimum information needed for assistance.


I have sent some information and VBoxSVC.log which contains error messages in my previous post but hadn't send guest log. Now I send all information and logs described in Minimum information needed for assistance. If I am asked, I can provide more information.

Host ==> OS: Windows 7 Enterprise SP1 32 bit - Memory: 4 GB
Guest ==> OS: Windows 7 Enterprise SP1 32 bit - Memory: 1 GB
VirtualBox ==> 4.3.6r91406 - Guest Additions upgraded to same version and installed in the guest.
USB Devices ==> Omnikey 3121 SmartCard Reader & Lenovo USB Keyboard & Logitech USB Mouse

When I try to attach the smart card reader or other USB devices to guest OS, the host is unmounting the USB device, but the guest is not mounting it. When I try to attach the same device again, the guest OS container is freezing completely and the following error message (also in the attachment) appears in VirtualBox log file (C:\Users\User\.VirtualBox\VBoxSVC.log).
Attachments
VBoxSVCLog.zip
(1.63 KiB) Downloaded 23 times
GuestLog.zip
(15.16 KiB) Downloaded 28 times
FıratBilir
 
Posts: 11
Joined: 25. Oct 2013, 16:16

Re: 4.3 still breaks ALL USB windows host again

Postby theAlse » 21. Jan 2014, 08:57

What is the latest status regarding this issue?
Has it been recognized as a bug?
theAlse
 
Posts: 2
Joined: 17. Dec 2013, 15:58

Re: 4.3 still breaks ALL USB windows host again

Postby Zygmunc » 21. Jan 2014, 18:41

Hm. It's weird that You guys have this problem. I tested 4.3.6 and USB Host to Guest worked perfectly. There wasn't any issue for guest machine to catch the device from host. I even tried with success to catch the USB mouse and USB keyboard to guest.
I think, that after You updated VBOX, You should check if VBoxUSB.sys driver version is correct. It is in drivers folder of host.
It sometimes is not reinstalled automatically to Your version of VBOX. It can be a source of problem.

Cause I can't use VB version from 4.1.30 to the latest because It crashes constantly on never machine with intel i3 and it shows enormous slowness and slugishness on Core2Duo (separate thread in this branch) I returned to 4.0.22 and due to VBoxUSB inproper driver I suffered no USB detection on guest at all and famous "USB device is busy" error.
Zygmunc
 
Posts: 5
Joined: 27. Aug 2011, 02:26
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP

Re: 4.3 still breaks ALL USB windows host again

Postby Rick Murtagh » 25. Jan 2014, 03:13

The problem still exists in 4.3.6 r91406

Failed to attach the USB device Proximiant EZ-USB FX2 USB DEVICE to the virtual machine Win XP SP3 Autoupdate.

USB device 'Proximiant EZ-USB FX2 USB DEVICE' with UUID {12ca4f06-3f58-4e19-948d-838c378dd307} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}
Attachments
errordlg.png
errordlg.png (39.44 KiB) Viewed 5498 times
vboxusb.sys.png
vboxusb.sys.png (31.69 KiB) Viewed 5498 times
Win XP SP3 Autoupdate-2014-01-24-17-03-00.log
(83.36 KiB) Downloaded 23 times
Rick Murtagh
 
Posts: 1
Joined: 25. Jan 2014, 03:10

Re: 4.3 still breaks ALL USB windows host again

Postby mpack » 25. Jan 2014, 13:57

mpack
Site Moderator
 
Posts: 31810
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3 still breaks ALL USB windows host again

Postby Manos » 25. Jan 2014, 23:29

What is this? After I upgrade it to 4.3.6 I can not moud printer ank hasp key. Every think worked perfect before. I down grade it to 4.0 but the same problem again. web cam and memoty stic works ok but were not mounted by Devices-USB Devices. Extension Pack and guest additions is installed.
Manos
 
Posts: 4
Joined: 25. Jan 2014, 23:14

Re: 4.3 still breaks ALL USB windows host again

Postby Manos » 25. Jan 2014, 23:41

Failed to attach the USB device Hewlett-Packard DeskJet 970C [0100] to the virtual machine XP SP1.

USB device 'Hewlett-Packard DeskJet 970C' with UUID {954ea2df-ad52-4919-b207-b57bfb3c9df3} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

I guess it is the same problem and I have Windows 7 ultimate 64 host and windows xp guest but how was it working before???
Manos
 
Posts: 4
Joined: 25. Jan 2014, 23:14

Re: 4.3 still breaks ALL USB windows host again

Postby Manos » 28. Jan 2014, 22:52

I tryed this By "nayasis" and it worked for me
https://forums.virtualbox.org/viewtopic ... 04#p176270
THANK YOU NAYASIS
Manos
 
Posts: 4
Joined: 25. Jan 2014, 23:14

Re: 4.3 still breaks ALL USB windows host again

Postby FıratBilir » 4. Feb 2014, 09:11

theAlse wrote:What is the latest status regarding this issue?
Has it been recognized as a bug?


What is the latest status regarding this issue? Has it been recognized as a bug? None of the administrators had answered theAlse's question. I wonder the same thing.
FıratBilir
 
Posts: 11
Joined: 25. Oct 2013, 16:16

Re: 4.3 still breaks ALL USB windows host again

Postby klaus » 5. Feb 2014, 15:35

Can you provide detailed information what USB controller your system has (using device manager, the one to which the interesting USB device is attached), and which driver is installed for it? There must be some pattern behind the "doesn't work at all" reports, but as we're not seeing such trouble on our systems (various generation Intel/AMD systems, all of them with USB2/3 built into the chipset, no 3rd party controllers) this is far from affecting all users. Oh, and don't hesitate to mention anti-virus software and the like if it is installed. You can't imagine how deeply they install some of their components, which can lead to interesting misbehavior.
klaus
Oracle Corporation
 
Posts: 753
Joined: 10. May 2007, 14:57

Re: 4.3 still breaks ALL USB windows host again

Postby wayne.zhang » 6. Feb 2014, 07:55

I have the same issue on Windows 7 Enterprise 64bit. I have tried all of 4.3 releases and 4.2.18, none of them works. But I have confirmed 4.2.16 works.

I found a work around to make it works on 4.3.6. (NAYASIS's method don't work for me as I can't delete that registry key - it will be back again. A group policy? I am on a workstation of my office).

1. Install VirtualBox 4.2.16 (we know this is the latest release that works);
2. Backup VBox drivers in some where (c:\programs files\Oracle\VirtualBox\drivers\USB), for example, c:\program files\Oracle\VirtualBox-4.2.16-USB;
3. Uninstall VirtualBox 4.2.16;
4. Install latest VirtualBox 4.3 release 4.3.6;
5. Go to the backup USB driver folder (e.g c:\program files\Oracle\VirtualBox-4.2.16-USB);
6. Go to filter folder;
7. Right click file VBoxUSBMon.inf;
8. In the popup menu, click 'Install';
9. Ignore the warning message (something like a lasted version has been installed);
10. Reboot your Windows system;
11. USB should work for you VBox now.

It seems this is regression on VBox USB monitor filter.
wayne.zhang
 
Posts: 10
Joined: 6. May 2008, 10:48

Re: 4.3 still breaks ALL USB windows host again

Postby FıratBilir » 6. Feb 2014, 09:37

klaus wrote:Can you provide detailed information what USB controller your system has (using device manager, the one to which the interesting USB device is attached), and which driver is installed for it? There must be some pattern behind the "doesn't work at all" reports, but as we're not seeing such trouble on our systems (various generation Intel/AMD systems, all of them with USB2/3 built into the chipset, no 3rd party controllers) this is far from affecting all users. Oh, and don't hesitate to mention anti-virus software and the like if it is installed. You can't imagine how deeply they install some of their components, which can lead to interesting misbehavior.


Anti-virus softwares in my Windows 7 Enterprise SP1 32 bit host and guest computers are both McAfee VirusScan Enterprise + AntiSpyware Enterprise 8.8 Patch 1. However, I made the tests again this morning and before the test I disabled all the components of McAfee. (Access Protection, Buffer Overflow Protection, On-Delivery Email Scanner and On-Access Scanner) Nothing changed in the tests, guest is still freezing when I try to attach a USB device.

I made the tests again with my smartcard reader (seen as OMNIKEY 3x21 in host's device manager and OMNIKEY AG Smart Card Reader USB [0302] in VirtualBox - Guest Window - USB Devices menu) and with my keyboard (seen as HID Keyboard Device in host's device manager and LITE-ON Technology USB NetVista Full Width Keyboard. [0109] in VirtualBox - Guest Window - USB Devices menu) I didn't install any special driver for both of the devices in host Win7, the system automatically installed the drivers.

In Device Manager - OMNIKEY 3x21 - Properties - Driver menu:
Driver Provider: HID Global
Driver Date: 06.09.2011
Driver Version: 1.2.6.5
Driver Signer: Microsoft Windows Hardware Compatibility Publisher
In Driver Details, driver files: C:\Windows\system32\drivers\cxbu0wdm.sys and C:\Windows\system32\drivers\scfilter.sys

In Device Manager - HID Keyboard Device - Properties - Driver menu:
Driver Provider: Microsoft
Driver Date: 21.06.2006
Driver Version: 6.1.7601.17514
Driver Signer: Microsoft Windows
In Driver Details, driver files: C:\Windows\system32\drivers\kbdclass.sys, C:\Windows\system32\drivers\kbdhid.sys and C:\Windows\system32\drivers\VMkbd.sys (there's a sertificate sign before the first two but no sign before the last sys file)


I have also sent VBoxSVCLog.zip and GuestLog.zip files before. The problem firstly occured in 4.2.18 version, 4.2.16 version was working properly. Something you have done between 4.2.16 and 4.218 is causing this problem. This problem may be far from affecting all users but it is really affecting some users including me very badly. Because of this problem, I am connecting with remote desktop to my own guest computer to be able to attach my smartcard reader but the computer really slows down using this method and makes me furious. I hope you can find the cause of the problem and solve it really quickly.
FıratBilir
 
Posts: 11
Joined: 25. Oct 2013, 16:16

Re: 4.3 still breaks ALL USB windows host again

Postby klaus » 6. Feb 2014, 12:09

Sorry, you apparently missed that I was asking for the USB controller details. Complete failures are generally not related to specific devices, and in VirtualBox 4.2.18 we did make changes to the USB code on Windows, as anyone can see who looks at the ChangeLog. This change has been tested with the controllers and drivers (yes, the silly Windows USB controller driver design requires that the VirtualBox USB support uses different locations for different controller drivers), and many users confirmed that this works. Not saying you must be wrong, we just need to get the necessary information...

The easiest way to find the USB controller in question, use the device manager, and in the "View" menu select "Devices by connection", and then start unfolding "ACPI based PC", "Microsoft ACPI-Compliant System", "PCI bus", and from there each USB controller until you find where your devices live. Then open the properties of the controller (not the device), get the driver details. Then open the properties of a USB device, go to the "Details" tab, and get the value of the "Physical Device Object name".

With this information we should at least understand a lot better what the situation is, and if it should work or not.
klaus
Oracle Corporation
 
Posts: 753
Joined: 10. May 2007, 14:57

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 37 guests