Windows 8.1 and 64-bit Linux Guest

Discussions related to using VirtualBox on Windows hosts.

Windows 8.1 and 64-bit Linux Guest

Postby Swad » 19. Oct 2013, 16:18

I installed VirtualBox 4.3.0 r89960 onto a machine I recently built (and also upgraded to Windows 8.1 Pro from 8 Pro). I hadn't tried to install VirtualBox on this particular new hardware prior to upgrading to 8.1, but it did install fine as well as the VirtualBox extensions. The hardware is an ASUS Maximus VI Hero with 16GB RAM installed and a Core i7-4770k processor. The motherboard does have virtualization enabled in the BIOS--I double checked that.

I setup an Ubuntu guest and gave it 4GB RAM and 2 CPUs. I also setup the usual stuff I have in the past with my older machine (was a Core i7-920) regarding guest system options such as VT-x, Nested Paging and PAE/NX. In spite of setting up things as I did on my old system where I could run 64-bit guests fine with more than one CPU, this one stone walls me. On attempting to boot off the 64-bit Ubuntu 13.10 desktop ISO media (I also tried 13.04 64-bit), I get this message before it gets far in the boot process at all (before any prompts for me to interact with it while it's still loading off the ISO media:

"This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU."

I don't have any other virtualization technology running on this machine (that I'm aware of) - I verified Hyper-V was not enabled as a feature in the OS, and I don't have anything from VMware or other such technology running on this. Any advice what steps to take next? I ran a program I saw recommended called SecurAble and it indicated there was hardware virtualization, though it said it can't verify if it's locked or not (said it needs a 32-bit OS or something to do this). I know the i7-4770k doesn't support the VT-d technology, but I didn't think that was necessary to run a guest like this--just VT-x. I think I have everything setup as I have done in the past with my prior system.
Swad
 
Posts: 2
Joined: 19. Oct 2013, 16:03

Re: Windows 8.1 and 64-bit Linux Guest

Postby Ramshankar » 19. Oct 2013, 16:26

Set the guest OS type to 64 bit in the GUI. VirtualBox 4.3 is more strict regarding the distinction.

Optionally, you can also use VBoxManage command to set the 64 bit type of the VM.
Code: Select all   Expand viewCollapse view
VBoxManage modifyvm <vmname> --longmode on
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: Windows 8.1 and 64-bit Linux Guest

Postby Swad » 19. Oct 2013, 16:47

Fantastic--thanks! I looked right past the 64-bit version under the general settings. For some reason I thought I had looked at that previously, but obviously not. All is running well now that I properly selected Ubuntu (64 bit). Thanks again and for the speedy response!
Swad
 
Posts: 2
Joined: 19. Oct 2013, 16:03

Re: Windows 8.1 and 64-bit Linux Guest

Postby VboxChimp » 20. Oct 2013, 17:17

Using 4.3 on Windows 8.1 the 64bit options are not listed in the version dropdown when I create a new VM. I have verified that Virtualization is enabled on my DELL XPS 15 i7 bios. This seems to be a Windows version issue as I booted into Linux Mint 15 on a different partition of the same machine and, installed VB 4.3 and can see the 64 bit options of linux in the dropdown when creating a new VM there.

I have uninstalled and reinstalled to see if these 64bit options show up in Win 8.1, but so far cannot get this to work.

I tried the vboxmanage longmode command on a new Ubuntu 13.10 VM. The command completes but I still get the error starting up the VM about x86-64 and detecting only i686.

Any other things to try?
thanks.

Update:
I double-checked Hyper-V and it turns out it was enabled/installed. So I removed this from "Turn Windows Features on or off" and I am now able to see these 64bit linux options.
VboxChimp
 
Posts: 1
Joined: 20. Oct 2013, 17:09

Re: Windows 8.1 and 64-bit Linux Guest

Postby Aladino80 » 2. Nov 2013, 09:03

Thank you,
I had the same issue after updating to Window 8.1 all the 64 bit are gone from the OS option list and i turned the Hyper-V off and that fixed it.
Thank you again.
Aladino80
 
Posts: 1
Joined: 2. Nov 2013, 09:00


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: butters and 20 guests