Page 2 of 3

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 9. Feb 2013, 22:01
by noteirak
mpack's steps are the only steps that will ever work.
The critical points are that your machine must be running and ready for USB connection (ie, you're on the desktop in the VM), and ONLY THEN, you plug your USB device.
You will see that on the Windows host, it will detect a Virtualbox USB device, and in the guest, it will actually see the proper device.
And of course, this must be done after you created the USB filter.

If you did these in the proper order, there is no reason for it not to work.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 9. Feb 2013, 22:15
by cattowerpro
There has to be a way for this to work. Like I ave said, I followed these directions to a Tee, and still it doesn't work. I am persistent and I do care about my equipment, but I don't really care about the software on it and I will change what ever I have to to complete this task. Maybe my equipment is too new I only have usb 3.0 ports although I have downgraded the hubs to 2.0. I will reconfigure some stuff and see what I come up with.

I really appreciate the help that you guys have givin' me you are awesome in my book. If I come up with anything, I will let you know.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 10. Feb 2013, 11:14
by mpack
Oh. You should have mentioned USB 3.0 right away, and mentioned that no USB devices work, not just this one wireless dongle. Last I heard, VirtualBox does not support USB 3.0 ports. Also, I'm not sure that plugging an extender (hub) into a USB 3.0 will help - I can't see why VirtualBox would care about that. VBox will care about driver stacks, host APIs and perhaps protocol changes.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 10. Feb 2013, 13:17
by cattowerpro
I probably would have mencioned that none of the other devices worked if that was the case, I have NO problems with any of my other usb devices. ALL usb pen (flash) drives work fine on both the hub and the 3.0 ports them selves. With and/or without filters no problems.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 10. Feb 2013, 13:38
by mpack
That's interesting, it's the opposite of what previous USB 3.0 users have reported - and it is still important info that would have been nice to know up front.

What about the wireless dongle itself? Is that USB 2.0 or USB 3.0?

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 10. Feb 2013, 17:36
by cattowerpro
i believe its 2.0 i read a lot about it and i couldn't find any info on it but people reported it opprating just fine on 2.0 systems

it uses rt2870/rt3070 Ralink Drivers and it picks up without drivers in the linux enviornment I am useing when I boot into it from startup without VB.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 15. Feb 2013, 05:28
by Facedesk
OP I've been having the exact same issue don't lose faith I'm struggling the same battle too! I've tried mpack's instructions too and I've tried a lot of other things with it and it hasn't worked at all. Just like you I have been hunting all over google and trying so many different things trying to get wifi readable within Backtrack 5 r3 as the guest operating system for both virtualbox and vmware. The error code is quite similar between virtualbox and vmware.

VB error says the USB adapter could not be connected to the guest machine because it is busy with a previous request.
VM error says the USB adapter could not be connected because it is currently in use with the host machine.

I believe the issue we are facing is not a VM issue or a VB issue.

I don't even think it's an issue with our USB adapters being compatible.

I think this issue has to do with my laptop factory image or laptop hardware. Because I was able to get my usb wireless to connect to a virtual machine of backtrack with VM on my Desktop Tower without trouble, but this does me no good for pen testing, I need to get this working preferable on my laptop, but It has been an impossible journey so far to get past this error code no matter what I've tried.

I am using a Asus ROG G75V laptop that I bought from Best Buy. The machine comes preloaded with a piece of shit proprietary windows 7 home edition with custom asus pre-installed software installed on it for hardware compatibility. I think something with this custom asus image or laptop hardware is causing this problem.

because of this hardware and image is asus proprietary I could not even load a clean install of windows onto a new SSD I bought to upgrade the laptop but ended as a constant failure when I tried. I was getting an error message that I was lacking some hardware drivers. It would not load a clean install even after I tried installing all the drivers from the Asus support site for my laptop. The only way I was able to get a working OS for my laptop was to back up the bestbuy factory image and load it to the SSD. I know this is a completely different issue. but it showed me that Asus has a complete lockdown on my machine making it practically impossible ( or just very SPAM_SEARCH difficult) to change my primary OS when I think that would be the way for me to test my theory to this problem. In my eyes it's become a problem above my skill level and it is embarrassing to say I own the Windows MCSA for configuring Windows 7 certificate...

I will keep tracking this thread hopefully I'm wrong and a solution is found. Till then I will be attempting to load backtrack onto a android tablet as an alternative and my research as shown that to be a fairly advanced project too.. I can't seem to win at getting a portable pen testing solution.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 15. Feb 2013, 05:44
by cattowerpro
Hey there, I am usually awesome with computer software. Also like you I am trying to get backtrack to work. I have been racking my brain and reading post after post and google, and bing, and everything else I can read. Ive been trying different things no matter how rediculous they sound. Ive just installed a new copy of windows 8, and a new virtualbox, with nothing but my antivirus and virtual box. still same problem. So I decided to try VMware workstation 9 today first day, works like a charm. Its a shame I really liked everything else about virtual box but I think its time to move on.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 13. Apr 2013, 08:59
by YourFriend
mpack wrote:"Busy with a previous request" always means that something else (i.e. the host) is already using the device, which basically can't happen if you followed the advice that should have been found by Googling:

  1. Install the extension pack.
  2. Enable USB and EHCI in the VM settings.
  3. Add a USB filter to match the device.
  4. plug the device in AFTER the VM has finished booting up, and say yes when prompted to allow the VBox USB driver to be installed on the host.
  5. Unplug and replug the device.

Hello all,

I just ran into this issue and think i might have found the missing step, that may work for the rest of us.......

To keep mpacks's list in order, I would place this step in-between 3 and 4.

- Open up Window's Device Manager, on the HOST, Expand the Tree that your Device is related to(in this case Network adapters), Right click on the Driver and Uninstall.
Also, if you have any 3rd party tools or driver software running on the HOST, please remove it or make sure the services and applications are not running.

On step 5, if unplugging and replugging the device doesn't do the trick, try Unplugging ALL the USB devices on the HOST, wait a few seconds and plug them back into the same ports they were pulled from.

Good Luck

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 13. Apr 2013, 11:36
by mpack
Doesn't make much sense I'm afraid. The device shouldn't even be plugged in before step 4, so why is it already detected and present in the hosts device list?

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 15. Aug 2013, 11:33
by perrrjantai
I had same problem with android phone. I have 3 USB ports in my laptop (HP Pavilion 15 Sleekbook), 2 of them are on the other side (these are having the issues VB not capturing my phone but giving host an access to it). Third USB port works like a charm and VB captures the device without giving host OS an access to it.

In short: Try different USB ports.

Hope this helps.. I think it's something to do with some USB controllers not fully compatible with VB.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 29. Oct 2014, 11:07
by Dave_Walker
Been using VirtualBox happily for around 3 years until last week. It's now October 2014 and I get this error when I upgraded to the latest version (currently 4.3.18).

Noe no would startup on my Win 7 - 64bit machine.

There's a fair amount of suggestions on this subject but nothing worked for me.

I eventually downgraded my install back to 4.3.12 and all was well.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 26. Feb 2015, 22:06
by Bernie W
I got this working simply by ejecting the USB device from the (Windows 8 ) host.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 6. Aug 2015, 13:57
by AZIDone
Hi to all...

I've also had this issue, not too sure why this happens but I only just got it working doing some diferent steps...

1. I removed the filter from VM "USB settings" to the host.

2. I disabled the network and bridge AP in the "NET settings". (EDIT: I now checked the settings and here I just left as usual, Bridge AP and the internal wireless option)

3. I plugged in my Atheros Alpha Wireless Card and let Windows 8 detect it.

4. Started my virtual Kali distro and logged in.

5. Once booted I used the option under the Device submenu at the top of the VM window, so it's: Device -> USB -> Atheros UB91C [0108]. NOTE: Here there was two times the wireless card name writen exactly the same, first one failed, second one didn't and I saw the wireless was detected using iwconfig command, you must see wlan0 in the result.

So right now it's up and working.

I have to say I only installed Kali yesterday and it gave me some headache to get it all working, I installed guestadditions and Oracle VM Virtualbox Extension Pack 5.0.0 (you should install the right extension pack depending on your VM version) to get the USB 2.0 EHCI working, in my case I could only use USB 1.0 before installing the extension pack. Some how it worked yesterday also, but when I tryed again today I could not get the Alpha Wireless Card to work... but after doing the steps mencioned above it's working fine.

EDIT STEP 2: Seams like I skiped this option, but I don't think it makes a big diference, at this moment I have two conections on VM Kali, wlan0 and eth0, everything working fine...

Anyway, hope someone finds this info usefull, if I find any other way to get it working I will post again.

All best to all.

Re: usb Result Code: E_INVALIDARG (0x80070057)

PostPosted: 30. Oct 2015, 09:46
by __grzegorz__
Good day,
Same issue here.
What helped me to find the solution is the fact, that the machine worked some time ago.
I returned to it after a month or so and the issue arised.

What has changed in the meantime? Maybe Windows Update cause all this?
Installed any software?
Yes, in the mean time I've installed some third party software for hardware port monitoring (including USB).
It was HardwareMonitoringStudio.
I uninstalled it, and all problems under VB were gone.

So, especially embedded system developers shall check for USB-port monitoring software, which seems to may collide with VB drivers for USB ports.

Hope it helps.