Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Discussions related to using VirtualBox on Windows hosts.

Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 22. Oct 2012, 19:01

After upgrading from 4.2.0 to 4.2.2 I have no more Virtualbox Hostonly Adapter.
If I try to add one manually I get "Failed to create the host-only network interface".
If I try to start the XP Virtualbox with network adapter in "Brideged mode" I get:

Failed to open a session for the virtual machine WindowsXP.
Failed to open/create the internal network 'HostInterfaceNetworking-Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

The only way to start my XP Virtualbox is to set netowrking in NAT mode, but I need more.

My host OS is Windows 7 professional SP1; guest OS is Windows XP SP3. All did work pretty good until upgrade.

Thank you in advance for your suggestions!
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby dj_palindrome » 23. Oct 2012, 06:22

An in-place, upgrade install from 4.2.0 to 4.2.2 on a Windows 7 x64 host produces the following:

"--Error Renaming Connection-- Cannot rename this connection. A connection with the name you specified already exists. Specify a different name."

Apparently there is a flaw in the installer script.

In addition to the 'Proxy' issue already reported, the Host-only Networks section of VirtualBox Settings is completely blank. VirtualBox Host-Only Network Adapter also disappears from host networking, which is left in some sort of funky error state (system-tray network-status icon has a red-'X' overlay).

The easiest way seems to just give up, uninstall VirtualBox 4.2.0, then install 4.2.2 into the original location.
An uninstall doesn't remove user settings, which are located at %userprofile%\.virtualbox.
dj_palindrome
 
Posts: 8
Joined: 1. Jun 2011, 20:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Knoppix, Debian, Windows XP

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 23. Oct 2012, 08:00

Thank you for your answer. I tried already to uninstall 4.2.2 and then go back to 4.2.0, but my network configuration did not get back to work. I tried also to go back to 4.1.18, no success either. I think something is definitely dirty with the registry. Is there a clean uninstall procedure, so that the registry go back to the state when no Virtualbox at all was installed? Or are there any well known registry entries that deal with virtualbox networking, that I could delete?
Thank you in advance
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 23. Oct 2012, 16:54

Really afraid that there's no real solution to this problem: I have been googling here and there for 2 days, but no one seems to have a solution, even if many people out there share the same frustrating issue.
Please do you really have no suggestion at all? :cry:
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby Perryg » 23. Oct 2012, 17:20

I would look in the preference section of VirtualBox and see if the host only adapter is there and configured properly. If not then add one and configure it to default.

See attachment for default settings:

host-only-1.png
host-only-1.png (25.24 KiB) Viewed 2230 times

host-only-2.png
host-only-2.png (28.41 KiB) Viewed 2230 times
Perryg
Site Moderator
 
Posts: 25937
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 23. Oct 2012, 17:35

As described in the original post, I cannot add a Host-only adapter manually, because I get the error "Failed to create the host-only network interface".
Thank you for your reply
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby Perryg » 23. Oct 2012, 17:43

Have you tried to remove VirtualBox (using the VirtualBox installer) and then installing it again making sure that all packages are set to install?
Perryg
Site Moderator
 
Posts: 25937
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 24. Oct 2012, 08:58

Hallo Perryg, thank you for your reply. I already tried that way, with and without Administrator privileges: no success. I tried also to install a Virtualbox adapter manually from the device manager by using the "Add legacy hardware" command and then pointing to the VirtualBox\drivers\network\netadp\ folder: no success (I get "Not enough system resources" failure message).
Really disappointed by what's happening, since, as I see, many people out there had this same issue in the past and are still having it: maybe I will give a try to VMWare, while waiting for the right suggestions or a patch from Oracle.
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby Perryg » 24. Oct 2012, 14:27

Ah system resources. Give this a try.
http://www.virtualbox.org/manual/ch12.html#idp19338672
Perryg
Site Moderator
 
Posts: 25937
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby pgmo » 25. Oct 2012, 08:53

Hallo PerryG, thank you for your valuable answer. Unfortunately I did as suggested in the manual excerpt you pointed out, but again with no success.
I'm thinking that Oracle must issue a new setup package, which is able to detect known errors and correct them. Otherwise there's no possibility at all to correct the problem.
pgmo
 
Posts: 7
Joined: 22. Oct 2012, 18:50

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby phearce » 7. Jan 2013, 03:46

I was experiencing similar trouble, and just posted a full explanation in topic #41437, "download vBox bridged network adaptor". Here's the key part:

Solution:
This is what worked for me -- YMMV.
  • Before each step, disable virus protection. After each step reboot.
  • Follow the instructions for increasing the net filters at the bottom of this thread: ticket/7040.
    Code: Select all   Expand viewCollapse view
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters
    I bumped this number up to 32.
  • In Device Manager, select 'View Hidden Adapters', and delete all of the "Unknown device" network adapters
  • Uninstall VB
  • In Device Manager, delete any remaining (hidden) network adapters with the word "VirtualBox" in their title
  • Critical step: In Control Panel/Network and Internet/Network Connections right-click on Network Bridge and open properties. Under 'Adapters' de-select everything. Apply, OK, close
  • Install VB (leave the default selection, which is everything)
phearce
 
Posts: 2
Joined: 6. Jan 2013, 18:09
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: windows, ubuntu

Re: Upgrade 4.2.0 to 4.2.2: Virtualbox Hostonly Adapter lost

Postby Guaracy » 18. Feb 2013, 23:41

Hi,
Did someone had this problem fixed? It appears to me when I tried to upgrade from 4.2.2 to 4.2.8 and I did try everything and nothing works I keep not been able to create host-only adapter.

Well I think I'll have to migrate to WMware.

Cheers,
Guaracy
 
Posts: 1
Joined: 18. Feb 2013, 23:39


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 27 guests