shared folders not seen

Discussions about using Linux guests in VirtualBox.

shared folders not seen

Postby himagain » 23. Jul 2012, 07:31

Hi there people,
https://forums.virtualbox.org/viewtopic ... 29&t=15868 Been there (for some dark reason, most support answers want you to use the cmd line - should be unnecessary in 2012) and looked also in search - literally hundreds of non-answers, so, I'll try to be clear here: :?
I'm using Ubuntu as a guest on a W7 Box. (I use specific W7 programs like Dragon talk-2-text which oddly work in Linux but not the other way around, so... ) :-)
I HAVE read the docs, I have re-installed multiple times with varying setup situations and verified the Guest Additions install.
I think I'm missing something fairly simple here and it is probably Directory related. (Wish I could work out how to copy and post the actual setup here) :
I've nominated two locations as Shares:
W7 Box:
D:
D:\VBOXSHARED (in caps)

Ubuntu:
Both as automounted and full access. (As per the simple options)

AS per the docs, two new Dirs, same names, prefaced with sf_DRIVE_D and sf_VBOXSHARED in HOME/DOCUMENTS

----------------------------------------------------
I have tried variations on the above locations with no results - and am still unsure how to allow W7 access to Ubuntu files.
I am using a common files program, LibreOO, which has identical structure in both Systems.
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby mpack » 23. Jul 2012, 10:40

I should warn you that "D:" is a drive letter, not a folder specification. If you had intended to indicate the root folder then the proper designation should have been "D:\".

I don't really know what you're doing with the "sf_xxxx" prefixes in Ubuntu: the network share name is given in the VM shared folder setup, you don't (AFAIK, not being a Linux expert) rename the shares inside the guest OS. Typically the share name should be kept simple: "Examplename" - note capitalised first letter but otherwise no mixing of case, nothing but roman characters (no '_'), moderate length.

It also probably isn't a good idea to share the root folder of any host drive.
mpack
Site Moderator
 
Posts: 29832
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: shared folders not seen

Postby Perryg » 23. Jul 2012, 14:40

The sf_ is the /media/sf_<sharename> of an auto-mount and you should not use auto-mount period in a Linux guest. It may be fine for basic share to get a file to the guest but the permissions will be torked.

Manually mount the shared folder and yes it is best to do so at the command line.

This should help Howto: Install Linux Guest Additions

Pay attention to the mount switches -o rw,......
These will set the permission level of the shared folder.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: shared folders not seen

Postby himagain » 24. Jul 2012, 00:57

mpack wrote:I should warn you that "D:" is a drive letter, not a folder specification. If you had intended to indicate the root folder then the proper designation should have been "D:\".

I don't really know what you're doing with the "sf_xxxx" prefixes in Ubuntu: the network share name is given in the VM shared folder setup, you don't (AFAIK, not being a Linux expert) rename the shares inside the guest OS. Typically the share name should be kept simple: "Examplename" - note capitalised first letter but otherwise no mixing of case, nothing but roman characters (no '_'), moderate length.

It also probably isn't a good idea to share the root folder of any host drive.

Hi Mpack,
I did intend in desperation testing to allow access to ANYTHING just to get it to work.... hence D: not just root.
Naming seems to be my problem here - the internal docs for VBox do say to prefix the local Shared folder with "sf_ " ???

I always avoid the CMD line if any alternative is available and today, most systems are now EUF (END User Friendly) and the internal Vbox options do allow for an automatic setup. I'm obviously missing the obvious here - understanding how to designate and where - a file to be shared between the two systems.
AFAIK the Shared Directories/folders simply have to exist on the Host System and the guest is told where they are. Permissions might be another ballgame............

THanks for your help,
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby himagain » 24. Jul 2012, 01:18

Perryg wrote:The sf_ is the /media/sf_<sharename> of an auto-mount and you should not use auto-mount period in a Linux guest. It may be fine for basic share to get a file to the guest but the permissions will be torked.

Manually mount the shared folder and yes it is best to do so at the command line.

This should help Howto: Install Linux Guest Additions

Pay attention to the mount switches -o rw,......
These will set the permission level of the shared folder.


Hi Perry,
I just went and looked at that post - Migod! It's like the worst of the bad old days of Linux! :shock: THat would take a lot of study on my part - and all I want to do is a vanilla install. E.G. On a forum i run elsewhere, it is embarrassing to note that other users have simply followed the book and are up and running - that's how I came back to give Linux/Vbox another try - the new Ubuntu is very close to the real world (the other 99.99999% of us) :D
My problem here is specific to VBox.
Everything else is great - all like clockwork and very EUF.
Guest additions and rest of setup clockwork easy - all just GUI driven. (This is the sixth re-install trying to find the answer to a simple problem of pointing....)

I know that as soon as I get this "wood-4-the-trees" thing fixed I will be a real evangelist to save the world from Windoze and that Other Thing. :-)

Thanks and Cheers!
Himagain
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby Perryg » 24. Jul 2012, 01:42

Shoot its not that bad.

Say you share something and called it share

In the guest terminal you simply type the following.

First create the mount point
Code: Select all   Expand viewCollapse view
sudo mkdir /mnt/share

Mount the share
Code: Select all   Expand viewCollapse view

sudo mount -t vboxsf -o rw,uid=1000,gid=1000 share /mnt/share

Heck even copy and paste the commands, it couldn't be easier than that.
Now if you want this to be permanent you add the mount statement to /etc/rc.local

I guarantee if you continue to use the auto-mount you will have nothing but problems due to permissions.
Besides if you learn something what's the hurt? I or just about any real Linux user here can help you if you have an issue.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: shared folders not seen

Postby himagain » 24. Jul 2012, 05:23

Perryg wrote:Shoot its not that bad.

Say you share something and called it share

In the guest terminal you simply type the following.

First create the mount point
Code: Select all   Expand viewCollapse view
sudo mkdir /mnt/share

Mount the share
Code: Select all   Expand viewCollapse view

sudo mount -t vboxsf -o rw,uid=1000,gid=1000 share /mnt/share

Heck even copy and paste the commands, it couldn't be easier than that.
Now if you want this to be permanent you add the mount statement to /etc/rc.local

I guarantee if you continue to use the auto-mount you will have nothing but problems due to permissions.
Besides if you learn something what's the hurt? I or just about any real Linux user here can help you if you have an issue.


Hi Perry,
It DID seem easy when I realised that you could C&P into a terminal! (Not in my day - last century). Naturally, it worked both ways :D
BUT.............. :(
-----------------------------------------
him@him-VirtualBox:~$ sudo mount -t vboxsf -o rw,uid=1000,gid=1000 share /mnt/share
[sudo] password for him:
/sbin/mount.vboxsf: mounting failed with the error: Protocol error
him@him-VirtualBox:~$
-------------------------------------------------------
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby himagain » 24. Jul 2012, 06:16

Hi Perry,
BTW: On looking to add the info to the rc.local file, I found two others already there of the same name??.
Also: tried to delete the last two folders I manually installed by SF_ prefixed names and can't access them now as I "Do Not Have Permissions" to do so.

While in the Linux Guest: to select directories to add to Share, the selection is to the Windoze Drives.

Yes, it REALLY should be a simple painless matter......... but :?

Cheers!
Himagain
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby mpack » 24. Jul 2012, 10:41

Hmm. It's clear that this discussion is about configuration of a Linux Guest, and nothing much at all about being on a Windows host. Hence, moving this to "Linux Guests".
mpack
Site Moderator
 
Posts: 29832
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: shared folders not seen

Postby himagain » 24. Jul 2012, 11:53

mpack wrote:Hmm. It's clear that this discussion is about configuration of a Linux Guest, and nothing much at all about being on a Windows host. Hence, moving this to "Linux Guests".

OK - but it *IS* about being on a Windoze Host - most of the discussions I'm having with people is about the fact that hardly anyone has a Windows Host Linux Guest it seems.

Cheers,
Himagain
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby Perryg » 24. Jul 2012, 14:19

The protocol error means something is not right.
Did you remember to use the VirtualBox shared folder wizard to create the share and did you make sure the share *name* was called share? No spaces, characters, and Linux is case sensitive so watch those.

As for the rc.local file, you need to edit it as sudo.
Code: Select all   Expand viewCollapse view
sudo gedit /etc/rc.local


Remember sudo. It elevates your user to admin status to be able to work with privileged commands.

By the way mpack is right. This is a guest issue. No one cares if you use Windows or not, just the combination so as to be able to help.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: shared folders not seen

Postby himagain » 25. Jul 2012, 00:02

Perryg wrote:The protocol error means something is not right.
Did you remember to use the VirtualBox shared folder wizard to create the share and did you make sure the share *name* was called share? No spaces, characters, and Linux is case sensitive so watch those.

As for the rc.local file, you need to edit it as sudo.
Code: Select all   Expand viewCollapse view
sudo gedit /etc/rc.local


Remember sudo. It elevates your user to admin status to be able to work with privileged commands.

By the way mpack is right. This is a guest issue. No one cares if you use Windows or not, just the combination so as to be able to help.


Hi Perry,
I really DO appreciate the help here - and my point about posting under "Windows" was basically whether it could be a problem on its own .... :-{

The code I used was exactly as you gave it to me - thankfully, a C&P! :-)

Here might also be one of my problems: I want Ubuntu to be able to access Drive D:\DOCS on the Host.
So, in the Wizard setup ( which only searches the Host, I selected this existing directory) and accepted the default actions.
Then, I'm unclear as to how/where to access those files in Ubuntu - the help files do offer alternative locations, but for now I'd be happy with defaults - if I knew where they went! :-)

Cheers,
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby Perryg » 25. Jul 2012, 00:11

Ok if you look at the shared folders settings for the guest you should see that you have shared a folder.
What is the Folder Name? (Be specific)
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: shared folders not seen

Postby himagain » 25. Jul 2012, 00:41

Perryg wrote:Ok if you look at the shared folders settings for the guest you should see that you have shared a folder.
What is the Folder Name? (Be specific)


D:\DOCS
DOCS
Auto mount
Full Access
Permanent
himagain
 
Posts: 15
Joined: 3. Jul 2012, 03:09

Re: shared folders not seen

Postby Perryg » 25. Jul 2012, 00:49

Well if your are determined on using auto mount you will find them in /media/sf_DOCS.
Just remember that asking for any help regarding permission issues isn't going to go well.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Next

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 11 guests