Increasing VDI file size destroyed my NAT

Discussions related to using VirtualBox on Windows hosts.

Increasing VDI file size destroyed my NAT

Postby btrakd » 4. Jul 2012, 06:40

Alfa card AWUS036H
Modem
Internal wireless card
Virtual Box 4.1.6
BT5 Virtual Box
XP host



Virtual box settings
- Adapter1: NAT->AdapterName: Blank->Adapter type: Intel PRO/1000 MT Desktop (82540EM)
I have three BT5 VM's installed in VBox. Two have small virtual drives (under 10 gig)
NAT works fine and Alfa can be enabled/disabled with out effecting NAT (as long as
Alfa is disable NAT works); the third VM giving me NAT problems has been migrated to a
larger drive on a different partition. Migration seemed to go fine, and BT5 was able
to function flawlessly, except that NAT will not work. Somewhere between starting the
bigger BT5 VBox and running aircrack, a new 'Virtual Box Host-Only Network' adapter
(Virtual Box Host-Only Network#2)appeared within XP host.
ifconfig on VBoxes that have functional NAT display eth0 AND lo (local loopback), but
on the broken VBox ifconfig only shows lo. :shock: i suspect re-enabling eth0, will solve the problem or the the virtualbox host only network adapter must be recreated to work with the moved VM. eth0 is what i want on my broken VBox, how do i get eth0??? How do i find out which adapter is being used by which VBox? Thanks for time reading my problem.

ps:I used HDClone and have already tried root@bt:~# ifconfig eth0 up
btrakd
 
Posts: 3
Joined: 4. Jul 2012, 06:21

Re: Increasing VDI file size destroyed my NAT

Postby Frank Mehnert » 4. Jul 2012, 09:45

I don't use HDClone but did that tool change the VDI image ID by any chance? Have a look into /etc/udev/rules.d and search for a rule 70-persistent-net.rules. If this rule exist, delete it and reboot the guest. See here.
Frank Mehnert
Oracle Corporation
 
Posts: 2523
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Lenny
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Increasing VDI file size destroyed my NAT

Postby mpack » 4. Jul 2012, 12:27

IMHO, this question is improperly posed. Almost no details of host or guest given, and no log provided.

Before we all head down the garden path, @btrakd, please see :-

Minimal information needed for assistance
https://forums.virtualbox.org/viewtopic ... 24&t=48476

In particular, please provide the latest VM log, as a zipped attachment please.
mpack
Site Moderator
 
Posts: 13199
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Increasing VDI file size destroyed my NAT

Postby btrakd » 10. Jul 2012, 02:23

Frank Mehnert wrote:I don't use HDClone but did that tool change the VDI image ID by any chance? Have a look into /etc/udev/rules.d and search for a rule 70-persistent-net.rules. If this rule exist, delete it and reboot the guest. See here.


Frank - a big thank you - you were spot on !! :D I had 6 eth# entries in 70-persistent-net.rules. I deleted all but one, renamed it eth0 and rebooted. NAT returns !! Thank you for helping new guy-have a nice day

p.s. when applying the fix noted above ensure you are keeping the entry whose MAC address matches the MAC displayed in 'Virtual Box Manager' NAT adapter settings for your particular machine. i.e. Check Virtual Box Manager, note MAC address being used for NAT, THEN boot VM. -> Then keep entry in 70-persistent-net.rules with matching MAC, changing "Name="eth(?)" to Name="eth0"

Also make sure your NAT "adapter type" in Virtual Box Manager is set to Intel PRO/1000 T Server (other adapter types are known to create NAT problems if selected)
btrakd
 
Posts: 3
Joined: 4. Jul 2012, 06:21


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 33 guests