VBoxTestOGL.exe has stopped working?

Discussions related to using VirtualBox on Windows hosts.

VBoxTestOGL.exe has stopped working?

Postby gabam » 30. Jan 2012, 16:49

Hi friends,
I hope u guys are fine and doing well. I am constantly getting this error message whenever I run Virtualbox.
Code: Select all   Expand viewCollapse view
VBoxTestOGL.exe has stopped working

Code: Select all   Expand viewCollapse view
Check online for a solution and close the program.

Code: Select all   Expand viewCollapse view
Close the program.


Code: Select all   Expand viewCollapse view
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   VBoxTestOGL.exe
  Application Version:   0.0.0.0
  Application Timestamp:   4eef31e7
  Fault Module Name:   aticfx64.dll
  Fault Module Version:   8.17.10.1047
  Fault Module Timestamp:   4cabd6c0
  Exception Code:   c0000005
  Exception Offset:   000000000002f5bf
  OS Version:   6.1.7601.2.1.0.768.3
  Locale ID:   1033
  Additional Information 1:   336d
  Additional Information 2:   336d92dbe63a546ae0908c4e08d6d8f6
  Additional Information 3:   6bb3
  Additional Information 4:   6bb35966a774e57730cac2f2c3e787b2

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


But the program is working fine, and all my virtual systems seem to work ok. Could you please tell me whether this error is normal. Or is there some serious issue, and how to get rid of this error message? One thing that is bothering me is that my NAT is not working under Solaris guest, I wonder if this has anything to do with this error. Please help me with this issue. I am using 64-bit version of Windows 7 Home Premium, on a Toshiba Laptop with core i3 CPU and 6GB RAM.
Looking forward to your kind replies.
Thanks in advance!
gabam
 
Posts: 14
Joined: 21. Jul 2011, 20:33
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: FreeBSD

Re: VBoxTestOGL.exe has stopped working?

Postby smb77 » 15. Feb 2012, 19:50

I'm seeing the same error dialog.

VirtualBox is version is 4.1.8 GUI, but had seen the problem under ver 4.0.x and upgraded hoping to clear the issue. I also have extension pack 4.1.8 installed.

Host machine is a Dell Latitude E6410, Core i5, 4GB, WIN XP SP3. Once I click 'close,' on the dialog box, VirtualBox appears to start normally. Multiple guest operating systems, including WIN XP, Win 7, and Fedora Linux seem to run normally using NAT.

Thanks for your time.
smb77
 
Posts: 1
Joined: 15. Feb 2012, 19:33

Re: VBoxTestOGL.exe has stopped working?

Postby glide3 » 7. Jul 2012, 13:01

Hi

Same or similar problem here

"VBoxTestOGL.exe has stopped working" after a fresh install of Windows 7 64 bit running on the following new laptop I just purchased.

WROST OF ALL: Virtual box loads, but so so so slowly. It takes at least 1 minutes or more for it to start. From what i can tell its the VBoxTestOGL.exe process sitting there and holding it up with 0% cpu usage. On my other laptop it takes like 3 seconds to start and you don't even get to see the VBoxTestOGL.exe process.
I suspect the "VBoxTestOGL.exe" process checks for compatibility with some or many drivers probably something to do with GFX or Open Graphics Library.
If I end the "VBoxTestOGL.exe" process twice then VirtualBox.exe loads much quickly ... or straight after. :(

system specs:
Dell 17 inch XPS (L702x)
Intel i7-2760QM 2.40GHz
8 gig ram
SSD - ADATA 256 gig S900x, second hard drive 5400 rpm seagate
Nvidia 3 gig gfx card with 3D glass and all that other junk that I will never use
Windows 7 pro - 64 bit
Virtual Box version: 4.1.18 r78361

I have tried the following with no solution yet.
1) Reinstalled oracle virtual box, in Admin mode also. A few times, and even used ccleaner and manual removal of left over files and registry values.
2) Disabled my 3D graphics card aka "NVIDIA stereo controller" (noticed the name after uninstalling all nvidia related 3d drivers) two of them
3) Added a NVIDIA custom "manage 3d settings" for the vboxtestogl.exe file and set everything to compliant or optimal performance. I could definately play here more but i suspect this isn't the solution. Although I noticed other forums with similar issues and ATI cards ... hence my idea in this area.
4) Disabled my nvidia 4 x high def sound devices, although the actual sound card is a realtek ... which i sweird
5) Will continue to try other things, disable other drivers etc. Wish I had the time to reinstall the OS and slowly test VirtualBox as I install drivers etc.

I noticed that while playing with some of the NVIDIA settings for that OGL app the same "VBoxTestOGL.exe has stopped working" occurred recursively until I killed it.

As I said a sucky solution to getting it to start faster is to toast / kill the vboxOGL process x 2. But this is just not fun as it needs to be

Regards
Rory / Glide3
glide3
 
Posts: 3
Joined: 7. Jul 2012, 12:27

Re: VBoxTestOGL.exe has stopped working?

Postby glide3 » 7. Jul 2012, 13:46

Forgot to post the error

Problem signature:
Problem Event Name: APPCRASH
Application Name: VBoxTestOGL.exe
Application Version: 0.0.0.0
Application Timestamp: 4fce11da
Fault Module Name: nvoglv64.DLL
Fault Module Version: 8.17.12.8577
Fault Module Timestamp: 4eb2dddc
Exception Code: c0000005
Exception Offset: 00000000008c8e72
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 7177
Additional Information 1: f69c
Additional Information 2: f69c8d47212dfd75b3c9579973765e30
Additional Information 3: 17a4
Additional Information 4: 17a4819665fd5754f351077cf7f24a6a


So we have
1) VBoxTestOGL.exe - crashing and slowing things down
2) nvoglv64.DLL - as mentioned in the above error. Further reading suggests this is the NVIDIA Compatible OpenGL ICD
3) ATI users having similar issues in other virtualbox forums, but I feel alone in the NVIDIA circle :(
4) nvoglv32.dll also mentioned in some cases. Therefore this might involve 32 bit and or 64 bit versions
5) I see the first poster has a ATI graphics card from the "aticfx64.dll" :( where I have NVIDIA but its a 64 bit version :) yay

thoughts
1) So I suspect we need smart people to tell us what to disable that is graphics related that will get this OGL to be happy and faster / stable.
2) Is OGL = OpenGL. As in the old school opposition to Direct3D.
3) As far as I know, directx / direct3d comes with OPENGL / OGL support
4) Win 7 comes with Directx 11 as far as I know, so maybe we need to install Directx 8, 9 or 10? (to solve the issue)

Will keep hunting
Rory
glide3
 
Posts: 3
Joined: 7. Jul 2012, 12:27

Re: VBoxTestOGL.exe has stopped working?

Postby glide3 » 7. Jul 2012, 14:37

My problem SOLVED :) yay

So this won't be helping ATI people :( sorry. (unless someone can try the solution and verify)

All I did was update my NVIDIA drivers from 285 to 301.42 (latest as of 2012-07-07). I assume this updates openGL as well. I also told it to do a "clean install" checkbox offered on page 2 or so of the install process. I even let it fully install my 3D stuff and didn't make one change.

So to me my previous 3D idea was way off. Probably just a NVIDIA / ORACLE (VirtualBox) OpenGL issue that NVIDIA have somehow solved/hidden/bypassed or whatever.

Virtual box now starts in seconds again instead of minutes. That OGL process must have happy.
I never even reinstalled Oracle VirtualBox after the NVIDIA update, but I did restart.

So ones question might be why the heck didn't you do a NVIDIA update from the start ... its so obvious. Answer to that is I have a dell. Historically (my last 3-4 dell laptops) Dell and or NVIDIA have NEVER allowed me to update my laptop graphics card drivers.
NVIDIA would say that Dell would offer the best support for drivers for my laptop and hence whatever version I downloaded from their website just wouldn't install. AND DELL .... they almost never update the GFX drivers for NVIDIA and or ATI on their website more than once.
So maybe since this is my first XPS (their "media" / "gaming" laptop range) I have joined the ranks of Dell users that are "allowed" to download NVIDIA drivers direct from NVIDIA and dell.... with a nice warning from the NVIDIA website that dell might not like me using this newer drivers due to support issues.

I can understand dell wanting a small subset of NVIDIA drivers out there on their laptops for support reasons but I'm sure laptop gamers want the latest GFX edge and hence the latest NVIDIA and ATI game optimized drivers. But then they need to at least now and again update the drivers on the dell support site while that product is still being sold around the world. The same goes for other manufacturers.

And in my case drivers that actually solve a VirtualBox open GL issue.

Might sound obvious but ATI uses should also just update their drivers, hold thumbs, and then query ATI/AMD and Oracle for fixes there after. Or their laptop manufacturer to update their drivers.

hope this helps someone.
Rory
glide3
 
Posts: 3
Joined: 7. Jul 2012, 12:27

Re: VBoxTestOGL.exe has stopped working?

Postby JT » 14. Jan 2013, 21:57

After upgrading my laptop from Windows 7 to Windows 8, I am also getting this error each time a I launch the Virtual Box Manager window or start a virtual machine. Other than the nuisance of needing the close the error message every time, things work as expected.

My laptop has a rather basic graphics processor (Intel 945 Express Chipset with the default drivers provided by Microsoft with Windows 8 Pro RTM). I don't expect this card to be able to provide much if any acceleration benefit (most of my VMs are console based *nix systems anyway). However, it would be nice to have an option to permanently disable this test for the entire host system and assume that the features its checking for are not available if the test is not run to get rid of the error message every time I need to open a new window.
JT
 
Posts: 1
Joined: 14. Jan 2013, 21:45


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Poci and 38 guests