Page 26 of 29

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 19. Aug 2014, 04:25
by mm_half3
Hello,

I have two virtual systems being started up using VBoxVmService. One of them is set to mount a file system from the other at boot time, and I would like to delay the startup of the one that mounts the file system, until the other system completes its boot sequence. Can this be done in VBoxVmService.ini? If not will probably just use an at job to mount it.

Thanks,

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 19. Aug 2014, 15:37
by AnrDaemon
If second VM is a Linux guest (or close enough to it), you can use _netdev flag on networked file system to indicate what it is. It'll postpone mounting until that guest boot up the network stack, but won't solve a race condition in startup times of both VM's.
What it would help, though, is that you'd be able to narrow the scope of your remounting cron job to only those filesystems with _netdev flag.
More details are available in man mount.

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 20. Aug 2014, 21:24
by mm_half3
AnrDaemon wrote:If second VM is a Linux guest (or close enough to it), you can use _netdev flag on networked file system to indicate what it is. It'll postpone mounting until that guest boot up the network stack, but won't solve a race condition in startup times of both VM's.
What it would help, though, is that you'd be able to narrow the scope of your remounting cron job to only those filesystems with _netdev flag.
More details are available in man mount.



Thanks for the response, was already using the_netdev flag in the systems fstab file, thought it would prevent problems. Using the cron with a two minute delay after boot is working nicely.

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 11. Oct 2014, 02:29
by Docfxit
I really like the way VBoxVMService starts with no other windows showing during startup. I'm trying to get one program showing without the guest desktop showing. I have the one program automatically starting in the guest. Does anyone know how to show just the one program that is running on the guest?

I know I can use:
VBoxManage.exe startvm XPVirtualMachine -type GUI
But it shows:
1. The cmd window since it's started from a bat file.
2. The Oracle VM VirtualBox window.
3. The Windows startup screen.

Host Win7
Guest XP Pro

Thank you,

Docfxit

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 15. Oct 2014, 23:42
by Docfxit
Is it possible to use VBoxVMService with Seamless instead of VBoxHeadless?

Or does anyone know how to run VirtualBox seamless in a service?

Thank you,

Docfxit

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 23. Oct 2014, 01:31
by Docfxit
I am trying to get VirtualBox to stay running as a service. I can't use VBoxVMService because it runs headless and I would like to run seamless. I'm wondering if anyone here knows why VirtualBox won't stay running. I'm using a program called AlwaysUp to run it as a service. I have contacted there support and they say it's a VirtualBox problem. I have started a thread for VirtualBox and they won't advise me of why it's crashing because it wasn't designed to be run as a service. I am logging on with the same user VirtualBox was created with. I'm not getting any user messages when it starts.

Any ideas on how to figure out why VirtualBox is crashing would be great.

Host: Win7 sp1 64bit
Guest: XP Pro sp3 32bit
Antivirus: Bitdefender
Firewall: ZoneAlarm

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 25. Oct 2014, 18:02
by Docfxit
It appears a post is rarely answered in this thread. I discovered a post will be answered in a more timely manner at:

https://sourceforge.net/p/vboxvmservice ... Ginger%29/

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 11. Jul 2015, 07:40
by FB2000
VBoxVmService 5.0 - Codename: "Litchi" has arrived.

Read the announcement here:

LINK: https://forums.virtualbox.org/viewtopic.php?f=6&t=8595&p=327786#p327786

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 13. Jul 2015, 10:33
by oper
New "Litchi" on 32-bit Windows 2003 server displays: "VBoxVmService.exe is not a valid Win32 application". Do I need some additional libraries to be installed? Can you please help?

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 1. Aug 2015, 07:17
by Nija
Hi, I have installed oracle virtualbox 4.3.20 96997. Please share the link for download extension pack of the same release .

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 28. Nov 2015, 13:44
by Lino
Hi.
Please explain whether it is possible to use Virtual Box for old 3D-graphic (FPS, TPS, еtс.) games on a guest WinXP?
I installed DirectX-extension from iso. But almost all the old games do not recognize "virtualbox graphics adapter" as 3D video-adapter and do not run.
Native Nvidia driver for WinXP is not installed ("not found hardware").

Tell me, is there a general solution?

Host system Win 10 x64, 660 Geforce card.
Sorry my English.

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 3. Dec 2015, 12:15
by LilooJedi
Hi,

First, thanks for your tool, it's very useful.

Second, I have 2 evolution requests.
One: it would be nice to have an 'end-of-action' notification with the VmServiceTray (in the way of the USB notifications for example) so that the user knows that VmBoxService is started or Vm0 is stopped.
Two: along with the start and stop, it would be convenient to be able to take a snapshot.

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 30. Dec 2015, 23:13
by kalelreturns
I'm running several vm clones. I tried using this but it seems to only start up the original vm and cant find the clone vms. Is there a solution for this?

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 16. Jan 2016, 18:10
by ComputerJay
Hello.

This is a very useful tool.

It seems that the main VirtualBox GUI and VBoxVMService do not share save states.

Is this correct?

Thanks

Re: [VBoxVmService] -> Discussion & Support

PostPosted: 16. Jan 2016, 19:27
by kalzimin
VBox.log
Log file
(99.36 KiB) Downloaded 47 times
Hi guys,
I am facing a real issue with VMs right now. I'm using a PC
VBox.log
Log file
(99.36 KiB) Downloaded 47 times
dual core 4 GB RAM win7 x64, VM is Win7 x86 4.3.12, extension pack installed, VM created, shutdown perfect. But when I wanted to start it again, it sends me 2 error messages:
Échec de l'ouverture de session pour la machine virtuelle Abutu.

Failed to assign the machine to the session (E_FAIL).

Code d'erreur : VBOX_E_VM_ERROR (0x80BB0003)
Composant : Machine
Interface : IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
Code retourné : E_FAIL (0x80004005)

and

Échec de l'ouverture de session pour la machine virtuelle Abutu.

The VM session was aborted.

Code d'erreur : E_FAIL (0x80004005)
Composant : SessionMachine
Interface : ISession {12f4dcdb-12b2-4ec1-b7cd-ddd9f6c5bf4d}

here is the log file
.